当前位置:网站首页>POJ 2208 six lengths of tetrahedron are known, and the volume is calculated
POJ 2208 six lengths of tetrahedron are known, and the volume is calculated
2022-07-06 18:25:00 【Full stack programmer webmaster】
Hello everyone , I meet you again , I'm the king of the whole stack .
Pyramids
Time Limit: 1000MS | Memory Limit: 65536K | |||
---|---|---|---|---|
Total Submissions: 2718 | Accepted: 886 | Special Judge |
Description
Recently in Farland, a country in Asia, a famous scientist Mr. Log Archeo has discovered ancient pyramids. But unlike those in Egypt and Central America, they have triangular (not rectangular) foundation. That is, they are tetrahedrons in mathematical sense. In order to find out some important facts about the early society of the country (it is widely believed that the pyramid sizes are in tight connection with Farland ancient calendar), Mr. Archeo needs to know the volume of the pyramids. Unluckily, he has reliable data about their edge lengths only. Please, help him!
Input
The file contains six positive integer numbers not exceeding 1000 separated by spaces, each number is one of the edge lengths of the pyramid ABCD. The order of the edges is the following: AB, AC, AD, BC, BD, CD.
Output
A real number — the volume printed accurate to four digits after decimal point.
Sample Input
1000 1000 1000 3 4 5
Sample Output
Find the height of the tetrahedron according to the edge , Then calculate by formula .
Code :
/* ***********************************************
Author :_rabbit
Created Time :2014/5/9 21:32:01
File Name :5.cpp
************************************************ */
#pragma comment(linker, "/STACK:102400000,102400000")
#include <stdio.h>
#include <iostream>
#include <algorithm>
#include <sstream>
#include <stdlib.h>
#include <string.h>
#include <limits.h>
#include <string>
#include <time.h>
#include <math.h>
#include <queue>
#include <stack>
#include <set>
#include <map>
using namespace std;
#define INF 0x3f3f3f3f
#define eps 1e-8
#define pi acos(-1.0)
typedef long long ll;
double volume(double a,double b,double c,double d,double e,double f){
double a2=a*a,b2=b*b,c2=c*c,d2=d*d,e2=e*e,f2=f*f;
double tr1=acos((c2+b2-f2)/(2*b*c));
double tr2=acos((a2+c2-e2)/(2*a*c));
double tr3=acos((a2+b2-d2)/(2*a*b));
double tr4=(tr1+tr2+tr3)/2;
double temp=sqrt(sin(tr4)*sin(tr4-tr1)*sin(tr4-tr2)*sin(tr4-tr3));
return a*b*c*temp/3;
}
int main()
{
//freopen("data.in","r",stdin);
//freopen("data.out","w",stdout);
double a,b,c,d,e,f;
while(cin>>a>>b>>c>>d>>e>>f)printf("%.4f\n",volume(a,b,c,d,e,f));
return 0;
}
Copyright notice : This article is an original blog article . Blog , Without consent , Shall not be reproduced .
Publisher : Full stack programmer stack length , Reprint please indicate the source :https://javaforall.cn/117405.html Link to the original text :https://javaforall.cn
边栏推荐
- Compilation principle - top-down analysis and recursive descent analysis construction (notes)
- Insert dial file of Jerry's watch [chapter]
- Introduction to the usage of model view delegate principal-agent mechanism in QT
- 1700C - Helping the Nature
- Tree-LSTM的一些理解以及DGL代码实现
- Jerry's watch reading setting status [chapter]
- Distiller les connaissances du modèle interactif! L'Université de technologie de Chine & meituan propose Virt, qui a à la fois l'efficacité du modèle à deux tours et la performance du modèle interacti
- STM32+ESP8266+MQTT协议连接OneNet物联网平台
- [Android] kotlin code writing standardization document
- Introduction and case analysis of Prophet model
猜你喜欢
Jerry is the custom background specified by the currently used dial enable [chapter]
The third season of Baidu online AI competition is coming in midsummer, looking for you who love AI!
[Android] kotlin code writing standardization document
【Swoole系列2.1】先把Swoole跑起来
Why does wechat use SQLite to save chat records?
推荐好用的后台管理脚手架,人人开源
44所高校入选!分布式智能计算项目名单公示
Virtual machine VirtualBox and vagrant installation
Splay
Ms-tct: INRIA & SBU proposed a multi-scale time transformer for motion detection. The effect is SOTA! Open source! (CVPR2022)...
随机推荐
1700C - Helping the Nature
A method of sequentially loading Unity Resources
STM32+MFRC522完成IC卡号读取、密码修改、数据读写
Open source and safe "song of ice and fire"
Jielizhi obtains the currently used dial information [chapter]
测试1234
I want to say more about this communication failure
阿里云国际版ECS云服务器无法登录宝塔面板控制台
44所高校入选!分布式智能计算项目名单公示
Recommend easy-to-use backstage management scaffolding, everyone open source
Transport layer congestion control - slow start and congestion avoidance, fast retransmission, fast recovery
小程序在产业互联网中的作用
关于这次通信故障,我想多说几句…
2022暑期项目实训(一)
【Swoole系列2.1】先把Swoole跑起来
Compilation principle - top-down analysis and recursive descent analysis construction (notes)
2019 Alibaba cluster dataset Usage Summary
Comparative examples of C language pointers *p++, * (p++), * ++p, * (++p), (*p) + +, +(*p)
celery最佳实践
Maixll-Dock 摄像头使用