当前位置:网站首页>POJ 2208 six lengths of tetrahedron are known, and the volume is calculated
POJ 2208 six lengths of tetrahedron are known, and the volume is calculated
2022-07-06 18:25:00 【Full stack programmer webmaster】
Hello everyone , I meet you again , I'm the king of the whole stack .
Pyramids
Time Limit: 1000MS | Memory Limit: 65536K | |||
---|---|---|---|---|
Total Submissions: 2718 | Accepted: 886 | Special Judge |
Description
Recently in Farland, a country in Asia, a famous scientist Mr. Log Archeo has discovered ancient pyramids. But unlike those in Egypt and Central America, they have triangular (not rectangular) foundation. That is, they are tetrahedrons in mathematical sense. In order to find out some important facts about the early society of the country (it is widely believed that the pyramid sizes are in tight connection with Farland ancient calendar), Mr. Archeo needs to know the volume of the pyramids. Unluckily, he has reliable data about their edge lengths only. Please, help him!
Input
The file contains six positive integer numbers not exceeding 1000 separated by spaces, each number is one of the edge lengths of the pyramid ABCD. The order of the edges is the following: AB, AC, AD, BC, BD, CD.
Output
A real number — the volume printed accurate to four digits after decimal point.
Sample Input
1000 1000 1000 3 4 5
Sample Output
Find the height of the tetrahedron according to the edge , Then calculate by formula .
Code :
/* ***********************************************
Author :_rabbit
Created Time :2014/5/9 21:32:01
File Name :5.cpp
************************************************ */
#pragma comment(linker, "/STACK:102400000,102400000")
#include <stdio.h>
#include <iostream>
#include <algorithm>
#include <sstream>
#include <stdlib.h>
#include <string.h>
#include <limits.h>
#include <string>
#include <time.h>
#include <math.h>
#include <queue>
#include <stack>
#include <set>
#include <map>
using namespace std;
#define INF 0x3f3f3f3f
#define eps 1e-8
#define pi acos(-1.0)
typedef long long ll;
double volume(double a,double b,double c,double d,double e,double f){
double a2=a*a,b2=b*b,c2=c*c,d2=d*d,e2=e*e,f2=f*f;
double tr1=acos((c2+b2-f2)/(2*b*c));
double tr2=acos((a2+c2-e2)/(2*a*c));
double tr3=acos((a2+b2-d2)/(2*a*b));
double tr4=(tr1+tr2+tr3)/2;
double temp=sqrt(sin(tr4)*sin(tr4-tr1)*sin(tr4-tr2)*sin(tr4-tr3));
return a*b*c*temp/3;
}
int main()
{
//freopen("data.in","r",stdin);
//freopen("data.out","w",stdout);
double a,b,c,d,e,f;
while(cin>>a>>b>>c>>d>>e>>f)printf("%.4f\n",volume(a,b,c,d,e,f));
return 0;
}
Copyright notice : This article is an original blog article . Blog , Without consent , Shall not be reproduced .
Publisher : Full stack programmer stack length , Reprint please indicate the source :https://javaforall.cn/117405.html Link to the original text :https://javaforall.cn
边栏推荐
- Top command details
- The difference between parallelism and concurrency
- Maixll dock camera usage
- [swoole series 2.1] run the swoole first
- 推荐好用的后台管理脚手架,人人开源
- std::true_type和std::false_type
- 华为0基金会——图片整理
- STM32+ESP8266+MQTT协议连接OneNet物联网平台
- Running the service with systemctl in the container reports an error: failed to get D-Bus connection: operation not permitted (solution)
- C language college laboratory reservation registration system
猜你喜欢
当保存参数使用结构体时必备的开发技巧方式
Introduction and case analysis of Prophet model
Penetration test information collection - CDN bypass
287. Find duplicates
Transport layer congestion control - slow start and congestion avoidance, fast retransmission, fast recovery
Declval of template in generic programming
Recommend easy-to-use backstage management scaffolding, everyone open source
[the 300th weekly match of leetcode]
Compilation Principle -- C language implementation of prediction table
关于这次通信故障,我想多说几句…
随机推荐
win10系统下插入U盘有声音提示却不显示盘符
Declval (example of return value of guidance function)
Docker安装Redis
2019阿里集群数据集使用总结
第三季百度网盘AI大赛盛夏来袭,寻找热爱AI的你!
Windows connects redis installed on Linux
解读云原生技术
Introduction and case analysis of Prophet model
推荐好用的后台管理脚手架,人人开源
C language college laboratory reservation registration system
Open source and safe "song of ice and fire"
具体说明 Flume介绍、安装和配置
44所高校入选!分布式智能计算项目名单公示
Compilation principle - top-down analysis and recursive descent analysis construction (notes)
Markdown syntax for document editing (typera)
随着MapReduce job实现去加重,多种输出文件夹
Distill knowledge from the interaction model! China University of science and Technology & meituan proposed virt, which combines the efficiency of the two tower model and the performance of the intera
【.NET CORE】 请求长度过长报错解决方案
Unity资源顺序加载的一个方法
[the 300th weekly match of leetcode]