当前位置:网站首页>1230: 蜂巢
1230: 蜂巢
2022-08-03 05:10:00 【-JMY-】
题目描述
一只蜜蜂在下图所示的数字蜂房上爬动,已知它只能从标号小的蜂房爬到标号大的相邻蜂房,现在问你:蜜蜂从蜂房M开始爬到蜂房N,M<N,有多少种爬行路线?
输入
只有一行,是2个用空格隔开的整数M,N(1<=M,N<=60)。
输出
只有1行,1个整数,即有多少种爬行路线。
样例输入
1 3
样例输出
2
(这题其实是找规律,明白规律就很简单了)
参考代码:
#include<bits/stdc++.h>
using namespace std;
long long a[2][60],m,n,l;
int main(){
cin>>m>>n;
a[0][0]=1;
a[1][0]=1;
while(m>1){
m--;
n--;
}
for(l=1;l<=(n-1)/2;l++){
a[0][l]=a[0][l-1]+a[1][l-1];
a[1][l]=a[0][l]+a[1][l-1];
}
cout<<a[1-n%2][l-1];
return 0;
}
边栏推荐
- Talking about GIS Data (6) - Projected Coordinate System
- -查找数-
- Lambda表达式案例
- Modelarts第一次培训
- 安装IIS服务(Internet信息服务(Internet Information Services,简写IIS,互联网信息服务)
- Talking about GIS Data (5) - Geographic Coordinate System
- 曲线特征----曲线弯曲程度的探究
- 1. 两数之和
- 【 Harmony OS 】 【 ano UI 】 lightweight data storage
- 内部类、static关键字、final
猜你喜欢
MOSN 反向通道详解
typescript47-函数之间的类型兼容性
Exception (abnormal) and Error (error) difference analysis
Talking about GIS Data (5) - Geographic Coordinate System
Detailed explanation of MOSN reverse channel
【特征选取】计算数据点曲率
MySql数据库
Modelarts第一次培训
Harmony OS ets ArkUI 】 【 】 the development basic page layout and data connection
js implements a bind function
随机推荐
Length n of condensed distance matrix ‘y‘ must be a binomial coefficient
Secondary development of WinForm controls
Common fluorescent dyes to modify a variety of groups and its excitation and emission wavelength data in the data
初步认识ZK
Peptides mediated PEG DSPE of phospholipids, targeted functional materials - PEG - RGD/TAT/NGR/APRPG
背压机制
对角矩阵(diagonal matrix)
建立树形结构
minio下载文件乱码或者是一条横线
2017-06-11 Padavan 完美适配newifi mini【adbyby+SS+KP ...】youku L1 /小米mini
快速上手 Mockito 单元测试框架
NotImplementedError: file structure not yet supported
Djiango第三次培训
详解Nurbs曲线
Response 重写设置返回值
Power button 561. An array of split
3. 无重复字符的最长子串
typescript41-class类的私有修饰符
typescript46-函数之间的类型兼容性
用户密码加密工具