当前位置:网站首页>谎牛计数(春季每日一题 53)
谎牛计数(春季每日一题 53)
2022-07-07 14:28:00 【sweetheart7-7】
奶牛 Bessie 躲在数轴上的某处。
农夫约翰的 N N N 头奶牛中的每头奶牛都有一条信息要分享:第 i i i 头奶牛说 Bessie 躲在小于或等于 p i p_i pi 的某个位置,或者说 Bessie 躲在大于或等于 p i p_i pi 的某个位置。
不幸的是,可能不存在躲藏位置与所有奶牛的回答均一致,这意味着并非所有奶牛都在说真话。
计算在撒谎的奶牛的最小数量。
输入格式
输入的第一行包含 N N N。
以下 N N N 行每行包含字符 L
或 G
,之后是一个整数 p i p_i pi。L
表示第 i i i 头奶牛说 Bessie 的躲藏位置小于或等于 p i p_i pi,而 G
表示第 i i i 头奶牛说 Bessie 的躲藏位置大于或等于 p i p_i pi。
输出格式
输出在撒谎的奶牛的最小数量。
数据范围
1 ≤ N ≤ 1000 1≤N≤1000 1≤N≤1000,
0 ≤ p i ≤ 1 0 9 0≤pi≤10^9 0≤pi≤109。
输入样例1:
2
G 3
L 5
输出样例1:
0
样例1解释
有可能没有奶牛在撒谎。
输入样例2:
2
G 3
L 2
输出样例2:
1
样例2解释
至少一头奶牛在撒谎。
// 枚举每一个端点,撒谎的牛的数量等于左边的 L 之和 + 右边的 G 之和
// Bessie 所在位置取端点中间和取端点对答案的影响是一样的
#include<iostream>
#include<algorithm>
#define x first
#define y second
using namespace std;
const int N = 1010;
int n;
pair<int, char> q[N];
int s[N];
int main(){
cin >> n;
for(int i = 1; i <= n; i++) cin >> q[i].y >> q[i].x;
sort(q + 1, q + 1 + n);
for(int i = 1; i <= n; i++){
s[i] = s[i - 1];
if(q[i].y == 'L') s[i]++;
}
int res = n;
for(int i = n, r = 0; i; i--){
int j = i, t = 0;
while(j && q[j].x == q[i].x){
if(q[j].y == 'G') t++;
j--;
}
res = min(res, s[j] + r);
r += t;
i = j + 1;
}
cout << res << endl;
return 0;
}
边栏推荐
- AutoLISP series (3): function function 3
- 删除 console 语句引发的惨案
- PHP has its own filtering and escape functions
- torch. Numel action
- 预测——灰色预测
- Performance comparison of tidb for PostgreSQL and yugabytedb on sysbench
- spark调优(三):持久化减少二次查询
- How to determine whether the checkbox in JS is selected
- Odoo integrated plausible embedded code monitoring platform
- [vulnhub range] thales:1
猜你喜欢
【Vulnhub靶场】THALES:1
Have fun | latest progress of "spacecraft program" activities
Lecturer solicitation order | Apache seatunnel (cultivating) meetup sharing guests are in hot Recruitment!
使用JSON.stringify()去实现深拷贝,要小心哦,可能有巨坑
C语言进阶——函数指针
Record the migration process of a project
Performance comparison of tidb for PostgreSQL and yugabytedb on sysbench
如何快速检查钢网开口面积比是否符合 IPC7525
Leetcode-231-2的幂
Odoo集成Plausible埋码监控平台
随机推荐
Unity3d click events added to 3D objects in the scene
Record the migration process of a project
pycharm 终端部启用虚拟环境
IP地址和物理地址有什么区别
Shandong old age Expo, 2022 China smart elderly care exhibition, smart elderly care and aging technology exhibition
null == undefined
How to implement backspace in shell
Set the route and optimize the URL in thinkphp3.2.3
"The" "PIP" "entry cannot be recognized as the name of a cmdlet, function, script file, or runnable program."
面试题 01.02. 判定是否互为字符重排-辅助数组算法
Communication mode between application program and MATLAB
Three. JS series (1): API structure diagram-1
数据中台落地实施之法
laravel post提交数据时显示异常
无法将“pip”项识别为 cmdlet、函数、脚本文件或可运行程序的名称
Leetcode-136-只出现一次的数(用异或来解答)
Markdown formula editing tutorial
laravel怎么获取到public路径
Imitate the choice of enterprise wechat conference room
记录Servlet学习时的一次乱码