当前位置:网站首页>HDU - 1114 Piggy Bank (full backpack)
HDU - 1114 Piggy Bank (full backpack)
2022-07-02 17:42:00 【WA_ automata】
HDU - 1114 Piggy-Bank
Problem Description
Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid.
But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs!
Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it’s weight in grams.
Output
Print exactly one line of output for each test case. The line must contain the sentence “The minimum amount of money in the piggy-bank is X.” where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line “This is impossible.”.
Sample Input
3
10 110
2
1 1
30 50
10 110
2
1 1
50 30
1 6
2
10 3
20 4
Sample Output
The minimum amount of money in the piggy-bank is 60.
The minimum amount of money in the piggy-bank is 100.
This is impossible.
The main idea of the topic : There is a backpack with the size of E, Now it can only be filled F, Ask for some space left , Value is p, The quality is w Full of coins , Ask the total value of coins used after the last filling .
#include<iostream>
#include<cstring>
using namespace std;
const int N = 10010;
int dp[N];
int main()
{
int T;cin>>T;
while(T--)
{
memset(dp,0x3f,sizeof dp);
int e,f;cin>>e>>f;
int h=f-e;
int n;cin>>n;
dp[0]=0;
for(int i=1;i<=n;i++)
{
int p,w;cin>>p>>w;
for(int j=w;j<=h;j++)
dp[j]=min(dp[j],dp[j-w]+p);
}
if(dp[h]==0x3f3f3f3f) cout<<"This is impossible."<<endl;
else cout<<"The minimum amount of money in the piggy-bank is "<<dp[h]<<"."<<endl;
}
return 0;
}
边栏推荐
猜你喜欢
freemarker+poi实现动态生成excel文件及解析excel文件
【目标跟踪】|SiamFC
每日一题——小乐乐改数字
从收集到输出:盘点那些强大的知识管理工具——优秀笔记软件盘点(四)
After meeting a full stack developer from Tencent, I saw what it means to be proficient in MySQL tuning
链表求和[dummy+尾插法+函数处理链表引用常见坑位]
[how to connect the network] Chapter 5 explore the server
[how is the network connected] Chapter 6 requests arrive at the server and respond to the client (end)
This "architect growth note" made 300 people successfully change jobs and enter the big factory, with an annual salary of 50W
Example nonlinear integer programming
随机推荐
Si446 usage record (II): generate header files using wds3
每日一题——“水仙花数”
【网络是怎样连接的】第五章 探索服务器
AtCoder Beginner Contest 237 VP补题
详细介绍scrollIntoView()方法属性
Explanation of traceroute command
Introduction to Hisilicon hi3798mv100 set top box chip [easy to understand]
2022 interview questions
IPtables中SNAT、DNAT和MASQUERADE的含义
[comment le réseau se connecte] chapitre 6: demande d'accès au serveur et réponse au client (terminé)
ssb门限_SSB调制「建议收藏」
Easyswoole3.2 restart failed
How to create a new page for SAP Spartacus storefront
executescalar mysql_ ExecuteScalar()
The bottom simulation implementation of vector
Introduction to nexus and detailed tutorial of Xiaobai using idea to package and upload to nexus3 private server
常用SQL语句(完整范例)
Uniapp H5 page calls wechat payment
Ssm+ wechat applet to realize property management system
简单线性规划问题