当前位置:网站首页>Simple continuous viewing PTA
Simple continuous viewing PTA
2022-07-06 20:38:00 【Sophomore to major】
Interesting topic , There are many input pits in front , Just pay attention .
This problem requires the realization of a simple game simulation program .
Given a 2N×2N Square grid game panel , Place some symbols in each grid . These symbols must appear in pairs , There may be more than one pair of the same symbol . The program reads in a pair of positions given by the player (x1,y1)、(x2,y2), Judge whether the symbols in these two positions match . If the match is successful , Then eliminate the two symbols to “*” And output the erased disk surface ; Otherwise output “Uh-oh”. If the matching error reaches 3 Time , The output “Game Over” And end the game . Or when all symbols match successfully , The output “Congratulations!”, And end the game .
Input format :
Enter a positive integer on a line N(<5). And then 2N That's ok , Each row 2N Capital letters ( In the meantime 1 Space separation ), Indicates the game disk . A positive integer is given after the disk surface K, And then K That's ok , Each line follows the format “x1 y1 x2 y2” Give a player's input . Pay attention to the lines in the grid 、 Column number is from 1 To 2N.
Output format :
According to each step of the player, enter , Output the corresponding result . When outputting the disk surface, pay attention to , The characters in each line are separated by 1 Space separation , There must be no extra space at the end of the line .
sample input 1:
2
I T I T
Y T I A
T A T Y
I K K T
11
1 1 1 3
4 2 4 3
3 1 4 2
2 2 1 2
3 1 2 4
4 4 3 1
2 1 3 4
3 3 1 4
4 1 2 3
2 4 3 2
1 1 2 2
sample output 1:
* T * T
Y T I A
T A T Y
I K K T
* T * T
Y T I A
T A T Y
I * * T
Uh-oh
* * * T
Y * I A
T A T Y
I * * T
Uh-oh
* * * T
Y * I A
* A T Y
I * * *
* * * T
* * I A
* A T *
I * * *
* * * *
* * I A
* A * *
I * * *
* * * *
* * * A
* A * *
* * * *
Congratulations!
sample input 2:
2
I T I T
Y T I A
T A T Y
I K K T
5
1 1 4 4
1 1 2 3
1 1 2 3
2 2 4 1
2 2 3 3
sample output 2:
Uh-oh
* T I T
Y T * A
T A T Y
I K K T
Uh-oh
Uh-oh
Game Over
#include <stdio.h>
int main() {
int n;
char arr[100][100];
scanf("%d", &n);
getchar();//\n
for (int i = 0; i < 2 * n; i++) {// Be careful with this input
scanf("%c", &arr[i][0]);
for (int j = 1; j < 2 * n; j++) {
scanf(" %c", &arr[i][j]);
}
getchar();
}
int k, x1, y1, x2, y2;
scanf("%d", &k);
int flag = 1, ctn = 0, flag2;//flag Judge first ,flag2 Judge whether it is finished
for (int i = 0; i < k; i++) {
flag2=0;
scanf("%d %d %d %d", &x1, &y1, &x2, &y2);
if (arr[x1 - 1][y1 - 1] == arr[x2 - 1][y2 - 1]&&arr[x1-1][y1-1]!='*'&&arr[x2-1][y2-1]!='*') {
arr[x1 - 1][y1 - 1] = arr[x2 - 1][y2 - 1] = '*';
}
else {
ctn++;
printf("Uh-oh\n");
if (ctn == 3) { printf("Game Over"); break; }
continue;
}
for (int i = 0; i < 2 * n; i++) {
for (int j = 0; j < 2 * n; j++) {
if (arr[i][j] != '*') {
flag2 = 1; break;
}
}
}
if (flag2 == 0) {
printf("Congratulations!");
break;
}
if (flag2) {
for (int i = 0; i < 2 * n; i++) {
flag = 1;
for (int j = 0; j < 2 * n; j++) {
if (flag) { flag = 0; printf("%c", arr[i][j]); }
else {
printf(" %c", arr[i][j]);
}
}
printf("\n");
}
}
}
return 0;
}
边栏推荐
- 【每周一坑】输出三角形
- BUUCTF---Reverse---easyre
- 为什么新手在编程社区提问经常得不到回答,甚至还会被嘲讽?
- Pytest (3) - Test naming rules
- Jupyter launch didn't respond after Anaconda was installed & the web page was opened and ran without execution
- 02 基础入门-数据包拓展
- Intel 48 core new Xeon run point exposure: unexpected results against AMD zen3 in 3D cache
- use. Net drives the OLED display of Jetson nano
- recyclerview gridlayout 平分中间空白区域
- C language games - minesweeping
猜你喜欢
Discussion on beegfs high availability mode
22-07-05 upload of qiniu cloud storage pictures and user avatars
B-杰哥的树(状压树形dp)
Maximum likelihood estimation and cross entropy loss
Boder radius has four values, and boder radius exceeds four values
01 基础入门-概念名词
Database - how to get familiar with hundreds of tables of the project -navicat these unique skills, have you got it? (exclusive experience)
【每周一坑】正整数分解质因数 +【解答】计算100以内质数之和
02 basic introduction - data package expansion
小孩子學什麼編程?
随机推荐
Entity alignment two of knowledge map
B-jiege's tree (pressed tree DP)
Tencent T4 architect, Android interview Foundation
【每周一坑】正整数分解质因数 +【解答】计算100以内质数之和
Web security - payload
Intel 48 core new Xeon run point exposure: unexpected results against AMD zen3 in 3D cache
永磁同步电机转子位置估算专题 —— 基波模型类位置估算概要
Review questions of anatomy and physiology · VIII blood system
Ideas and methods of system and application monitoring
Database - how to get familiar with hundreds of tables of the project -navicat these unique skills, have you got it? (exclusive experience)
Logic is a good thing
性能测试过程和计划
Detailed introduction of distributed pressure measurement system VIII: basic introduction of akka actor model
[DSP] [Part 1] start DSP learning
[diy] how to make a personalized radio
(work record) March 11, 2020 to March 15, 2021
(工作记录)2020年3月11日至2021年3月15日
Mécanisme de fonctionnement et de mise à jour de [Widget Wechat]
Leetcode question 283 Move zero
Unity load AB package