当前位置:网站首页>Simple continuous viewing PTA
Simple continuous viewing PTA
2022-07-06 20:38:00 【Sophomore to major】
Interesting topic , There are many input pits in front , Just pay attention .
This problem requires the realization of a simple game simulation program .
Given a 2N×2N Square grid game panel , Place some symbols in each grid . These symbols must appear in pairs , There may be more than one pair of the same symbol . The program reads in a pair of positions given by the player (x1,y1)、(x2,y2), Judge whether the symbols in these two positions match . If the match is successful , Then eliminate the two symbols to “*” And output the erased disk surface ; Otherwise output “Uh-oh”. If the matching error reaches 3 Time , The output “Game Over” And end the game . Or when all symbols match successfully , The output “Congratulations!”, And end the game .
Input format :
Enter a positive integer on a line N(<5). And then 2N That's ok , Each row 2N Capital letters ( In the meantime 1 Space separation ), Indicates the game disk . A positive integer is given after the disk surface K, And then K That's ok , Each line follows the format “x1 y1 x2 y2” Give a player's input . Pay attention to the lines in the grid 、 Column number is from 1 To 2N.
Output format :
According to each step of the player, enter , Output the corresponding result . When outputting the disk surface, pay attention to , The characters in each line are separated by 1 Space separation , There must be no extra space at the end of the line .
sample input 1:
2
I T I T
Y T I A
T A T Y
I K K T
11
1 1 1 3
4 2 4 3
3 1 4 2
2 2 1 2
3 1 2 4
4 4 3 1
2 1 3 4
3 3 1 4
4 1 2 3
2 4 3 2
1 1 2 2
sample output 1:
* T * T
Y T I A
T A T Y
I K K T
* T * T
Y T I A
T A T Y
I * * T
Uh-oh
* * * T
Y * I A
T A T Y
I * * T
Uh-oh
* * * T
Y * I A
* A T Y
I * * *
* * * T
* * I A
* A T *
I * * *
* * * *
* * I A
* A * *
I * * *
* * * *
* * * A
* A * *
* * * *
Congratulations!
sample input 2:
2
I T I T
Y T I A
T A T Y
I K K T
5
1 1 4 4
1 1 2 3
1 1 2 3
2 2 4 1
2 2 3 3
sample output 2:
Uh-oh
* T I T
Y T * A
T A T Y
I K K T
Uh-oh
Uh-oh
Game Over
#include <stdio.h>
int main() {
int n;
char arr[100][100];
scanf("%d", &n);
getchar();//\n
for (int i = 0; i < 2 * n; i++) {// Be careful with this input
scanf("%c", &arr[i][0]);
for (int j = 1; j < 2 * n; j++) {
scanf(" %c", &arr[i][j]);
}
getchar();
}
int k, x1, y1, x2, y2;
scanf("%d", &k);
int flag = 1, ctn = 0, flag2;//flag Judge first ,flag2 Judge whether it is finished
for (int i = 0; i < k; i++) {
flag2=0;
scanf("%d %d %d %d", &x1, &y1, &x2, &y2);
if (arr[x1 - 1][y1 - 1] == arr[x2 - 1][y2 - 1]&&arr[x1-1][y1-1]!='*'&&arr[x2-1][y2-1]!='*') {
arr[x1 - 1][y1 - 1] = arr[x2 - 1][y2 - 1] = '*';
}
else {
ctn++;
printf("Uh-oh\n");
if (ctn == 3) { printf("Game Over"); break; }
continue;
}
for (int i = 0; i < 2 * n; i++) {
for (int j = 0; j < 2 * n; j++) {
if (arr[i][j] != '*') {
flag2 = 1; break;
}
}
}
if (flag2 == 0) {
printf("Congratulations!");
break;
}
if (flag2) {
for (int i = 0; i < 2 * n; i++) {
flag = 1;
for (int j = 0; j < 2 * n; j++) {
if (flag) { flag = 0; printf("%c", arr[i][j]); }
else {
printf(" %c", arr[i][j]);
}
}
printf("\n");
}
}
}
return 0;
}
边栏推荐
- 小孩子學什麼編程?
- Pycharm remote execution
- Xcode6 error: "no matching provisioning profiles found for application"
- 7、数据权限注解
- PHP online examination system version 4.0 source code computer + mobile terminal
- 2022 construction electrician (special type of construction work) free test questions and construction electrician (special type of construction work) certificate examination
- 知识图谱之实体对齐二
- Mécanisme de fonctionnement et de mise à jour de [Widget Wechat]
- Tencent byte and other big companies interview real questions summary, Netease architects in-depth explanation of Android Development
- Le lancement du jupyter ne répond pas après l'installation d'Anaconda
猜你喜欢
逻辑是个好东西
2022 Guangdong Provincial Safety Officer C certificate third batch (full-time safety production management personnel) simulation examination and Guangdong Provincial Safety Officer C certificate third
知识图谱之实体对齐二
全网最全的知识库管理工具综合评测和推荐:FlowUs、Baklib、简道云、ONES Wiki 、PingCode、Seed、MeBox、亿方云、智米云、搜阅云、天翎
use. Net drives the OLED display of Jetson nano
SSO single sign on
【每周一坑】正整数分解质因数 +【解答】计算100以内质数之和
Statistical inference: maximum likelihood estimation, Bayesian estimation and variance deviation decomposition
设计你的安全架构OKR
Detailed explanation of knowledge map construction process steps
随机推荐
Rhcsa Road
What key progress has been made in deep learning in 2021?
Event center parameter transfer, peer component value transfer method, brother component value transfer
01 basic introduction - concept nouns
2022 refrigeration and air conditioning equipment installation and repair examination contents and new version of refrigeration and air conditioning equipment installation and repair examination quest
Core principles of video games
Continuous test (CT) practical experience sharing
Solution to the 38th weekly match of acwing
How to select several hard coded SQL rows- How to select several hardcoded SQL rows?
SSH connection denied
(工作记录)2020年3月11日至2021年3月15日
[DIY]如何制作一款個性的收音機
Activiti global process monitors activitieventlistener to monitor different types of events, which is very convenient without configuring task monitoring in acitivit
[DSP] [Part 1] start DSP learning
22-07-05 upload of qiniu cloud storage pictures and user avatars
Catch ball game 1
Can novices speculate in stocks for 200 yuan? Is the securities account given by qiniu safe?
解剖生理学复习题·VIII血液系统
[cloud native and 5g] micro services support 5g core network
Unity load AB package