当前位置:网站首页>Haut OJ 1357: lunch question (I) -- high precision multiplication
Haut OJ 1357: lunch question (I) -- high precision multiplication
2022-07-05 05:17:00 【hunziHang】
Problem description :
12 It's o'clock again , It's time for lunch , Small C Collapse in bed and don't want to get up , Small A Don't want to get used to him , So I said to him :“ Small C, You didn't make it last week choice Sister's addition , Now you can make choice Sister's multiplication , I'll bring you some rice .” Can you help me C.
Input :
Two integers A and B,A and B The length of l(0 <= l <= 1000).
Output :
Multi instance testing , Output A*B Result .
The sample input :
4038 5255 55718 7221 8160 104906 3511906 8767574
Sample output :
21219690 402339678 856032960 30790895736044
Cause analysis :
1. Create three int Array , Initialize to 0, Record length , Save each number in the string into the array cell ( Input backwards )
2. Multiply each number , c[i+j-1] + =a[i]*b[j]; c[i+j]+=c[i+j-1]/10; Don't let it slip +
3. Remove leading 0
Solution :
#include<bits/stdc++.h>
using namespace std;
#define endl "\n"
long long a[1000005];
int main(void)
{
ios::sync_with_stdio(false);
cin.tie(0);
cout.tie(0);
string str1,str2;
while(cin>>str1>>str2)
{
int a[2000],b[2000],c[5000],i,j,len;
memset(a,0,sizeof(a));
memset(b,0,sizeof(b));
memset(c,0,sizeof(c));
a[0]=str1.length();
b[0]=str2.length();
for(i=1;i<=a[0];i++)
a[i]=str1[a[0]-i]-'0';
for(i=1;i<=b[0];i++)
b[i]=str2[b[0]-i]-'0';
for(i=1;i<=a[0];i++)
for(j=1;j<=b[0];j++)
{
c[i+j-1]+=a[i]*b[j];
c[i+j]+=c[i+j-1]/10;
c[i+j-1]%=10;
}
len=a[0]+b[0]+1;
while(len>1&&c[len]==0)
len--;
for(i=len;i>=1;i--)
cout<<c[i];
cout<<endl;
}
return 0;
}
边栏推荐
- Ue4/ue5 illusory engine, material chapter, texture, compression and memory compression and memory
- Use of snippets in vscode (code template)
- [turn to] MySQL operation practice (III): table connection
- PMP candidates, please check the precautions for PMP examination in July
- 支持多模多态 GBase 8c数据库持续创新重磅升级
- [turn]: Apache Felix framework configuration properties
- A three-dimensional button
- 服务熔断 Hystrix
- Learning notes of "hands on learning in depth"
- Django reports an error when connecting to the database. What is the reason
猜你喜欢
BUUCTF MISC
Ue4/ue5 illusory engine, material chapter, texture, compression and memory compression and memory
Binary search basis
[轉]: OSGI規範 深入淺出
Unity3d learning notes
Generate filled text and pictures
Research on the value of background repeat of background tiling
Pointnet++的改进
C language Essay 1
Applet Live + e - commerce, si vous voulez être un nouveau e - commerce de détail, utilisez - le!
随机推荐
Shell Sort
2022 / 7 / 1 Résumé de l'étude
Research on the value of background repeat of background tiling
2022/7/2做题总结
Listview is added and deleted at the index
2022/7/1 learning summary
UE4/UE5 虚幻引擎,材质篇(三),不同距离的材质优化
Embedded database development programming (V) -- DQL
Unity sends messages and blocks indecent words
使用命令符关闭笔记本自带键盘命令
Cocos2dx Lua registers the touch event and detects whether the click coordinates are within the specified area
Solon Logging 插件的添加器级别控制和日志器的级别控制
django连接数据库报错,这是什么原因
Solon 框架如何方便获取每个请求的响应时间?
Kali 2018 full image download
Reverse one-way linked list of interview questions
【ES实战】ES上的native realm安全方式使用
支持多模多态 GBase 8c数据库持续创新重磅升级
win10虚拟机集群优化方案
Unity connects to the database