当前位置:网站首页>Haut OJ 1357: lunch question (I) -- high precision multiplication
Haut OJ 1357: lunch question (I) -- high precision multiplication
2022-07-05 05:17:00 【hunziHang】
Problem description :
12 It's o'clock again , It's time for lunch , Small C Collapse in bed and don't want to get up , Small A Don't want to get used to him , So I said to him :“ Small C, You didn't make it last week choice Sister's addition , Now you can make choice Sister's multiplication , I'll bring you some rice .” Can you help me C.
Input :
Two integers A and B,A and B The length of l(0 <= l <= 1000).
Output :
Multi instance testing , Output A*B Result .
The sample input :
4038 5255 55718 7221 8160 104906 3511906 8767574
Sample output :
21219690 402339678 856032960 30790895736044
Cause analysis :
1. Create three int Array , Initialize to 0, Record length , Save each number in the string into the array cell ( Input backwards )
2. Multiply each number , c[i+j-1] + =a[i]*b[j]; c[i+j]+=c[i+j-1]/10; Don't let it slip +
3. Remove leading 0
Solution :
#include<bits/stdc++.h>
using namespace std;
#define endl "\n"
long long a[1000005];
int main(void)
{
ios::sync_with_stdio(false);
cin.tie(0);
cout.tie(0);
string str1,str2;
while(cin>>str1>>str2)
{
int a[2000],b[2000],c[5000],i,j,len;
memset(a,0,sizeof(a));
memset(b,0,sizeof(b));
memset(c,0,sizeof(c));
a[0]=str1.length();
b[0]=str2.length();
for(i=1;i<=a[0];i++)
a[i]=str1[a[0]-i]-'0';
for(i=1;i<=b[0];i++)
b[i]=str2[b[0]-i]-'0';
for(i=1;i<=a[0];i++)
for(j=1;j<=b[0];j++)
{
c[i+j-1]+=a[i]*b[j];
c[i+j]+=c[i+j-1]/10;
c[i+j-1]%=10;
}
len=a[0]+b[0]+1;
while(len>1&&c[len]==0)
len--;
for(i=len;i>=1;i--)
cout<<c[i];
cout<<endl;
}
return 0;
}
边栏推荐
- [转]:Apache Felix Framework配置属性
- UE fantasy engine, project structure
- SDEI初探-透过事务看本质
- Embedded database development programming (V) -- DQL
- Out and ref functions of unity
- Fragment addition failed error lookup
- [paper notes] multi goal reinforcement learning: challenging robotics environments and request for research
- 发现一个很好的 Solon 框架试手的教学视频(Solon,轻量级应用开发框架)
- Simple modal box
- win下一键生成当日的时间戳文件
猜你喜欢
远程升级怕截胡?详解FOTA安全升级
十年不用一次的JVM调用
Do a small pressure test with JMeter tool
2022/7/2 question summary
[转]MySQL操作实战(三):表联结
Embedded database development programming (zero)
UE 虚幻引擎,项目结构
Merge sort
[interval problem] 435 Non overlapping interval
To the distance we have been looking for -- film review of "flying house journey"
随机推荐
Out and ref functions of unity
Generate filled text and pictures
cocos_ Lua loads the file generated by bmfont fnt
SDEI初探-透过事务看本质
Unity find the coordinates of a point on the circle
Programmers' experience of delivering takeout
一个新的微型ORM开源框架
Solon 框架如何方便获取每个请求的响应时间?
Django reports an error when connecting to the database. What is the reason
Unity synergy
Cocos2dx screen adaptation
Sixth note
Establish cloth effect in 10 seconds
Unity connects to the database
发现一个很好的 Solon 框架试手的教学视频(Solon,轻量级应用开发框架)
2022上半年全国教师资格证下
Unity parallax infinite scrolling background
Pointnet++的改进
[turn to] MySQL operation practice (I): Keywords & functions
Cocos2dx Lua registers the touch event and detects whether the click coordinates are within the specified area