当前位置:网站首页>POJ 1182 :食物链(并查集)[通俗易懂]
POJ 1182 :食物链(并查集)[通俗易懂]
2022-07-07 16:53:00 【全栈程序员站长】
大家好,又见面了,我是全栈君。
Time Limit: 1000MS | Memory Limit: 10000K | |
---|---|---|
Total Submissions: 43526 | Accepted: 12679 |
Description
动物王国中有三类动物A,B,C,这三类动物的食物链构成了有趣的环形。A吃B, B吃C,C吃A。
现有N个动物,以1-N编号。
每一个动物都是A,B,C中的一种,可是我们并不知道它究竟是哪一种。 有人用两种说法对这N个动物所构成的食物链关系进行描写叙述: 第一种说法是”1 X Y”,表示X和Y是同类。
另外一种说法是”2 X Y”。表示X吃Y。 此人对N个动物。用上述两种说法。一句接一句地说出K句话。这K句话有的是真的。有的是假的。
当一句话满足下列三条之中的一个时,这句话就是假话,否则就是真话。 1) 当前的话与前面的某些真的话冲突。就是假话; 2) 当前的话中X或Y比N大。就是假话。 3) 当前的话表示X吃X,就是假话。 你的任务是依据给定的N(1 <= N <= 50,000)和K句话(0 <= K <= 100,000),输出假话的总数。
Input
第一行是两个整数N和K,以一个空格分隔。
下面K行每行是三个正整数 D,X,Y。两数之间用一个空格隔开。当中D表示说法的种类。 若D=1,则表示X和Y是同类。 若D=2,则表示X吃Y。
Output
仅仅有一个整数。表示假话的数目。
Sample Input
100 7
1 101 1
2 1 2
2 2 3
2 3 3
1 1 3
2 3 1
1 5 5
Sample Output
3
好吧。。
这篇的确是最具体的。。点击打开链接
看了之后对并查集的了解更加深了。。。
弱菜在此感谢博主。。
还有这道题我用多重输入就错了。。
害我弄了好久。。
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<vector>
#include<queue>
#include<sstream>
#include<cmath>
using namespace std;
#define M 100500
int n;
int k;
int d;
int x;
int y;
int p[M];
int r[M];
int ans;
void start()
{
for(int i=1; i<=n; i++)
{
p[i]=i; //初始化并查集
r[i]=0; //初始化时。每一个元素作为一个集合,其元素为1
}
}
int find(int x) //并查集的find
{
if( p[x]==x )
return x;
else
{
int t = p[x];
p[x] = find ( p[x] );
r[x] = (r[x]+r[t])%3;
return p[x];
}
}
void Kruskal(int x, int y, int d)
{
int xx = find(x);
int yy = find(y);
p[yy] = xx;
r[yy] = (r[x]-r[y]+3+(d-1))%3;
}
int main()
{
scanf("%d%d", &n, &k);
start();
ans = 0;
for(int i=1; i<=k; i++)
{
scanf("%d%d%d", &d, &x, &y);
if(x>n || y>n || (d==2&&x==y))
ans++;
else if( find(x) == find(y) )
{
if( d==1 && r[x]!=r[y] )
ans++;
if( d==2 && (r[x]+1)%3 != r[y] )
ans++;
}
else
Kruskal(x, y, d);
}
printf("%d\n", ans);
return 0;
}
发布者:全栈程序员栈长,转载请注明出处:https://javaforall.cn/116605.html原文链接:https://javaforall.cn
边栏推荐
- Improve application security through nonce field of play integrity API
- Wireshark分析抓包数据*.cap
- 国内的软件测试会受到偏见吗
- 线程池和单例模式以及文件操作
- Some key points in the analysis of spot Silver
- I feel cheated. Wechat tests the function of "size number" internally, and two wechat can be registered with the same mobile number
- Will low code help enterprises' digital transformation make programmers unemployed?
- 抢占周杰伦
- 3.关于cookie
- Yunjing network technology interview question [Hangzhou multi tester] [Hangzhou multi tester _ Wang Sir]
猜你喜欢
Discuss | what preparations should be made before ar application is launched?
gsap动画库
socket編程之常用api介紹與socket、select、poll、epoll高並發服務器模型代碼實現
学习open62541 --- [67] 添加自定义Enum并显示名字
[paper sharing] where's crypto?
伺服力矩控制模式下的力矩目标值(fTorque)计算
静态路由配置
RISCV64
Antisamy: a solution against XSS attack tutorial
6. About JWT
随机推荐
RISCV64
Continuous test (CT) practical experience sharing
清华、剑桥、UIC联合推出首个中文事实核查数据集:基于证据、涵盖医疗社会等多个领域
体总:安全有序恢复线下体育赛事,力争做到国内赛事应办尽办
Kirk borne's selection of learning resources this week [click the title to download directly]
C语言中匿名的最高境界
String type, constant type and container type of go language
线程池中的线程工厂
PTA 1101 B是A的多少倍
低代码助力企业数字化转型会让程序员失业?
Do you really understand sticky bag and half bag? 3 minutes to understand it
完整的电商系统
GSAP animation library
【Unity Shader】插入Pass实现模型遮挡X光透视效果
企业展厅设计中常用的三种多媒体技术形式
Save the memory of the model! Meta & UC Berkeley proposed memvit. The modeling time support is 30 times longer than the existing model, and the calculation amount is only increased by 4.5%
Will low code help enterprises' digital transformation make programmers unemployed?
數據驗證框架 Apache BVal 再使用
学习open62541 --- [67] 添加自定义Enum并显示名字
Kubernetes DevOps CD工具对比选型