当前位置:网站首页>poj 3414 Pots (bfs+线索)
poj 3414 Pots (bfs+线索)
2022-07-05 20:48:00 【全栈程序员站长】
大家好,又见面了,我是全栈君,今天给大家准备了Idea注册码。
Pots
Time Limit: 1000MS | Memory Limit: 65536K | |||
---|---|---|---|---|
Total Submissions: 10071 | Accepted: 4237 | Special Judge |
Description
You are given two pots, having the volume of A and B liters respectively. The following operations can be performed:
- FILL(i) fill the pot i (1 ≤ i ≤ 2) from the tap;
- DROP(i) empty the pot i to the drain;
- POUR(i,j) pour from pot i to pot j; after this operation either the pot j is full (and there may be some water left in the pot i), or the pot i is empty (and all its contents have been moved to the pot j).
Write a program to find the shortest possible sequence of these operations that will yield exactly C liters of water in one of the pots.
Input
On the first and only line are the numbers A, B, and C. These are all integers in the range from 1 to 100 and C≤max(A,B).
Output
The first line of the output must contain the length of the sequence of operations K. The following K lines must each describe one operation. If there are several sequences of minimal length, output any one of them. If the desired result can’t be achieved, the first and only line of the file must contain the word ‘impossible’.
Sample Input
3 5 4
Sample Output
6
FILL(2)
POUR(2,1)
DROP(1)
POUR(2,1)
FILL(2)
POUR(2,1)
思路:一共同拥有6种操作:把A中水倒掉,把A加满,把B里的水倒入A中。B和A类似。
罐子最大容积为100,设一个常量N=100, 开一个二维数组记录状态变化的值。
1、从水龙头往A里加水t,记录-t,
2、从水龙头往B里加水t,记录-t-N,
3、从B里面往A加水t,记录t
4、从A里面往B加水t。记录N+t
5、把A里水倒掉,记录2*N+t,(A原有水t)
6、把B里水倒掉,记录3*N+t,(B原有水t)
#include<stdio.h>
#include<queue>
#include<map>
#include<string>
#include<string.h>
using namespace std;
#define N 105
const int inf=0x1f1f1f1f;
int a,b,c,flag;
int mark[N][N];
struct node
{
int x,y,t;
friend bool operator<(node a,node b)
{
return a.t>b.t;
}
};
void prif(int x,int y) //递归输出路径
{
if(x==0&&y==0)
return ;
if(mark[x][y]>3*N)
{
prif(x,mark[x][y]-3*N);
printf("DROP(2)\n");
}
else if(mark[x][y]>2*N)
{
prif(mark[x][y]-2*N,y);
printf("DROP(1)\n");
}
else if(mark[x][y]>N)
{
int tmp=mark[x][y]-N;
prif(x+tmp,y-tmp);
printf("POUR(1,2)\n");
}
else if(mark[x][y]>0)
{
int tmp=mark[x][y];
prif(x-tmp,y+tmp);
printf("POUR(2,1)\n");
}
else if(mark[x][y]>-N)
{
int tmp=-mark[x][y];
prif(x-tmp,y);
printf("FILL(1)\n");
}
else if(mark[x][y]<-N)
{
int tmp=N+mark[x][y];
prif(x,y+tmp);
printf("FILL(2)\n");
}
}
void bfs()
{
priority_queue<node>q;
node cur,next;
mark[0][0]=inf; //该状态仅仅能出现一次。赋值为inf防止干扰其它值
mark[a][0]=-a;
mark[0][b]=-b-N;
cur.t=1;
cur.x=a;
cur.y=0;
q.push(cur);
cur.x=0;
cur.y=b;
q.push(cur);
while(!q.empty())
{
cur=q.top();
q.pop();
next.t=cur.t+1;
if(cur.x==c||cur.y==c)
{
flag=1;
printf("%d\n",cur.t);
prif(cur.x,cur.y);
return ;
}
if(cur.x<a) //向A加水
{
int tmp=a-cur.x;
next.y=cur.y;
next.x=a; //来自水龙头的水
if(!mark[next.x][next.y])
{
mark[next.x][next.y]=-tmp;
q.push(next);
}
if(cur.y>0) //来自B的水
{
int tmp=min(cur.y,a-cur.x);
next.x=cur.x+tmp;
next.y=cur.y-tmp;
if(!mark[next.x][next.y])
{
mark[next.x][next.y]=tmp;
q.push(next);
}
}
}
if(cur.y<b) //向B加水
{
int tmp=b-cur.y;
next.x=cur.x;
next.y=b; //来自水龙头的水
if(!mark[next.x][next.y])
{
mark[next.x][next.y]=-tmp-N;
q.push(next);
}
if(cur.x>0) //来自A的水
{
int tmp=min(cur.x,b-cur.y);
next.y=cur.y+tmp;
next.x=cur.x-tmp;
if(!mark[next.x][next.y])
{
mark[next.x][next.y]=tmp+N;
q.push(next);
}
}
}
if(cur.x>0) //倒掉水
{
int tmp=cur.x;
next.x=0;
next.y=cur.y;
if(!mark[next.x][next.y])
{
mark[next.x][next.y]=2*N+tmp;
q.push(next);
}
}
if(cur.y>0)
{
int tmp=cur.y;
next.y=0;
next.x=cur.x;
if(!mark[next.x][next.y])
{
mark[next.x][next.y]=3*N+tmp;
q.push(next);
}
}
}
}
int main()
{
while(scanf("%d%d%d",&a,&b,&c)!=-1)
{
memset(mark,0,sizeof(mark));
flag=0;
bfs();
if(!flag)
printf("impossible\n");
}
return 0;
}
版权声明:本文博客原创文章,博客,未经同意,不得转载。
发布者:全栈程序员栈长,转载请注明出处:https://javaforall.cn/117660.html原文链接:https://javaforall.cn
边栏推荐
- Duchefa丨S0188盐酸大观霉素五水合物中英文说明书
- Which is the best online collaboration product? Microsoft loop, notion, flowus
- Abnova丨DNA 标记高质量控制测试方案
- leetcode:1755. 最接近目标值的子序列和
- 手机开户股票开户安全吗?我家比较偏远,有更好的开户途径么?
- 台风来袭!建筑工地该如何防范台风!
- Use of thread pool
- 序列联配Sequence Alignment
- Ros2 topic [01]: installing ros2 on win10
- CADD course learning (7) -- Simulation of target and small molecule interaction (semi flexible docking autodock)
猜你喜欢
When steam education enters personalized information technology courses
产品好不好,谁说了算?Sonar提出分析的性能指标,帮助您轻松判断产品性能及表现
The development of research tourism practical education helps the development of cultural tourism industry
Duchefa p1001 plant agar Chinese and English instructions
National Eye Care Education Conference, 2022 the Fourth Beijing International Youth eye health industry exhibition
mysql全面解析json/数组
研学旅游实践教育的开展助力文旅产业发展
渗透创客精神文化转化的创客教育
Which is the best online collaboration product? Microsoft loop, notion, flowus
Return to blowing marshland -- travel notes of zhailidong, founder of duanzhitang
随机推荐
Monorepo管理方法论和依赖安全
台风来袭!建筑工地该如何防范台风!
清除app data以及获取图标
产品好不好,谁说了算?Sonar提出分析的性能指标,帮助您轻松判断产品性能及表现
Web Service简单入门示例
线程池的使用
2022 Beijing eye health products exhibition, eye care products exhibition, China eye Expo held in November
小程序事件绑定
Point cloud file Dat file read save
[quick start of Digital IC Verification] 2. Through an example of SOC project, understand the architecture of SOC and explore the design process of digital system
PHP反序列化+MD5碰撞
Codeforces Round #804 (Div. 2) - A, B, C
CADD course learning (7) -- Simulation of target and small molecule interaction (semi flexible docking autodock)
2.8 basic knowledge of project management process
Implementation of redis unique ID generator
Is it safe to open a stock account by mobile phone? My home is relatively remote. Is there a better way to open an account?
Duchefa d5124 md5a medium Chinese and English instructions
When steam education enters personalized information technology courses
Clear app data and get Icon
小程序项目结构