当前位置:网站首页>poj 3414 Pots (bfs+线索)
poj 3414 Pots (bfs+线索)
2022-07-05 20:48:00 【全栈程序员站长】
大家好,又见面了,我是全栈君,今天给大家准备了Idea注册码。
Pots
Time Limit: 1000MS | Memory Limit: 65536K | |||
---|---|---|---|---|
Total Submissions: 10071 | Accepted: 4237 | Special Judge |
Description
You are given two pots, having the volume of A and B liters respectively. The following operations can be performed:
- FILL(i) fill the pot i (1 ≤ i ≤ 2) from the tap;
- DROP(i) empty the pot i to the drain;
- POUR(i,j) pour from pot i to pot j; after this operation either the pot j is full (and there may be some water left in the pot i), or the pot i is empty (and all its contents have been moved to the pot j).
Write a program to find the shortest possible sequence of these operations that will yield exactly C liters of water in one of the pots.
Input
On the first and only line are the numbers A, B, and C. These are all integers in the range from 1 to 100 and C≤max(A,B).
Output
The first line of the output must contain the length of the sequence of operations K. The following K lines must each describe one operation. If there are several sequences of minimal length, output any one of them. If the desired result can’t be achieved, the first and only line of the file must contain the word ‘impossible’.
Sample Input
3 5 4
Sample Output
6
FILL(2)
POUR(2,1)
DROP(1)
POUR(2,1)
FILL(2)
POUR(2,1)
思路:一共同拥有6种操作:把A中水倒掉,把A加满,把B里的水倒入A中。B和A类似。
罐子最大容积为100,设一个常量N=100, 开一个二维数组记录状态变化的值。
1、从水龙头往A里加水t,记录-t,
2、从水龙头往B里加水t,记录-t-N,
3、从B里面往A加水t,记录t
4、从A里面往B加水t。记录N+t
5、把A里水倒掉,记录2*N+t,(A原有水t)
6、把B里水倒掉,记录3*N+t,(B原有水t)
#include<stdio.h>
#include<queue>
#include<map>
#include<string>
#include<string.h>
using namespace std;
#define N 105
const int inf=0x1f1f1f1f;
int a,b,c,flag;
int mark[N][N];
struct node
{
int x,y,t;
friend bool operator<(node a,node b)
{
return a.t>b.t;
}
};
void prif(int x,int y) //递归输出路径
{
if(x==0&&y==0)
return ;
if(mark[x][y]>3*N)
{
prif(x,mark[x][y]-3*N);
printf("DROP(2)\n");
}
else if(mark[x][y]>2*N)
{
prif(mark[x][y]-2*N,y);
printf("DROP(1)\n");
}
else if(mark[x][y]>N)
{
int tmp=mark[x][y]-N;
prif(x+tmp,y-tmp);
printf("POUR(1,2)\n");
}
else if(mark[x][y]>0)
{
int tmp=mark[x][y];
prif(x-tmp,y+tmp);
printf("POUR(2,1)\n");
}
else if(mark[x][y]>-N)
{
int tmp=-mark[x][y];
prif(x-tmp,y);
printf("FILL(1)\n");
}
else if(mark[x][y]<-N)
{
int tmp=N+mark[x][y];
prif(x,y+tmp);
printf("FILL(2)\n");
}
}
void bfs()
{
priority_queue<node>q;
node cur,next;
mark[0][0]=inf; //该状态仅仅能出现一次。赋值为inf防止干扰其它值
mark[a][0]=-a;
mark[0][b]=-b-N;
cur.t=1;
cur.x=a;
cur.y=0;
q.push(cur);
cur.x=0;
cur.y=b;
q.push(cur);
while(!q.empty())
{
cur=q.top();
q.pop();
next.t=cur.t+1;
if(cur.x==c||cur.y==c)
{
flag=1;
printf("%d\n",cur.t);
prif(cur.x,cur.y);
return ;
}
if(cur.x<a) //向A加水
{
int tmp=a-cur.x;
next.y=cur.y;
next.x=a; //来自水龙头的水
if(!mark[next.x][next.y])
{
mark[next.x][next.y]=-tmp;
q.push(next);
}
if(cur.y>0) //来自B的水
{
int tmp=min(cur.y,a-cur.x);
next.x=cur.x+tmp;
next.y=cur.y-tmp;
if(!mark[next.x][next.y])
{
mark[next.x][next.y]=tmp;
q.push(next);
}
}
}
if(cur.y<b) //向B加水
{
int tmp=b-cur.y;
next.x=cur.x;
next.y=b; //来自水龙头的水
if(!mark[next.x][next.y])
{
mark[next.x][next.y]=-tmp-N;
q.push(next);
}
if(cur.x>0) //来自A的水
{
int tmp=min(cur.x,b-cur.y);
next.y=cur.y+tmp;
next.x=cur.x-tmp;
if(!mark[next.x][next.y])
{
mark[next.x][next.y]=tmp+N;
q.push(next);
}
}
}
if(cur.x>0) //倒掉水
{
int tmp=cur.x;
next.x=0;
next.y=cur.y;
if(!mark[next.x][next.y])
{
mark[next.x][next.y]=2*N+tmp;
q.push(next);
}
}
if(cur.y>0)
{
int tmp=cur.y;
next.y=0;
next.x=cur.x;
if(!mark[next.x][next.y])
{
mark[next.x][next.y]=3*N+tmp;
q.push(next);
}
}
}
}
int main()
{
while(scanf("%d%d%d",&a,&b,&c)!=-1)
{
memset(mark,0,sizeof(mark));
flag=0;
bfs();
if(!flag)
printf("impossible\n");
}
return 0;
}
版权声明:本文博客原创文章,博客,未经同意,不得转载。
发布者:全栈程序员栈长,转载请注明出处:https://javaforall.cn/117660.html原文链接:https://javaforall.cn
边栏推荐
- Open source SPL eliminates tens of thousands of database intermediate tables
- Abnova 环孢素A单克隆抗体,及其研究工具
- Duchefa cytokinin dihydrozeatin (DHZ) instructions
- Return to blowing marshland -- travel notes of zhailidong, founder of duanzhitang
- CADD course learning (7) -- Simulation of target and small molecule interaction (semi flexible docking autodock)
- Applet event binding
- Abbkine trakine F-actin Staining Kit (green fluorescence) scheme
- Abnova丨 CD81单克隆抗体相关参数和应用
- Abnova CD81 monoclonal antibody related parameters and Applications
- 小程序代码的构成
猜你喜欢
教你自己训练的pytorch模型转caffe(三)
IC popular science article: those things about Eco
ClickHouse 复制粘贴多行sql语句报错
Make Jar, Not War
National Eye Care Education Conference, 2022 the Fourth Beijing International Youth eye health industry exhibition
CADD course learning (7) -- Simulation of target and small molecule interaction (semi flexible docking autodock)
Abnova DNA marker high quality control test program
MySQL fully parses json/ arrays
Interpreting the daily application functions of cooperative robots
表单文本框的使用(二) 输入过滤(合成事件)
随机推荐
Abnova 环孢素A单克隆抗体,及其研究工具
Wanglaoji pharmaceutical's public welfare activity of "caring for the most lovely people under the scorching sun" was launched in Nanjing
Hongmeng OS' fourth learning
产品好不好,谁说了算?Sonar提出分析的性能指标,帮助您轻松判断产品性能及表现
Applet event binding
IC popular science article: those things about Eco
[UE4] unrealinsight obtains the real machine performance test report
2. < tag hash table, string> supplement: Sword finger offer 50 The first character DBC that appears only once
Duchefa细胞分裂素丨二氢玉米素 (DHZ)说明书
Classic implementation method of Hongmeng system controlling LED
常用的视图容器类组件
手机开户股票开户安全吗?我家比较偏远,有更好的开户途径么?
ProSci LAG3抗体的化学性质和应用说明
Fundamentals - configuration file analysis
3.3 project evaluation
Abnova丨CRISPR SpCas9 多克隆抗体方案
Analyze the knowledge transfer and sharing spirit of maker Education
Duchefa丨S0188盐酸大观霉素五水合物中英文说明书
Usaco3.4 "broken Gong rock" band raucous rockers - DP
Simple understanding of interpolation search