当前位置:网站首页>1204 character deletion operation (2)
1204 character deletion operation (2)
2022-07-06 07:59:00 【Zhanglilong 666】
Title Description
Delete the string after the specified position character m Characters ( Include characters in the specified position ).
Input requirements
Enter two integer numbers in the first line n and m, Respectively represent the... Of the string n Characters ( Non subscript ) And to delete m Characters .
In the second line, enter the original string to be processed .
Output requirements
Output the processed string .
sample input
7 6 I love movie
sample output
I love
#include<cstdio>
#include<cstring>
int main()
{
char a[1006];
int len,i,sum=0,j=0,n,m;
scanf("%d%d\n",&n,&m);
gets(a);
len=strlen(a);
m=m-1;
n=n-1;
for(i=0;i<len;i++){
if(i<n||i>(m+n)){
printf("%c",a[i]);
}
}
printf("\n");
}
边栏推荐
- The ECU of 21 Audi q5l 45tfsi brushes is upgraded to master special adjustment, and the horsepower is safely and stably increased to 305 horsepower
- 861. Score after flipping the matrix
- Asia Pacific Financial Media | art cube of "designer universe": Guangzhou community designers achieve "great improvement" in urban quality | observation of stable strategy industry fund
- 实现精细化生产, MES、APS、ERP必不可少
- 二叉树创建 & 遍历
- 【云原生】手把手教你搭建ferry开源工单系统
- [untitled]
- 继电反馈PID控制器参数自整定
- Le chemin du navigateur Edge obtient
- 1015 reversible primes (20 points) prime d-ary
猜你喜欢
Asia Pacific Financial Media | "APEC industry +" Western Silicon Valley invests 2trillion yuan in Chengdu Chongqing economic circle to catch up with Shanghai | stable strategy industry fund observatio
Nft智能合约发行,盲盒,公开发售技术实战--合约篇
A Closer Look at How Fine-tuning Changes BERT
Database basic commands
[count] [combined number] value series
[computer skills]
[untitled]
It's hard to find a job when the industry is in recession
The ECU of 21 Audi q5l 45tfsi brushes is upgraded to master special adjustment, and the horsepower is safely and stably increased to 305 horsepower
"Designer universe": "benefit dimension" APEC public welfare + 2022 the latest slogan and the new platform will be launched soon | Asia Pacific Financial Media
随机推荐
P3047 [USACO12FEB]Nearby Cows G(树形dp)
C # create database connection object SQLite database
Document 2 Feb 12 16:54
649. Dota2 Senate
Nft智能合约发行,盲盒,公开发售技术实战--合约篇
The Vice Minister of the Ministry of industry and information technology of "APEC industry +" of the national economic and information technology center led a team to Sichuan to investigate the operat
软件开发的一点随记
Launch APS system to break the problem of decoupling material procurement plan from production practice
MySQL view tablespace and create table statements
flask返回文件下载
2.10transfrom attribute
The ECU of 21 Audi q5l 45tfsi brushes is upgraded to master special adjustment, and the horsepower is safely and stably increased to 305 horsepower
Data governance: metadata management
Notes on software development
Step by step guide to setting NFT as an ens profile Avatar
. Net 6 learning notes: what is NET Core
CAD ARX gets the current viewport settings
A Closer Look at How Fine-tuning Changes BERT
Common functions for PHP to process strings
Leetcode question brushing record | 203_ Remove linked list elements