当前位置:网站首页>7-25 read numbers (loop switch)
7-25 read numbers (loop switch)
2022-07-03 01:35:00 【Big fish】
Enter an integer , Output the Pinyin corresponding to each number . When the integer is negative , First, the output fu
word . The Pinyin corresponding to ten numbers is as follows :
0: ling
1: yi
2: er
3: san
4: si
5: wu
6: liu
7: qi
8: ba
9: jiu
Input format :
Input gives an integer on a line , Such as :1234.
Tips : Integers include negative numbers 、 Zero and positive .
Output format :
Output the Pinyin corresponding to the integer in one line , The Pinyin of each number is separated by a space , There is no final space at the end of the line . Such as yi er san si.
sample input :
-600
No blank lines at the end
sample output :
fu liu ling ling
No blank lines at the end
There are two ways to achieve this :
Code 1:
#include<stdio.h>
int main()
{
int num = 0;
int a[11] = { 0 };
scanf("%d", &num);
if (num < 0)
{
printf("fu ");
num *= -1;
}
if (num == 0)
{
printf("ling");
}
int k = 0,i=0;
while (num)// Store each bit of data in the array .
{
a[i] = num % 10;
i++;
num /= 10;
}
k = --i;
for(int i=k;i>=0;i--)// Print each bit in turn , Last, don't print spaces
{
switch (a[i])
{
case 0:
if (i == 0)
{
printf("ling");
break;
}
printf("ling ");
break;
case 1:
if (i == 0)
{
printf("yi");
break;
}
printf("yi ");
break;
case 2:
if (i == 0)
{
printf("er");
break;
}
printf("er ");
break;
case 3:
if (i == 0)
{
printf("san");
break;
}
printf("san ");
break;
case 4:
if (i == 0)
{
printf("si");
break;
}
printf("si ");
break;
case 5:
if (i == 0)
{
printf("wu");
break;
}
printf("wu ");
break;
case 6:
if (i == 0)
{
printf("liu");
break;
}
printf("liu ");
break;
case 7:
if (i == 0)
{
printf("qi");
break;
}
printf("qi ");
break;
case 8:
if (i == 0)
{
printf("ba");
break;
}
printf("ba ");
break;
case 9:
if (i == 0)
{
printf("jiu");
break;
}
printf("jiu ");
break;
}
}
return 0;
}
result :
test result :
Code 2:
#include<stdio.h>
int main()
{
int num = 0;
scanf("%d", &num);
if (num < 0)
{
printf("fu ");
num *= -1;
}
if (num == 0)
printf("ling");
int t = num;
int i = 1;
while (num)// This part is about num Figure out the number of digits
{
i *= 10;
num /= 10;
}
i = i / 10;
int m = 0,d=0;
while(i)// Print directly from the top
{
m = t / i;
d = m % 10;
i /= 10;
switch (d)
{
case 0:
if (i == 0)
{
printf("ling");
break;
}
printf("ling "); break;
case 1:
if (i == 0)
{
printf("yi");
break;
}
printf("yi "); break;
case 2:
if (i == 0)
{
printf("er");
break;
}
printf("er "); break;
case 3:
if (i == 0)
{
printf("san");
break;
}
printf("san "); break;
case 4:
if (i == 0)
{
printf("si");
break;
}
printf("si "); break;
case 5:
if (i == 0)
{
printf("wu");
break;
}
printf("wu "); break;
case 6:
if (i == 0)
{
printf("liu");
break;
}
printf("liu "); break;
case 7:
if (i == 0)
{
printf("qi");
break;
}
printf("qi "); break;
case 8:
if (i == 0)
{
printf("ba");
break;
}
printf("ba "); break;
case 9:
if (i == 0)
{
printf("jiu");
break;
}
printf("jiu "); break;
}
}
return 0;
}
test result :
The problem itself is not difficult , It's easy to grasp the printing order of this problem , In fact, I have learned data structure , Stack to achieve the best .
边栏推荐
- 【面试题】1369- 什么时候不能使用箭头函数?
- Meituan dynamic thread pool practice ideas, open source
- [androd] module dependency replacement of gradle's usage skills
- 【数据挖掘】任务5:K-means/DBSCAN聚类:双层正方形
- CF1617B Madoka and the Elegant Gift、CF1654C Alice and the Cake、 CF1696C Fishingprince Plays With Arr
- wirehark数据分析与取证A.pacapng
- leetcode 6103 — 从树中删除边的最小分数
- Using tensorboard to visualize the model, data and training process
- dotConnect for PostgreSQL数据提供程序
- Now that the teenager has returned, the world's fireworks are the most soothing and ordinary people return to work~
猜你喜欢
Force buckle 204 Count prime
A simple tool for analyzing fgui dependencies
Scheme and practice of cold and hot separation of massive data
Niu Ke swipes questions and clocks in
[data mining] task 6: DBSCAN clustering
C#应用程序界面开发基础——窗体控制(3)——文件类控件
Tâche 6: regroupement DBSCAN
Using tensorboard to visualize the model, data and training process
音程的知识的总结
【數據挖掘】任務6:DBSCAN聚類
随机推荐
Tp6 fast installation uses mongodb to add, delete, modify and check
Openresty cache
MySQL foundation 07-dcl
海量数据冷热分离方案与实践
After reading this article, I will teach you to play with the penetration test target vulnhub - drivetingblues-9
Test shift right: Elk practice of online quality monitoring
d. LDC build shared library
【QT】自定义控件的封装
一比特苦逼程序員的找工作經曆
[fh-gfsk] fh-gfsk signal analysis and blind demodulation research
强化学习 Q-learning 实例详解
C#应用程序界面开发基础——窗体控制(4)——选择类控件
C language course information management system
C语言课程信息管理系统
Mathematical knowledge: step Nim game game game theory
测试右移:线上质量监控 ELK 实战
leetcode刷题_两数之和 II - 输入有序数组
Create your first Kivy program Hello word (tutorial includes source code)
数学知识:Nim游戏—博弈论
Meituan dynamic thread pool practice ideas, open source