当前位置:网站首页>1037 Magic Coupon
1037 Magic Coupon
2022-07-02 05:33:00 【Brosto_Cloud】
The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product... but hey, magically, they have some coupons with negative N's!
For example, given a set of coupons { 1 2 4 −1 }, and a set of product values { 7 6 −2 −3 } (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.
Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.
Input Specification:
Each input file contains one test case. For each case, the first line contains the number of coupons NC, followed by a line with NC coupon integers. Then the next line contains the number of products NP, followed by a line with NP product values. Here 1≤NC,NP≤105, and it is guaranteed that all the numbers will not exceed 230.
Output Specification:
For each test case, simply print in a line the maximum amount of money you can get back.
Sample Input:
4
1 2 4 -1
4
7 6 -2 -3
Sample Output:
43
在输入的时候就把两组数据中的正负数分开存放,正数从大到小排序,负数从小到大排序,正数和正数相乘,负数和负数相乘,再加起来即可。
#include <iostream>
#include <algorithm>
using namespace std;
long long n1, n2, ans, ax, bx, ay, by; //x代表正数个数,y代表负数个数
long long a[100010], b[100010], a1[100010], b1[100010];
int main() {
cin >> n1;
long long t;
for (int i = 1; i <= n1; i++) {
cin >> t;
if (t > 0) {
a[++ax] = t;
}
if (t < 0) {
a1[++ay] = t;
}
}
cin >> n2;
for (int i = 1; i <= n2; i++) {
cin >> t;
if (t > 0) {
b[++bx] = t;
}
if (t < 0) {
b1[++by] = t;
}
}
sort(a + 1, a + 1 + ax, greater<int>());
sort(b + 1, b + 1 + bx, greater<int>());
sort(a1 + 1, a1 + 1 + ay);
sort(b1 + 1, b1 + 1 + by);
int i = 1, j = 1;
while (i <= ax && j <= bx) {
ans += a[i] * b[j];
i++;
j++;
}
i = 1, j = 1;
while (i <= ay && j <= by) {
ans += a1[i] * b1[j];
i++;
j++;
}
cout << ans;
return 0;
}
边栏推荐
- MySQL foundation --- query (learn MySQL foundation in 1 day)
- Fabric. JS 3 APIs to set canvas width and height
- Sliding window on the learning road
- Gee dataset: chirps pentad high resolution global grid rainfall dataset
- Gee data set: export the distribution and installed capacity of hydropower stations in the country to CSV table
- Nodejs (02) - built in module
- ERP management system development and design existing source code
- Fabric. JS iText sets the color and background color of the specified text
- Principle and implementation of parallax effect
- Centos8 installation mysql8.0.22 tutorial
猜你喜欢
Black Horse Notes - - set Series Collection
Fabric. JS iText set italics manually
Fabric. JS upload local image to canvas background
Gee series: Unit 1 Introduction to Google Earth engine
Gee: remote sensing image composite and mosaic
Brew install * failed, solution
Gee: analyze the change of spatial centroid of remote sensing image [centroid acquisition analysis]
Fabric.js 渐变
Gee data set: export the distribution and installed capacity of hydropower stations in the country to CSV table
Gee: use of common mask functions in remote sensing image processing [updatemask]
随机推荐
Gee data set: export the distribution and installed capacity of hydropower stations in the country to CSV table
Gee: use of common mask functions in remote sensing image processing [updatemask]
Zzuli:1064 encrypted characters
RNN recurrent neural network
Fabric.js 自由绘制矩形
视差特效的原理和实现方法
Fabric. JS iText superscript and subscript
Fabric. JS 3 APIs to set canvas width and height
Here comes a new chapter in the series of data conversion when exporting with easyexcel!
数据库批量插入数据
Gee: explore the change of water area in the North Canal basin over the past 30 years [year by year]
I want to understand the swift code before I learn it. I understand it
Global and Chinese markets for marine selective catalytic reduction systems 2022-2028: Research Report on technology, participants, trends, market size and share
如何写出好代码 — 防御式编程指南
Generate QR code
延时队列两种实现方式
Record sentry's path of stepping on the pit
Zzuli:1061 sequential output of digits
Financial portal related information
Database batch insert data