当前位置:网站首页>MPLS experiment
MPLS experiment
2022-07-05 06:19:00 【i am okay】
One 、 Experimental topology and experimental requirements
Two 、 Experimental configuration
R1
interface GigabitEthernet0/0/0
ip address 192.168.2.1 255.255.255.0
interface LoopBack0
ip address 192.168.1.1 255.255.255.0
ip route-static 192.168.3.0 255.255.255.0 192.168.2.2
ip route-static 192.168.4.0 255.255.255.0 192.168.2.2
R2
ip vpn-instance a1
// establish VPN Space
ipv4-family
//DR value
route-distinguisher 2:2
vpn-target 2:2 export-extcommunity
//TR value
vpn-target 2:2 import-extcommunity
ip vpn-instance b1
ipv4-family
route-distinguisher 1:1
vpn-target 1:1 export-extcommunity
vpn-target 1:1 import-extcommunity
mpls lsr-id 2.2.2.2
// Appoint mplsid1 Number
mpls
// Turn on mpls
mpls ldp
interface GigabitEthernet0/0/0
ip address 23.1.1.1 255.255.255.0
mpls
// On the interface mpls
mpls ldp
interface GigabitEthernet0/0/1
ip binding vpn-instance b1
// To put VPN Bind the port first and then configure the address , Otherwise IP The address will appear in the common routing table
ip address 192.168.2.2 255.255.255.0
interface GigabitEthernet0/0/2
ip binding vpn-instance a1
ip address 192.168.2.2 255.255.255.0
interface LoopBack0
ip address 2.2.2.2 255.255.255.255
bgp 1
router-id 2.2.2.2
peer 4.4.4.4 as-number 1
peer 4.4.4.4 connect-interface LoopBack0
ipv4-family unicast
undo synchronization
peer 4.4.4.4 enable
ipv4-family vpnv4
policy vpn-target
peer 4.4.4.4 enable
ipv4-family vpn-instance a1
// stay bgp Import VPN a1 The routing
import-route rip 1
ipv4-family vpn-instance b1
import-route direct
// stay bgp towards VPN b1 Import static and direct routes , Can't write , Because handwriting bgp Can't label the second layer
import-route static
ospf 1 router-id 2.2.2.2
area 0.0.0.0
network 2.2.2.2 0.0.0.0
network 23.1.1.1 0.0.0.0
rip 1 vpn-instance a1
// by VPN Spatial dynamic routing protocol
undo summary
version 2
network 192.168.2.0
import-route bgp
ip route-static vpn-instance b1 192.168.1.0 255.255.255.0 192.168.2.1
R3
mpls lsr-id 3.3.3.3
mpls
mpls ldp
interface GigabitEthernet0/0/0
ip address 34.1.1.1 255.255.255.0
mpls
mpls ldp
interface GigabitEthernet0/0/1
ip address 23.1.1.2 255.255.255.0
mpls
mpls ldp
interface GigabitEthernet0/0/2
interface LoopBack0
ip address 3.3.3.3 255.255.255.255
ospf 1 router-id 3.3.3.3
area 0.0.0.0
network 3.3.3.3 0.0.0.0
network 23.1.1.2 0.0.0.0
network 34.1.1.1 0.0.0.0
R4
sysname R4
ip vpn-instance a1
ipv4-family
route-distinguisher 2:2
vpn-target 2:2 export-extcommunity
vpn-target 2:2 import-extcommunity
ip vpn-instance b1
ipv4-family
route-distinguisher 1:1
vpn-target 1:1 export-extcommunity
vpn-target 1:1 import-extcommunity
mpls lsr-id 4.4.4.4
mpls
mpls ldp
interface GigabitEthernet0/0/0
ip binding vpn-instance b1
ip address 192.168.3.2 255.255.255.0
interface GigabitEthernet0/0/1
ip address 34.1.1.2 255.255.255.0
mpls
mpls ldp
interface GigabitEthernet0/0/2
ip binding vpn-instance a1
ip address 192.168.3.2 255.255.255.0
interface GigabitEthernet4/0/0
ip address 47.1.1.1 255.255.255.0
interface NULL0
interface LoopBack0
ip address 4.4.4.4 255.255.255.255
bgp 1
router-id 4.4.4.4
peer 2.2.2.2 as-number 1
peer 2.2.2.2 connect-interface LoopBack0
ipv4-family unicast
undo synchronization
peer 2.2.2.2 enable
ipv4-family vpnv4
policy vpn-target
peer 2.2.2.2 enable
ipv4-family vpn-instance a1
import-route ospf 2
ipv4-family vpn-instance b1
import-route direct
import-route static
ospf 1 router-id 4.4.4.4
area 0.0.0.0
network 4.4.4.4 0.0.0.0
network 34.1.1.2 0.0.0.0
ospf 2 router-id 4.4.4.4 vpn-instance a1
import-route bgp
area 0.0.0.0
network 192.168.3.2 0.0.0.0
ip route-static vpn-instance a1 192.168.4.0 255.255.255.0 192.168.3.1
ip route-static vpn-instance b1 192.168.4.0 255.255.255.0 192.168.3.1
R5
interface GigabitEthernet0/0/1
ip address 192.168.3.1 255.255.255.0
interface LoopBack0
ip address 192.168.4.1 255.255.255.0
ip route-static 192.168.1.0 255.255.255.0 192.168.3.2
ip route-static 192.168.2.0 255.255.255.0 192.168.3.2
R6
interface GigabitEthernet0/0/0
ip address 192.168.2.1 255.255.255.0
interface LoopBack0
ip address 192.168.1.1 255.255.255.0
rip 1
undo summary
version 2
network 192.168.1.0
network 192.168.2.0
R7
interface GigabitEthernet0/0/0
ip address 192.168.3.1 255.255.255.0
interface GigabitEthernet0/0/1
ip address 47.1.1.2 255.255.255.0
interface GigabitEthernet0/0/2
interface LoopBack0
ip address 192.168.4.2 255.255.255.0
ospf 1 router-id 7.7.7.7
area 0.0.0.0
network 192.168.3.1 0.0.0.0
network 192.168.4.2 0.0.0.0
ip route-static 0.0.0.0 0.0.0.0 192.168.3.2
边栏推荐
- Data visualization chart summary (II)
- 博弈论 AcWing 894. 拆分-Nim游戏
- [rust notes] 16 input and output (Part 1)
- SQLMAP使用教程(二)实战技巧一
- 1040 Longest Symmetric String
- NotImplementedError: Cannot convert a symbolic Tensor (yolo_boxes_0/meshgrid/Size_1:0) to a numpy ar
- 【Rust 笔记】16-输入与输出(下)
- Shutter web hardware keyboard monitoring
- Is it impossible for lamda to wake up?
- JS quickly converts JSON data into URL parameters
猜你喜欢
区间问题 AcWing 906. 区间分组
背包问题 AcWing 9. 分组背包问题
Leetcode stack related
Appium automation test foundation - Summary of appium test environment construction
实时时钟 (RTC)
MySQL advanced part 1: stored procedures and functions
[2021]IBRNet: Learning Multi-View Image-Based Rendering Qianqian
栈 AcWing 3302. 表达式求值
Series of how MySQL works (VIII) 14 figures explain the atomicity of MySQL transactions and the principle of undo logging
Introduction to LVS [unfinished (semi-finished products)]
随机推荐
Chapter 6 relational database theory
1.15 - input and output system
QQ电脑版取消转义符输入表情
【Rust 笔记】14-集合(下)
Records of some tools 2022
【Rust 笔记】16-输入与输出(下)
博弈论 AcWing 892. 台阶-Nim游戏
Network security skills competition in Secondary Vocational Schools -- a tutorial article on middleware penetration testing in Guangxi regional competition
容斥原理 AcWing 890. 能被整除的数
1039 Course List for Student
博弈论 AcWing 891. Nim游戏
Leetcode heap correlation
How to set the drop-down arrow in the spinner- How to set dropdown arrow in spinner?
Currently clicked button and current mouse coordinates in QT judgment interface
Spark中groupByKey() 和 reduceByKey() 和combineByKey()
In depth analysis of for (VaR I = 0; I < 5; i++) {settimeout (() => console.log (I), 1000)}
阿里巴巴成立企业数智服务公司“瓴羊”,聚焦企业数字化增长
11-gorm-v2-03-basic query
QQ computer version cancels escape character input expression
Appium foundation - use the first demo of appium