当前位置:网站首页>1039 Course List for Student
1039 Course List for Student
2022-07-05 06:00:00 【Brosto_ Cloud】
Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.
Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤40,000), the number of students who look for their course lists, and K (≤2,500), the total number of courses. Then the student name lists are given for the courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students Ni (≤200) are given in a line. Then in the next line, Ni student names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.
Output Specification:
For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student's name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.
Sample Input:
11 5
4 7
BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
1 4
ANN0 BOB5 JAY9 LOR6
2 7
ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
3 1
BOB5
5 9
AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9
Sample Output:
ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0
Use map、set Containers ;
map Implement string mapping ,set Realize the automatic sorting of courses from small to large .
#include <iostream>
#include <vector>
#include <algorithm>
#include <string>
#include <set>
#include <map>
using namespace std;
map<string, set<int>>m;
int n, k;
map<string, int>cnt;
int main() {
cin >> n >> k;
int c, num; // Course number , The number of students who choose courses
string name;
for (int i = 0; i < k; i++) {
cin >> c >> num;
for (int j = 0; j < num; j++) {
cin >> name;
cnt[name]++;
m[name].insert(c);
}
}
for (int i = 0; i < n; i++) {
cin >> name;
cout << name << ' ' << cnt[name];
for (set<int>::iterator it = m[name].begin(); it != m[name].end(); it++) {
cout << ' ' << *it;
}
if (i != n - 1) {
cout << endl;
}
}
return 0;
}
边栏推荐
- A misunderstanding about the console window
- 【Rust 笔记】14-集合(下)
- Maximum number of "balloons"
- 从Dijkstra的图灵奖演讲论科技创业者特点
- Sword finger offer 04 Search in two-dimensional array
- API related to TCP connection
- One question per day 2047 Number of valid words in the sentence
- 每日一题-搜索二维矩阵ps二维数组的查找
- Detailed explanation of expression (csp-j 2021 expr) topic
- Graduation project of game mall
猜你喜欢
Sword finger offer 53 - I. find the number I in the sorted array
QQ电脑版取消转义符输入表情
Solution to the palindrome string (Luogu p5041 haoi2009)
[article de jailhouse] jailhouse hypervisor
LeetCode 0107.二叉树的层序遍历II - 另一种方法
[jailhouse article] performance measurements for hypervisors on embedded ARM processors
Implement an iterative stack
【云原生】微服务之Feign自定义配置的记录
leetcode-6108:解密消息
剑指 Offer 53 - I. 在排序数组中查找数字 I
随机推荐
【实战技能】如何做好技术培训?
Graduation project of game mall
R language [import and export of dataset]
Configuration and startup of kubedm series-02-kubelet
【Rust 笔记】14-集合(下)
Wazuh开源主机安全解决方案的简介与使用体验
数据可视化图表总结(二)
Personal developed penetration testing tool Satania v1.2 update
2022 pole technology communication arm virtual hardware accelerates the development of Internet of things software
The connection and solution between the shortest Hamilton path and the traveling salesman problem
Introduction and experience of wazuh open source host security solution
API related to TCP connection
QT判断界面当前点击的按钮和当前鼠标坐标
leetcode-6109:知道秘密的人数
【Rust 笔记】15-字符串与文本(下)
Brief introduction to tcp/ip protocol stack
leetcode-6111:螺旋矩阵 IV
Control Unit 控制部件
多屏电脑截屏会把多屏连着截下来,而不是只截当前屏
ALU逻辑运算单元