当前位置:网站首页>Rock-paper-scissors
Rock-paper-scissors
2022-07-07 23:39:00 【Yuesi】
Topic :
Stone scissors paper is a common guessing game . Stone is better than scissors , Scissors are better than cloth , Busson stone . If two people punch the same way , It's a draw .
One day , Small AA And small BB Just playing with stone scissors and paper . It's known that their fists are periodic , such as :“ stone - cloth - stone - scissors - stone - cloth - stone - scissors ……”, That is to say “ stone - cloth - stone - scissors ” For the cycle of . Excuse me, , Small AA And small BB Than the NN After the round , Who wins more rounds ?
Input format
The input contains three lines .
The first line contains three integers :N,NA,NB, They are better than N round , Small AA The cycle length of the punch , Small BB The cycle length of the punch .0 < N,NA,NB < 1000<N,NA,NB<100.
The second line contains NA It's an integer , It means small A The law of punching .
The third line contains NB It's an integer , It means small B The law of punching .
among ,0 Express “ stone ”,2 Express “ scissors ”,5 Express “ cloth ”. Two adjacent integers are separated by a single space .
Output format
Output one line , If small A More rounds won , Output "A"; If small B More rounds won , Output "B"; If the two are even , Output “draw”.
Tips
For test data , The guessing process is :
A:0 2 5 0 2 5 0 2 5 0
B:0 5 0 2 0 5 0 2 0 5
AA Win. 44 round ,BB Win. 22 round , The two sides are even 44 round , therefore AA More rounds won .
Extra space at the end of each line when outputting , It doesn't affect the correctness of the answer
The sample input
10 3 4
0 2 5
0 5 0 2
Sample output
A
#include<bits/stdc++.h>
using namespace std;
int main(){
int a[400],b[400];
int n,a1,a2;
int k1=0,k2=0,ping=0;
scanf("%d%d%d",&n,&a1,&a2);
for(int i=1;i<=a1;i++){
scanf("%d",&a[i]);
}
for(int i=1;i<=a2;i++){
scanf("%d",&b[i]);
}
if(a1<n){
for(int i=a1+1;i<=n;i++){
if(i%a1==0){
a[i]=a[a1];
}else{
a[i]=a[i%a1];
}
}
}
if(a2<n){
for(int i=a2+1;i<=n;i++){
if(i%a2==0){
b[i]=b[a2];
}else{
b[i]=b[i%a2];
}
}
}
for(int i=1;i<=n;i++){
if(a[i]!=b[i]){
if(a[i]==0){
if(b[i]==2){
k1++;
}
if(b[i]==5){
k2++;
}
}
if(a[i]==2){
if(b[i]==5){
k1++;
}
if(b[i]==0){
k2++;
}
}
if(a[i]==5){
if(b[i]==0){
k1++;
}
if(b[i]==2){
k2++;
}
}
}
if(a[i]==b[i]){
ping++;
}
}
if(k1==k2){
printf("draw\n");
}
if(k1>k2){
printf("A\n");
}
if(k1<k2){
printf("B\n");
}
return 0;
}
边栏推荐
- 8.31 Tencent interview
- B_QuRT_User_Guide(37)
- 包装行业智能供应链S2B2B商城解决方案:开辟电商消费新生态
- Ora-02437 failed to verify the primary key violation
- Mobile heterogeneous computing technology - GPU OpenCL programming (basic)
- B_ QuRT_ User_ Guide(38)
- 0-1 knapsack problem
- Svn relocation
- 生鲜行业数字化采购管理系统:助力生鲜企业解决采购难题,全程线上化采购执行
- 通达信买基金安全吗?
猜你喜欢
C method question 1
Interface
[compilation principle] lexical analysis design and Implementation
SAP HR奖罚信息导出
关于CH32库函数与STM32库函数的区别
KeePass realizes automatic input of web pages
Digital procurement management system for fresh food industry: help fresh food enterprises solve procurement problems and implement online procurement throughout the process
Benchmarking Detection Transfer Learning with Vision Transformers(2021-11)
SAP HR 劳动合同信息 0016
B_ QuRT_ User_ Guide(36)
随机推荐
B_QuRT_User_Guide(36)
家用电器行业渠道商协同系统解决方案:助力家电企业快速实现渠道互联网化
ASP. Net core middleware request processing pipeline
Class C design questions
SAP HR reward and punishment information export
648. Word replacement
SQL database execution problems
Anxinco EC series modules are connected to the multi protocol access products of onenet Internet of things open platform
Markdown
Oracle string sorting
ASP. Net open web page
Home appliance industry channel business collaboration system solution: help home appliance enterprises quickly realize the Internet of channels
【7.5】15. 三数之和
[stm32+esp8266 connects to Tencent cloud IOT development platform 3] stm32+esp8266-01s dynamically registers devices on Tencent cloud (at instruction mode) -- with source code
As a new force, chenglian premium products was initially injected, and the shares of relevant listed companies rose 150% in response
One week learning summary of STL Standard Template Library
Anti climbing means cracking the second
One of the anti climbing methods
B / Qurt Utilisateur Guide (36)
New potential energy of industrial integration, Xiamen station of city chain technology digital summit successfully held