当前位置:网站首页>Rock-paper-scissors

Rock-paper-scissors

2022-07-07 23:39:00 Yuesi

Rock-paper-scissors

Topic
Stone scissors paper is a common guessing game . Stone is better than scissors , Scissors are better than cloth , Busson stone . If two people punch the same way , It's a draw .

One day , Small AA And small BB Just playing with stone scissors and paper . It's known that their fists are periodic , such as :“ stone - cloth - stone - scissors - stone - cloth - stone - scissors ……”, That is to say “ stone - cloth - stone - scissors ” For the cycle of . Excuse me, , Small AA And small BB Than the NN After the round , Who wins more rounds ?

Input format
The input contains three lines .

The first line contains three integers :N,NA,NB, They are better than N round , Small AA The cycle length of the punch , Small BB The cycle length of the punch .0 < N,NA,NB < 1000<N,NA,NB<100.

The second line contains NA It's an integer , It means small A The law of punching .

The third line contains NB It's an integer , It means small B The law of punching .

among ,0 Express “ stone ”,2 Express “ scissors ”,5 Express “ cloth ”. Two adjacent integers are separated by a single space .

Output format
Output one line , If small A More rounds won , Output "A"; If small B More rounds won , Output "B"; If the two are even , Output “draw”.

Tips
For test data , The guessing process is :
A:0 2 5 0 2 5 0 2 5 0
B:0 5 0 2 0 5 0 2 0 5

AA Win. 44 round ,BB Win. 22 round , The two sides are even 44 round , therefore AA More rounds won .

Extra space at the end of each line when outputting , It doesn't affect the correctness of the answer

The sample input
10 3 4
0 2 5
0 5 0 2
Sample output
A

#include<bits/stdc++.h>
using namespace std;
int main(){
    
	int a[400],b[400];
	int n,a1,a2;
	int k1=0,k2=0,ping=0;
	scanf("%d%d%d",&n,&a1,&a2);
	for(int i=1;i<=a1;i++){
    
		scanf("%d",&a[i]);
	} 
	for(int i=1;i<=a2;i++){
    
		scanf("%d",&b[i]);
	} 
	if(a1<n){
    
		for(int i=a1+1;i<=n;i++){
    
			if(i%a1==0){
    
				a[i]=a[a1];
			}else{
    
				a[i]=a[i%a1];
			}	
		}	
	}
	if(a2<n){
    
		for(int i=a2+1;i<=n;i++){
    
			if(i%a2==0){
    
				b[i]=b[a2];
			}else{
    
				b[i]=b[i%a2];
			}	
		}
	}
	for(int i=1;i<=n;i++){
    
		if(a[i]!=b[i]){
    
			if(a[i]==0){
    
				if(b[i]==2){
    
					k1++;
				}
				if(b[i]==5){
    
					k2++;
				}
			}
			if(a[i]==2){
    
				if(b[i]==5){
    
					k1++;
				}
				if(b[i]==0){
    
					k2++;
				}
			}
			if(a[i]==5){
    
				if(b[i]==0){
    
					k1++;
				}
				if(b[i]==2){
    
					k2++;
				}
			}
		}
		if(a[i]==b[i]){
    
			ping++;
		}
	}
	if(k1==k2){
    
		printf("draw\n");
	}
	if(k1>k2){
    
		printf("A\n");
	}
	if(k1<k2){
    
		printf("B\n");
	}
	return 0;
}

原网站

版权声明
本文为[Yuesi]所创,转载请带上原文链接,感谢
https://yzsam.com/2022/02/202202130556375147.html