当前位置:网站首页>1008 circular right shift of array elements (20 points)
1008 circular right shift of array elements (20 points)
2022-07-06 04:14:00 【White phoenix leans on the sword and returns】
An array A There is N(>0) It's an integer , On the premise that no other array is allowed , Loop each integer to the right M(≥0) A place , the A The data in is from (A0A1⋯AN−1) Transformation for (AN−M⋯AN−1A0A1⋯AN−M−1)( Last M The number loop moves to the front of M A place ). If you need to consider the program to move data as little as possible , How to design a way to move ?
Input format :
Each input contains a test case , The first 1 Line input N(1≤N≤100) and M(≥0); The first 2 Line input N It's an integer , Space between .
Output format :
In a row, the output loop shifts to the right M Sequence of integers after bits , Space between , There must be no extra spaces at the end of the sequence .
sample input :
6 2
1 2 3 4 5 6
sample output :
5 6 1 2 3 4
Topic analysis :
1. Use an intermediate variable to store the last item of the array
2. Let the last item of the array -1 Items move backward in turn
3. Let the first item = Intermediate variable
4. Output
The code is as follows :
C Language :
#include <stdio.h>
int main() {
int a[101];
int n, m;
scanf("%d%d", &n, &m);
for (int i = 0; i < n; i++) {
scanf("%d", &a[i]);
}
for (int i = 0; i < m; i++) {
int t = a[n - 1];
for (int j = n - 2; j >= 0; j--) {
a[j + 1] = a[j];
}
a[0] = t;
}
printf("%d", a[0]);
for (int i = 1; i < n; i++) {
printf(" %d", a[i]);
}
}
C++:
#include <iostream>
using namespace std;
int main() {
int a[101];
int n, m;
cin >> n >> m;
for (int i = 0; i < n; i++) {
cin >> a[i];
}
for (int i = 0; i < m; i++) {
int t = a[n - 1];
for (int j = n - 2; j >= 0; j--) {
a[j + 1] = a[j];
}
a[0] = t;
}
cout << a[0];
for (int i = 1; i < n; i++) {
cout << " " << a[i];
}
}
边栏推荐
- DM8 backup set deletion
- Pandora IOT development board learning (HAL Library) - Experiment 9 PWM output experiment (learning notes)
- Global and Chinese market of plasma separator 2022-2028: Research Report on technology, participants, trends, market size and share
- MySql數據庫root賬戶無法遠程登陸解决辦法
- Esp32 (based on Arduino) connects the mqtt server of emqx to upload information and command control
- Figure application details
- Global and Chinese markets for patent hole oval devices 2022-2028: Research Report on technology, participants, trends, market size and share
- 51nod 1130 n factorial length V2 (Stirling approximation)
- Record the pit of NETCORE's memory surge
- 20、 EEPROM memory (AT24C02) (similar to AD)
猜你喜欢
ESP32(基于Arduino)连接EMQX的Mqtt服务器上传信息与命令控制
Fundamentals of SQL database operation
Thread sleep, thread sleep application scenarios
CertBot 更新证书失败解决
Basic knowledge of binary tree, BFC, DFS
C (thirty) C combobox listview TreeView
Maxay paper latex template description
Web components series (VII) -- life cycle of custom components
题解:《单词覆盖还原》、《最长连号》、《小玉买文具》、《小玉家的电费》
[disassembly] a visual air fryer. By the way, analyze the internal circuit
随机推荐
Simple blog system
自动化测试的好处
Ipv4中的A 、B、C类网络及子网掩码
QML和QWidget混合开发(初探)
C (XXIX) C listbox CheckedListBox Imagelist
Understanding of processes, threads, coroutines, synchronization, asynchrony, blocking, non blocking, concurrency, parallelism, and serialization
Leetcode32 longest valid bracket (dynamic programming difficult problem)
Unity中几个重要类
ESP32_ FreeRTOS_ Arduino_ 1_ Create task
使用JS完成一个LRU缓存
《2022年中国银行业RPA供应商实力矩阵分析》研究报告正式启动
Mlapi series - 04 - network variables and network serialization [network synchronization]
[disassembly] a visual air fryer. By the way, analyze the internal circuit
Redis (replicate dictionary server) cache
Pandora IOT development board learning (HAL Library) - Experiment 9 PWM output experiment (learning notes)
P3033 [usaco11nov]cow steelchase g (similar to minimum path coverage)
51nod 1130 n factorial length V2 (Stirling approximation)
Basic use of MySQL (it is recommended to read and recite the content)
Global and Chinese market of plasma separator 2022-2028: Research Report on technology, participants, trends, market size and share
Stable Huawei micro certification, stable Huawei cloud database service practice