当前位置:网站首页>HDU - 1114 Piggy-Bank(完全背包)
HDU - 1114 Piggy-Bank(完全背包)
2022-07-02 15:18:00 【WA_自动机】
HDU - 1114 Piggy-Bank
Problem Description
Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid.
But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs!
Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it’s weight in grams.
Output
Print exactly one line of output for each test case. The line must contain the sentence “The minimum amount of money in the piggy-bank is X.” where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line “This is impossible.”.
Sample Input
3
10 110
2
1 1
30 50
10 110
2
1 1
50 30
1 6
2
10 3
20 4
Sample Output
The minimum amount of money in the piggy-bank is 60.
The minimum amount of money in the piggy-bank is 100.
This is impossible.
题目大意:有一个背包大小为E,现在只能装满F,问剩余的空间用一些,价值为p,质量为w的硬币装满,问最后装满之后用的硬币总价值是多少。
#include<iostream>
#include<cstring>
using namespace std;
const int N = 10010;
int dp[N];
int main()
{
int T;cin>>T;
while(T--)
{
memset(dp,0x3f,sizeof dp);
int e,f;cin>>e>>f;
int h=f-e;
int n;cin>>n;
dp[0]=0;
for(int i=1;i<=n;i++)
{
int p,w;cin>>p>>w;
for(int j=w;j<=h;j++)
dp[j]=min(dp[j],dp[j-w]+p);
}
if(dp[h]==0x3f3f3f3f) cout<<"This is impossible."<<endl;
else cout<<"The minimum amount of money in the piggy-bank is "<<dp[h]<<"."<<endl;
}
return 0;
}
边栏推荐
- Win10系统使用pip安装juypter notebook过程记录(安装在系统盘以外的盘)
- [essay solicitation activity] Dear developer, RT thread community calls you to contribute
- Changwan group rushed to Hong Kong stocks: the annual revenue was 289million, and Liu Hui had 53.46% voting rights
- visibilitychange – 指定标签页可见时,刷新页面数据
- Chmod command principle and usage details [easy to understand]
- Goodbye, shucang. Alibaba's data Lake construction strategy is really awesome!
- ceph 原理
- ROS knowledge point - message_filters
- 深度之眼(二)——矩阵及其基本运算
- Eye of depth (III) -- determinant of matrix
猜你喜欢
QWebEngineView崩溃及替代方案
The construction of scalable distributed database cluster and the partition design of oneproxy sub database
About me
Si446 usage record (II): generate header files using wds3
剑指 Offer 25. 合并两个排序的链表
QStyle实现自绘界面项目实战(二)
从收集到输出:盘点那些强大的知识管理工具——优秀笔记软件盘点(四)
Goodbye, shucang. Alibaba's data Lake construction strategy is really awesome!
Win10 system uses pip to install juypter notebook process record (installed on a disk other than the system disk)
The difference of message mechanism between MFC and QT
随机推荐
线性规划例题 投资的收益与风险
人生的开始
2022 interview questions
体验居家办公完成项目有感 | 社区征文
executescalar mysql_ExecuteScalar()
Qwebengineview crash and alternatives
ETH数据集下载及相关问题
简单介绍BASE64Encoder的使用
A case study of college entrance examination prediction based on multivariate time series
Sword finger offer 25 Merge two sorted linked lists
SSB threshold_ SSB modulation "suggestions collection"
Qstype implementation of self drawing interface project practice (II)
Microservice architecture practice: using Jenkins to realize automatic construction
chrome浏览器快速访问stackoverflow
Goodbye, shucang. Alibaba's data Lake construction strategy is really awesome!
The beginning of life
A few lines of code to complete RPC service registration and discovery
VScode知识点——常见报错
Chmod command principle and usage details [easy to understand]
PCL knowledge points - voxelized grid method for down sampling of point clouds