当前位置:网站首页>C - minute number V3
C - minute number V3
2022-07-07 23:39:00 【Yuesi】
recursive
C - Minute number V3
# subject
take n Divide into m More than 0 The sum of different numbers of ,1 2 Same as 2 1 Treat as the same division .
Output all schemes in dictionary order . Data guarantee existence solution , That is, there will be no 1+2+…m > n The situation of
## Input
2 Number n,m(1 <= m <= 10,1 <= n <= 50 ).
(1+2+…m > n)
## Output
In dictionary order , Output all schemes . Between the numbers , Divide... With spaces .
## The sample input :
13 3
## Sample output :
1 2 10
1 3 9
1 4 8
1 5 7
2 3 8
2 4 7
2 5 6
3 4 6
#include<bits/stdc++.h>
using namespace std;
int m,n;
int num[100]={
0};
void dfs(int u,int x)
{
if(u>m+1||x<0)
// Not in line with the question
// It's ready m I didn't get the sum of my share n and m Not enough and more than n
{
return;// Go back to the previous step
}
if(u==m+1&&x==0)
// In line with the meaning of the topic , Output arrangement , And return to the previous step
{
for(int i=1;i<m;i++)
{
cout<<num[i]<<" ";
// Separate with a space
}
cout<<num[m]<<endl;
return;
}
for(int i=num[u-1]+1;i<=x;i++)
{
num[u]=i;// Save each value
dfs(u+1,x-i);
// Must be written as x-i
// It can't be written as x( Add in the previous step x=x-i;) Wrong
}
}
int main(){
scanf("%d%d",&n,&m);
// take n Divide into m Share
dfs(1,n);// From the first , The remaining number is n
return 0;
}
边栏推荐
- Display the server hard disk image to the browser through Servlet
- 【7.5】15. 三数之和
- Markdown
- ASP. Net query implementation
- [stm32+esp8266 connects to Tencent cloud IOT development platform 3] stm32+esp8266-01s dynamically registers devices on Tencent cloud (at instruction mode) -- with source code
- Dependency injection 2 advantage lifecycle
- IDEA 2021.3. X cracking
- USB (XV) 2022-04-14
- Slam interview summary
- Interface
猜你喜欢
Anxinco esp32-a1s development board is adapted to Baidu dueros routine to realize online voice function
Ora-02437 failed to verify the primary key violation
Lm12 rolling heikin Ashi double K-line filter
Map operation execution process
Take you hand in hand to build feign with idea
As a new force, chenglian premium products was initially injected, and the shares of relevant listed companies rose 150% in response
The file format and extension of XLS do not match
包装行业智能供应链S2B2B商城解决方案:开辟电商消费新生态
postgis学习
Summary of SQL single table query 2020.7.27
随机推荐
Dependency injection
【leetcode】day1
8.31 Tencent interview
ASP. Net core middleware request processing pipeline
Design and implementation of spark offline development framework
As a new force, chenglian premium products was initially injected, and the shares of relevant listed companies rose 150% in response
C simple question one
FPGA basics catalog
B_ QuRT_ User_ Guide(37)
[experiment sharing] log in to Cisco devices through the console port
Class C design questions
Open source hardware small project: anxinco esp-c3f control ws2812
One of the anti climbing methods
USB (XIV) 2022-04-12
【汇总】看过的一些Panel与视频
[untitled]
ASP. Net open web page
Explain
POJ2392 SpaceElevator [DP]
B_QuRT_User_Guide(37)