当前位置:网站首页>C - minute number V3
C - minute number V3
2022-07-07 23:39:00 【Yuesi】
recursive
C - Minute number V3
# subject
take n Divide into m More than 0 The sum of different numbers of ,1 2 Same as 2 1 Treat as the same division .
Output all schemes in dictionary order . Data guarantee existence solution , That is, there will be no 1+2+…m > n The situation of
## Input
2 Number n,m(1 <= m <= 10,1 <= n <= 50 ).
(1+2+…m > n)
## Output
In dictionary order , Output all schemes . Between the numbers , Divide... With spaces .
## The sample input :
13 3
## Sample output :
1 2 10
1 3 9
1 4 8
1 5 7
2 3 8
2 4 7
2 5 6
3 4 6
#include<bits/stdc++.h>
using namespace std;
int m,n;
int num[100]={
0};
void dfs(int u,int x)
{
if(u>m+1||x<0)
// Not in line with the question
// It's ready m I didn't get the sum of my share n and m Not enough and more than n
{
return;// Go back to the previous step
}
if(u==m+1&&x==0)
// In line with the meaning of the topic , Output arrangement , And return to the previous step
{
for(int i=1;i<m;i++)
{
cout<<num[i]<<" ";
// Separate with a space
}
cout<<num[m]<<endl;
return;
}
for(int i=num[u-1]+1;i<=x;i++)
{
num[u]=i;// Save each value
dfs(u+1,x-i);
// Must be written as x-i
// It can't be written as x( Add in the previous step x=x-i;) Wrong
}
}
int main(){
scanf("%d%d",&n,&m);
// take n Divide into m Share
dfs(1,n);// From the first , The remaining number is n
return 0;
}
边栏推荐
猜你喜欢
建筑建材行业SRM供应商云协同管理平台解决方案,实现业务应用可扩展可配置
[compilation principle] lexical analysis design and Implementation
C inheritance and interface design polymorphism
Mobile heterogeneous computing technology - GPU OpenCL programming (basic)
城联优品作为新力量初注入,相关上市公司股价应声上涨150%
SAP HR 家庭成员信息
USB (XV) 2022-04-14
Take you hand in hand to build Eureka server with idea
SAP HR labor contract information 0016
C cat and dog
随机推荐
平衡二叉树【AVL树】——插入、删除
Anxinco EC series modules are connected to the multi protocol access products of onenet Internet of things open platform
【汇总】看过的一些Panel与视频
0-1背包问题
Oracle statistics by time
[summary] some panels and videos seen
【leetcode】day1
FPGA basics catalog
进度播报|广州地铁七号线全线29台盾构机全部完成始发
MySQL Index Optimization Practice I
高效的S2B2C电商系统,是这样帮助电子材料企业提升应变能力的
What if once again forgets the login password of raspberry pie? And you don't have a monitor yet! Today, I would like to introduce a method
B_QuRT_User_Guide(36)
Navicat connects Oracle
城联优品作为新力量初注入,相关上市公司股价应声上涨150%
2022第六季完美童模陕西总决赛圆满落幕
MySQL Architecture
SAP HR 家庭成员信息
C # exchange number, judge to pass the exam
【7.5】15. Sum of three numbers