当前位置:网站首页>DP:树DP
DP:树DP
2022-07-05 19:52:00 【全栈程序员站长】
大家好,又见面了,我是全栈君,今天给大家准备了Idea注册码。
The more, The Better
Time Limit: 6000/2000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 5414 Accepted Submission(s): 3217
Problem Description
ACboy非常喜欢玩一种战略游戏,在一个地图上,有N座城堡。每座城堡都有一定的宝物,在每次游戏中ACboy同意攻克M个城堡并获得里面的宝物。但因为地理位置原因。有些城堡不能直接攻克,要攻克这些城堡必须先攻克其它某一个特定的城堡。你能帮ACboy算出要获得尽量多的宝物应该攻克哪M个城堡吗?
Input
每一个測试实例首先包含2个整数,N,M.(1 <= M <= N <= 200);在接下来的N行里。每行包含2个整数。a,b. 在第 i 行,a 代表要攻克第 i 个城堡必须先攻克第 a 个城堡,假设 a = 0 则代表能够直接攻克第 i 个城堡。
b 代表第 i 个城堡的宝物数量, b >= 0。当N = 0, M = 0输入结束。
Output
对于每一个測试实例。输出一个整数。代表ACboy攻克M个城堡所获得的最多宝物的数量。
Sample Input
3 2
0 1
0 2
0 3
7 4
2 2
0 1
0 4
2 1
7 1
7 6
2 2
0 0
Sample Output
5
13
dp[i][j]表示以i为根节点j个子节点的最大值。#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<limits.h>
#include<vector>
typedef long long LL;
using namespace std;
const int maxn=220;
int v[maxn];
int n,m;
int dp[maxn][maxn];
vector<int>s[maxn];
void tree_dp(int n,int f)
{
int len=s[n].size();
dp[n][1]=v[n];
for(int i=0;i<len;i++)
{
if(f>1) tree_dp(s[n][i],f-1);
for(int j=f;j>=1;j--)
{
for(int k=1;k<=j;k++)
dp[n][j+1]=max(dp[n][j+1],dp[n][j+1-k]+dp[s[n][i]][k]);
}
}
}
int main()
{
int f;
while(~scanf("%d%d",&n,&m)&&(n+m))
{
v[0]=0;
memset(dp,0,sizeof(dp));
for(int i=0;i<=n;i++)
s[i].clear();
for(int i=1;i<=n;i++)
{
scanf("%d%d",&f,&v[i]);
s[f].push_back(i);
}
tree_dp(0,m+1);
printf("%d\n",dp[0][m+1]);
}
return 0;
}
Anniversary party
Time Limit: 1000MS
Memory Limit: 65536K
Total Submissions: 4329
Accepted: 2463
Description
There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.
Input
Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go N – 1 lines that describe a supervisor relation tree. Each line of the tree specification has the form:
L K
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line
0 0
Output
Output should contain the maximal sum of guests' ratings.
Sample Input
7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0
Sample Output
5
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<limits.h>
typedef long long LL;
using namespace std;
const int maxn=6005;
int dp[maxn][2],pre[maxn];
int visit[maxn],n;
void tree_dp(int x)
{
visit[x]=1;
for(int i=1;i<=n;i++)
{
// cout<<"111 "<<i<<endl;
if(!visit[i]&&pre[i]==x)
{
tree_dp(i);
dp[x][1]+=dp[i][0];
dp[x][0]+=max(dp[i][1],dp[i][0]);
}
}
}
int main()
{
while(~scanf("%d",&n))
{
memset(dp,0,sizeof(dp));
memset(visit,0,sizeof(visit));
memset(pre,0,sizeof(pre));
for(int i=1;i<=n;i++)
scanf("%d",&dp[i][1]);
int x,y,root;
while(~scanf("%d%d",&x,&y)&&(x+y))
{
pre[x]=y;
root=y;
}
while(pre[root])
root=pre[root];
// cout<<"fuck "<<root<<endl;
tree_dp(root);
printf("%d\n",max(dp[root][0],dp[root][1]));
}
return 0;
}
发布者:全栈程序员栈长,转载请注明出处:https://javaforall.cn/117734.html原文链接:https://javaforall.cn
边栏推荐
- 建议收藏,我的腾讯Android面试经历分享
- Debezium series: modify the source code to support drop foreign key if exists FK
- gst-launch的-v参数
- What are general items
- 力扣 1200. 最小绝对差
- S7-200SMART利用V90 MODBUS通信控制库控制V90伺服的具体方法和步骤
- 【FAQ】华为帐号服务报错 907135701的常见原因总结和解决方法
- Xaas trap: all things serve (possible) is not what it really needs
- UWB ultra wideband positioning technology, real-time centimeter level high-precision positioning application, ultra wideband transmission technology
- Force buckle 729 My schedule I
猜你喜欢
[hard core dry goods] which company is better in data analysis? Choose pandas or SQL
leetcode刷题:二叉树11(平衡二叉树)
webuploader文件上传 拖拽上传 进度监听 类型控制 上传结果监听控件
Fundamentals of deep learning convolutional neural network (CNN)
成功入职百度月薪35K,2022Android开发面试解答
Apprentissage du projet MMO I: préchauffage
leetcode刷题:二叉树17(从中序与后序遍历序列构造二叉树)
Postman core function analysis - parameterization and test report
Xaas trap: all things serve (possible) is not what it really needs
力扣 729. 我的日程安排表 I
随机推荐
Redis cluster simulated message queue
third-party dynamic library (libcudnn.so) that Paddle depends on is not configured correctl
不愧是大佬,字节大牛耗时八个月又一力作
leetcode刷题:二叉树16(路径总和)
leetcode刷题:二叉树17(从中序与后序遍历序列构造二叉树)
leetcode刷题:二叉树15(找树左下角的值)
随机数生成的四种方法|Random|Math|ThreadLocalRandom|SecurityRandom
【obs】QString的UTF-8中文转换到blog打印 UTF-8 char*
The city chain technology Digital Innovation Strategy Summit was successfully held
leetcode刷题:二叉树13(相同的树)
[AI framework basic technology] automatic derivation mechanism (autograd)
What is the core value of testing?
[Collection - industry solutions] how to build a high-performance data acceleration and data editing platform
C application interface development foundation - form control (6) - menu bar, toolbar and status bar controls
Debezium series: modify the source code to support UNIX_ timestamp() as DEFAULT value
线程池参数及合理设置
Thread pool parameters and reasonable settings
浅浅的谈一下ThreadLocalInsecureRandom
Is it safe to open a mobile stock account? Is it reliable?
UWB ultra wideband positioning technology, real-time centimeter level high-precision positioning application, ultra wideband transmission technology