当前位置:网站首页>Hdu2377bus pass (build more complex diagram +spfa)
Hdu2377bus pass (build more complex diagram +spfa)
2022-07-05 20:53:00 【Full stack programmer webmaster】
Hello everyone , I meet you again , I'm the king of the whole stack
Topic links :
Ideas :
The title is given to many stations . Then you need to find a community with the minimum distance from these stations .. So do it once for every station spfa. Then we get the maximum value of each community , Finally, scan every community , Get that minimum community .. There are also questions that require minimal id, So put it in order .
subject :
Bus Pass
Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 667 Accepted Submission(s): 271
Problem Description
You travel a lot by bus and the costs of all the seperate tickets are starting to add up.
Therefore you want to see if it might be advantageous for you to buy a bus pass.
The way the bus system works in your country (and also in the Netherlands) is as follows:
when you buy a bus pass, you have to indicate a center zone and a star value. You are allowed to travel freely in any zone which has a distance to your center zone which is less than your star value. For example, if you have a star value of one, you can only travel in your center zone. If you have a star value of two, you can also travel in all adjacent zones, et cetera.
You have a list of all bus trips you frequently make, and would like to determine the minimum star value you need to make all these trips using your buss pass. But this is not always an easy task. For example look at the following figure:
Here you want to be able to travel from A to B and from B to D. The best center zone is 7400, for which you only need a star value of 4. Note that you do not even visit this zone on your trips!
Input
On the first line an integert(1 <=t<= 100): the number of test cases. Then for each test case:
One line with two integersnz(2 <=nz<= 9 999) andnr(1 <=nr<= 10): the number of zones and the number of bus trips, respectively.
nz lines starting with two integers id i (1 <= id i <= 9 999) and mz i (1 <= mz i <= 10), a number identifying the i-th zone and the number of zones adjacent to it, followed by mz i integers: the numbers of the adjacent zones.
nr lines starting with one integer mr i (1 <= mr i <= 20), indicating the number of zones the ith bus trip visits, followed by mr i integers: the numbers of the zones through which the bus passes in the order in which they are visited.
All zones are connected, either directly or via other zones.
Output
For each test case:
One line with two integers, the minimum star value and the id of a center zone which achieves this minimum star value. If there are multiple possibilities, choose the zone with the lowest number.
Sample Input
1
17 2
7400 6 7401 7402 7403 7404 7405 7406
7401 6 7412 7402 7400 7406 7410 7411
7402 5 7412 7403 7400 7401 7411
7403 6 7413 7414 7404 7400 7402 7412
7404 5 7403 7414 7415 7405 7400
7405 6 7404 7415 7407 7408 7406 7400
7406 7 7400 7405 7407 7408 7409 7410 7401
7407 4 7408 7406 7405 7415
7408 4 7409 7406 7405 7407
7409 3 7410 7406 7408
7410 4 7411 7401 7406 7409
7411 5 7416 7412 7402 7401 7410
7412 6 7416 7411 7401 7402 7403 7413
7413 3 7412 7403 7414
7414 3 7413 7403 7404
7415 3 7404 7405 7407
7416 2 7411 7412
5 7409 7408 7407 7405 7415
6 7415 7404 7414 7413 7412 7416
Sample Output
4 7400
Source
lcy | We have carefully selected several similar problems for you: 27222363248229621598
The code is :
#include<cstdio>
#include<queue>
#include<iostream>
#include<algorithm>
#include<cstring>
#include<vector>
#define INF 0x3f3f3f3f
using namespace std;
const int maxn=9999+10;
int dis[maxn],id[maxn],max_dis[maxn];
bool vis[maxn];
vector<int>vec[maxn];
int t,n,bus,cal;
bool cmp(int a,int b)
{
return a<b;
}
void spfa(int st)
{
queue<int>Q;
while(!Q.empty()) Q.pop();
memset(vis,false,sizeof(vis));
memset(dis,INF,sizeof(dis));
Q.push(st);
dis[st]=0;
vis[st]=true;
while(!Q.empty())
{
int temp=Q.front();
Q.pop();
vis[temp]=false;
for(int i=0;i<vec[temp].size();i++)
{
if(dis[temp]+1<dis[vec[temp][i]])
{
dis[vec[temp][i]]=dis[temp]+1;
if(!vis[vec[temp][i]])
{
vis[vec[temp][i]]=true;
Q.push(vec[temp][i]);
}
}
}
}
}
void read_graph()
{
memset(max_dis,0,sizeof(max_dis));
int u;
scanf("%d%d",&n,&bus);
for(int i=1;i<=maxn;i++)
vec[i].clear();
for(int i=1;i<=n;i++)
{
scanf("%d%d",&id[i],&cal);
for(int j=1;j<=cal;j++)
{
scanf("%d",&u);
vec[id[i]].push_back(u);
}
}
while(bus--)
{
scanf("%d",&cal);
while(cal--)
{
int st;
scanf("%d",&st);
spfa(st);
for(int i=1;i<=n;i++)
{
if(dis[id[i]]>max_dis[id[i]])
max_dis[id[i]]=dis[id[i]];
}
}
}
int ans=999999999,ans_id;
sort(id+1,id+1+n,cmp);
for(int i=1;i<=n;i++)
{
if(max_dis[id[i]]<ans)
{
ans=max_dis[id[i]];
ans_id=id[i];
}
}
printf("%d %d\n",ans+1,ans_id);
}
int main()
{
scanf("%d",&t);
while(t--)
{
read_graph();
}
return 0;
}
Copyright notice : This article is an original blog article . Blog , Without consent , Shall not be reproduced .
Publisher : Full stack programmer stack length , Reprint please indicate the source :https://javaforall.cn/117648.html Link to the original text :https://javaforall.cn
边栏推荐
猜你喜欢
教你自己训练的pytorch模型转caffe(二)
研学旅游实践教育的开展助力文旅产业发展
学习机器人无从下手?带你体会当下机器人热门研究方向有哪些
Abnova丨DNA 标记高质量控制测试方案
phpstudy小皮的mysql点击启动后迅速闪退,已解决
2. < tag hash table, string> supplement: Sword finger offer 50 The first character DBC that appears only once
产品好不好,谁说了算?Sonar提出分析的性能指标,帮助您轻松判断产品性能及表现
中国的软件公司为什么做不出产品?00后抛弃互联网;B站开源的高性能API网关组件|码农周刊VIP会员专属邮件周报 Vol.097
ProSci LAG3抗体的化学性质和应用说明
示波器探头对信号源阻抗的影响
随机推荐
[quick start of Digital IC Verification] 2. Through an example of SOC project, understand the architecture of SOC and explore the design process of digital system
解析五育融合之下的steam教育模式
Abnova blood total nucleic acid purification kit pre installed relevant instructions
Abnova丨荧光染料 620-M 链霉亲和素方案
Open source SPL eliminates tens of thousands of database intermediate tables
mysql全面解析json/数组
Popular science | does poor English affect the NPDP exam?
Abnova total RNA Purification Kit for cultured cells Chinese and English instructions
Duchefa low melting point agarose PPC Chinese and English instructions
学习机器人无从下手?带你体会当下机器人热门研究方向有哪些
中国的软件公司为什么做不出产品?00后抛弃互联网;B站开源的高性能API网关组件|码农周刊VIP会员专属邮件周报 Vol.097
poj 3414 Pots (bfs+线索)
解读协作型机器人的日常应用功能
Abnova丨培养细胞总 RNA 纯化试剂盒中英文说明书
基于AVFoundation实现视频录制的两种方式
ts 之 类的简介、构造函数和它的this、继承、抽象类、接口
Is the securities account given by the school of Finance and business safe? Can I open an account?
Duchefa丨P1001植物琼脂中英文说明书
Make Jar, Not War
Use of form text box (II) input filtering (synthetic event)