当前位置:网站首页>Brush questions during summer vacation, ouch ouch
Brush questions during summer vacation, ouch ouch
2022-07-06 17:13:00 【Toothache, want to eat peach】
Because the recent work content does not involve programming
I haven't typed the code for a long time
Now because of the school curriculum
Let's review it quickly
The exam was a blast
School tears two lines
Plus, there are physical tests in October
Recently, there are various sports competitions
Ah, ah, ah, ah, ah, ah, ah, come on
The first question is
subject :
Calculate two 32 An integer A and B And !
Input Multiple groups of input data , Each group is in a row , Including two no more than binary 32 An integer .
Output Enter... For each group , Output the result in a separate line .
Sample input
1 2
-1 1
Sample output
3
0
Be careful : Limit input
#include<stdio.h>
int main()
{
long a, b;
while(scanf("%ld %ld", &a, &b)!=EOF)
{
printf("%ld\n", a+b);
}
return 0;
}
The second question is
subject :
Calculate two 32 An integer A and B And !
Input The first line of input data is an integer TT, Express TT Group data . And then TT In line , Each line has two integers A and B.
Output Enter... For each group , Output the result in a separate line .
Sample input
2
1 2
-1 1
Sample output
3
0
Be careful :
Scanner yes SDK1.5 A new class , You can use this class to create an object .
Scanner input=new Scanner(System.in);
input You can call nextInt()、next()、nextLine() Other methods
nextInt(): it only reads the int value, nextInt() places the cursor in
the same line after reading the input.next(): read the input only till the space. It can’t read two words
separated by space. Also, next() places the cursor in the same line
after reading the input.( Generally used for Strings )nextLine(): reads input including space between the words (that is,
it reads till the end of line \n). Once the input is read, nextLine()
positions the cursor in the next line.
import java.util.Scanner;
public class Main {
public static void main(final String[] args) {
Scanner sc = new Scanner(System.in);
int T = sc.nextInt();
long a, b;
for (int i = 0; i < T; i++) {
// There are only two numbers in each line
a = sc.nextInt();
b = sc.nextInt();
System.out.println(a + b);
}
sc.close();
}
}
Third question
subject :
Calculate two 32 An integer A and B And !
Input Multiple groups of input data , Each group is in a row , It includes two 32 An integer . If both integers are 0, End of input .
Output Enter... For each group , Output the result in a separate line .
Sample input
1 2
-1 1
0 0
Sample output
3
0
Be careful :
Judge the condition
import java.util.Scanner;
public class input3 {
public static void main(final String[] args) {
final Scanner sc = new Scanner(System.in);
long a, b;
a = sc.nextInt();
b = sc.nextInt();
while (a != 0 || b != 0){
System.out.println(a + b);
a = sc.nextInt();
b = sc.nextInt();
}
sc.close();
}
}
Fourth question
subject
A number of 32 Bit integer summation .
Input
Multiple groups of input data , Each group is in a row , It includes a number of 32 An integer . The number at the beginning of the line is the number of subsequent numbers in the line , If the value at the beginning of the line is 0, End of input .Output
Enter... For each group , Output the result in a separate line .Sample input
5 1 2 3 4 5
2 -1 1
0
Sample output
15
0
Be careful :
There are more than two data in each row , Multi row data
#include <stdio.h>
int main()
{
long long int a, b, c = 0;
char d;
while (scanf("%lld", &a), a != 0)
{
while (d = getchar(), d != '\n')
{
scanf("%lld", &b);
c += b;
}
printf("%lld\n", c);
c = 0;
}
return 0;
}
Fifth question
subject
A number of 32 Bit integer summation .
Input
The first line of input data is an integer TT, Express TT Group test data , Each group is in a row . And then TT In line , The first number in each line is an integer NN, Then there are NN individual 32 An integer .
Output
Enter... For each group , Output the result in a separate line .
Sample input
3
5 1 2 3 4 5
2 -1 1
1 0
Sample output
15
0
0
边栏推荐
- 8086 segmentation technology
- The daemon thread starts redis and modifies the configuration file
- Login to verify the simple use of KOA passport Middleware
- Install docker under windows10 (through Oracle VM VirtualBox)
- Typescript basic operations
- 汇编语言基础知识
- Description of project structure configuration of idea
- 汇编语言寻址方式
- Fdog series (III): use Tencent cloud SMS interface to send SMS, write database, deploy to server, web finale.
- 8086 memory
猜你喜欢
Programmer orientation problem solving methodology
ByteDance open source Gan model compression framework, saving up to 97.8% of computing power - iccv 2021
Coursera cannot play video
Which is more important for programming, practice or theory [there are some things recently, I don't have time to write an article, so I'll post an article on hydrology, and I'll fill in later]
When it comes to Google i/o, this is how ByteDance is applied to flutter
High performance mysql (Third Edition) notes
TCP的三次握手和四次挥手
Alibaba cloud server builds SVN version Library
搭建flutter环境入坑集合
Train 100 pictures for 1 hour, and the style of the photos changes at will. There is a demo at the end of the article | siggraph 2021
随机推荐
À propos de l'utilisation intelligente du flux et de la carte
Compile homework after class
Only learning C can live up to expectations top3 demo exercise
High performance mysql (Third Edition) notes
手把手带你做强化学习实验--敲级详细
Introduction to microservices
Assembly language segment definition
Activiti目录(四)查询代办/已办、审核
Activiti directory (IV) inquiry agency / done, approved
Only learning C can live up to expectations top2 P1 variable
唯有学C不负众望 TOP3 Demo练习
Train 100 pictures for 1 hour, and the style of the photos changes at will. There is a demo at the end of the article | siggraph 2021
ByteDance 2022 school recruitment R & D advance approval publicity meeting, students' top 10 issues
Shell_ 00_ First meeting shell
Alibaba cloud server docker installation mysql5.5
GCC error: terminate called after throwing an instance of 'std:: regex_ error‘ what(): regex
SQL tuning notes
Alibaba cloud server builds SVN version Library
Activiti目录(五)驳回、重新发起、取消流程
谢邀,人在工区,刚交代码,在下字节跳动实习生