当前位置:网站首页>HDU - 6024 building shops (girls' competition)
HDU - 6024 building shops (girls' competition)
2022-07-06 16:03:00 【It's Xiao Zhang, ZSY】
C - Building Shops
HDU’s n classrooms are on a line ,which can be considered as a number line. Each classroom has a coordinate. Now Little Q wants to build several candy shops in these n classrooms.
The total cost consists of two parts. Building a candy shop at classroom ii would have some cost ci . For every classroom P without any candy shop, then the distance between P and the rightmost classroom with a candy shop on P’s left side would be included in the cost too. Obviously, if there is a classroom without any candy shop, there must be a candy shop on its left side.
Now Little Q wants to know how to build the candy shops with the minimal cost. Please write a program to help him.
Input
The input contains several test cases, no more than 10 test cases.
In each test case, the first line contains an integer n(1≤n≤3000), denoting the number of the classrooms.
In the following nn lines, each line contains two integers xi,ci(1e-9<=xi,ci<=1e9), denoting the coordinate of the ii-th classroom and the cost of building a candy shop in it.
There are no two classrooms having same coordinate.
Output
For each test case, print a single line containing an integer, denoting the minimal cost.
Sample Input
3
1 2
2 3
3 4
4
1 7
3 1
5 10
6 1
Sample Output
5
11
Broken thoughts , I wanted to write about dp That's it , Last time because dp Can't , It affects me to win the prize, woo woo , My registration fee
dp【i】【j】 For the first time i A classroom , The location of the previous candy store is j, What is the minimum cost of .
There are two kinds , One is to build a candy store here .dp【i】【i】=min(dp【i】【i】,dp【i-1】【j】+v【i】)(1<=j<i).
Second, do not build candy stores .dp【i】【j】=min(dp【i】【j】,dp【i-1】【j】+d【i】-d【j】)(1<=j<i).
Of course , The first classroom must build a candy store dp[1][1]=a[1].n.
#include <iostream>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <algorithm>
using namespace std;
int const N=1e5+10;
typedef long long ll;
struct node{
ll m,n;
}a[3010];
ll dp[3010][3010];
ll const inf=1e9+10;
int cmp(node x,node y)
{
return x.m<y.m;
}
int main()
{
int nn;
while(~scanf("%d",&nn))
{
for(int i=1;i<=nn;i++)
{
scanf("%lld%lld",&a[i].m,&a[i].n);
}
sort(a+1,a+nn+1,cmp);
memset(dp,inf,sizeof(dp));
dp[1][1]=a[1].n;
for(int i=1;i<=nn;i++)
for(int j=1;j<i;j++)
{
dp[i][j]=min(dp[i][j],dp[i-1][j]+a[i].m-a[j].m);
dp[i][i]=min(dp[i][i],dp[i-1][j]+a[i].n);
}
ll sum=inf;
for(int i=1;i<=nn;i++)
sum=min(sum,dp[nn][i]);
printf("%lld\n",sum);
}
return 0;
}
边栏推荐
- Opencv learning log 14 - count the number of coins in the picture (regardless of overlap)
- 【练习-8】(Uva 246)10-20-30==模拟
- 渗透测试 ( 8 ) --- Burp Suite Pro 官方文档
- [exercise-4] (UVA 11988) broken keyboard = = (linked list)
- Penetration test (1) -- necessary tools, navigation
- Analysis of protobuf format of real-time barrage and historical barrage at station B
- 1010 things that college students majoring in it must do before graduation
- Determine the Photo Position
- 【练习-4】(Uva 11988)Broken Keyboard(破损的键盘) ==(链表)
- Penetration testing (5) -- a collection of practical skills of scanning King nmap and penetration testing tools
猜你喜欢
渗透测试 ( 1 ) --- 必备 工具、导航
C语言必背代码大全
Web based photo digital printing website
Information security - threat detection - Flink broadcast stream broadcaststate dual stream merging application in filtering security logs
Penetration test (4) -- detailed explanation of meterpreter command
Penetration testing (5) -- a collection of practical skills of scanning King nmap and penetration testing tools
B - 代码派对(女生赛)
Penetration test (1) -- necessary tools, navigation
Essai de pénétration (1) - - outils nécessaires, navigation
mysql导入数据库报错 [Err] 1273 – Unknown collation: ‘utf8mb4_0900_ai_ci’
随机推荐
Shell Scripting
C 基本语法
D - Function(HDU - 6546)女生赛
【高老师UML软件建模基础】20级云班课习题答案合集
STM32 how to use stlink download program: light LED running light (Library version)
[exercise-1] (UVA 673) parentheses balance/ balanced brackets (stack)
快速转 TypeScript 指南
洛谷P1102 A-B数对(二分,map,双指针)
Alice and Bob (2021牛客暑期多校训练营1)
China's earthwork equipment market trend report, technical dynamic innovation and market forecast
[exercise -11] 4 values why sum is 0 (and 4 values of 0)
Information security - Analysis of security orchestration automation and response (soar) technology
If you want to apply for a programmer, your resume should be written like this [essence summary]
入门C语言基础问答
Opencv learning log 12 binarization of Otsu method
Penetration test (8) -- official document of burp Suite Pro
Opencv learning log 19 skin grinding
CS zero foundation introductory learning record
Ball Dropping
想应聘程序员,您的简历就该这样写【精华总结】