当前位置:网站首页>HDU - 6024 building shops (girls' competition)
HDU - 6024 building shops (girls' competition)
2022-07-06 16:03:00 【It's Xiao Zhang, ZSY】
C - Building Shops
HDU’s n classrooms are on a line ,which can be considered as a number line. Each classroom has a coordinate. Now Little Q wants to build several candy shops in these n classrooms.
The total cost consists of two parts. Building a candy shop at classroom ii would have some cost ci . For every classroom P without any candy shop, then the distance between P and the rightmost classroom with a candy shop on P’s left side would be included in the cost too. Obviously, if there is a classroom without any candy shop, there must be a candy shop on its left side.
Now Little Q wants to know how to build the candy shops with the minimal cost. Please write a program to help him.
Input
The input contains several test cases, no more than 10 test cases.
In each test case, the first line contains an integer n(1≤n≤3000), denoting the number of the classrooms.
In the following nn lines, each line contains two integers xi,ci(1e-9<=xi,ci<=1e9), denoting the coordinate of the ii-th classroom and the cost of building a candy shop in it.
There are no two classrooms having same coordinate.
Output
For each test case, print a single line containing an integer, denoting the minimal cost.
Sample Input
3
1 2
2 3
3 4
4
1 7
3 1
5 10
6 1
Sample Output
5
11
Broken thoughts , I wanted to write about dp That's it , Last time because dp Can't , It affects me to win the prize, woo woo , My registration fee
dp【i】【j】 For the first time i A classroom , The location of the previous candy store is j, What is the minimum cost of .
There are two kinds , One is to build a candy store here .dp【i】【i】=min(dp【i】【i】,dp【i-1】【j】+v【i】)(1<=j<i).
Second, do not build candy stores .dp【i】【j】=min(dp【i】【j】,dp【i-1】【j】+d【i】-d【j】)(1<=j<i).
Of course , The first classroom must build a candy store dp[1][1]=a[1].n.
#include <iostream>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <algorithm>
using namespace std;
int const N=1e5+10;
typedef long long ll;
struct node{
ll m,n;
}a[3010];
ll dp[3010][3010];
ll const inf=1e9+10;
int cmp(node x,node y)
{
return x.m<y.m;
}
int main()
{
int nn;
while(~scanf("%d",&nn))
{
for(int i=1;i<=nn;i++)
{
scanf("%lld%lld",&a[i].m,&a[i].n);
}
sort(a+1,a+nn+1,cmp);
memset(dp,inf,sizeof(dp));
dp[1][1]=a[1].n;
for(int i=1;i<=nn;i++)
for(int j=1;j<i;j++)
{
dp[i][j]=min(dp[i][j],dp[i-1][j]+a[i].m-a[j].m);
dp[i][i]=min(dp[i][i],dp[i-1][j]+a[i].n);
}
ll sum=inf;
for(int i=1;i<=nn;i++)
sum=min(sum,dp[nn][i]);
printf("%lld\n",sum);
}
return 0;
}
边栏推荐
- 7-1 懂的都懂 (20 分)
- Research Report on market supply and demand and strategy of China's land incineration plant industry
- VS2019初步使用
- China's earthwork tire market trend report, technical dynamic innovation and market forecast
- Information security - security professional name | CVE | rce | POC | Vul | 0day
- Research Report on market supply and demand and strategy of Chinese graphic screen printing equipment industry
- [exercise 4-1] cake distribution
- Penetration test (8) -- official document of burp Suite Pro
- Research Report on surgical fluid treatment industry - market status analysis and development prospect prediction
- Optimization method of path problem before dynamic planning
猜你喜欢
TCP的三次握手与四次挥手
Borg Maze (BFS+最小生成树)(解题报告)
Analysis of protobuf format of real-time barrage and historical barrage at station B
Penetration testing (5) -- a collection of practical skills of scanning King nmap and penetration testing tools
Nodejs+vue网上鲜花店销售信息系统express+mysql
渗透测试 ( 8 ) --- Burp Suite Pro 官方文档
Information security - Analysis of security orchestration automation and response (soar) technology
MySQL import database error [err] 1273 - unknown collation: 'utf8mb4_ 0900_ ai_ ci’
Analyse du format protobuf du rideau en temps réel et du rideau historique de la station B
Penetration test (7) -- vulnerability scanning tool Nessus
随机推荐
数据在内存中的存储&载入内存,让程序运行起来
【练习-7】(Uva 10976)Fractions Again?!(分数拆分)
【练习-4】(Uva 11988)Broken Keyboard(破损的键盘) ==(链表)
Accounting regulations and professional ethics [2]
Record of brushing questions with force deduction -- complete knapsack problem (I)
nodejs爬虫
C语言学习笔记
SSM框架常用配置文件
Perform general operations on iptables
渗透测试 ( 1 ) --- 必备 工具、导航
【练习-7】Crossword Answers
Research Report of cylindrical grinder industry - market status analysis and development prospect forecast
洛谷P1102 A-B数对(二分,map,双指针)
China's earthwork tire market trend report, technical dynamic innovation and market forecast
Accounting regulations and professional ethics [3]
Penetration test 2 --- XSS, CSRF, file upload, file inclusion, deserialization vulnerability
Penetration test (3) -- Metasploit framework (MSF)
Nodejs+vue online fresh flower shop sales information system express+mysql
Research Report on shell heater industry - market status analysis and development prospect forecast
Opencv learning log 19 skin grinding