当前位置:网站首页>【练习-10】 Unread Messages(未读消息)
【练习-10】 Unread Messages(未读消息)
2022-07-06 09:26:00 【火焰车】
题目描述
There is a group of people in an internet email message group. Messages are sent to all members of the group, and no two messages are sent at the same time.
Immediately before a person sends a message, they read all their unread messages up to that point.
Each sender also reads their own message the moment it is sent. Therefore, a person’s unread messages are exactly the set of messages sent after that person’s last message.
Each time a message is sent, compute the total number of unread messages over all group members.
输入
The first line of input contains two integers n (1 ≤ n ≤ 109 ) and m (1 ≤ m ≤ 1,000), where n is the number of people in the group, and m is the number of messages sent. The group members are
identified by number, 1 through n.
Each of the next m lines contains a single integer s (1 ≤ s ≤ n), which is the sender of that message. These lines are in chronological order.
输出
Output m lines, each with a single integer, indicating the total number of unread messages over all group members, immediately after each message is sent.
样例输入
【样例1】
2 4
1
2
1
2
【样例2】
3 9
1
2
3
2
1
3
3
2
1
样例输出
【样例1】
1
1
1
1
【样例2】
2
3
3
4
3
3
5
4
3
题目大意:
有n个人发m次消息(每次只有一个人发),接下来m行没行输入是第几个人发的。
当一个人发消息时,其他所有人都会有一条未读消息,当一个人发消息时,他的未读消息会清0.
AC代码:
#include<bits/stdc++.h>
using namespace std;
#define CLEAR(a) memset(a,0,sizeof a);
typedef long long ll;
const int N = 1e5+5;
const ll mod = 1e9+7;
map<ll,ll> mp;
int main()
{
ll n,m,x,res=0;
cin>>n>>m;
for(int i=1;i<=m;i++)
{
cin>>x;
res+=(n-(i-mp[x]));
mp[x]=i;
cout<<res<<endl;
}
return 0;
}
思路:
因为发一条消息时,除了自己每个人的未读消息都会+1。那不妨假设每个人都会+1,也就是说未读消息总数+n。
然后我们再减去发消息的人已经看了的消息,用map记录上一次看消息是什么时候,用i-mp[x]就是已经看了的消息(不需要额外-1,因为A发消息时A也+1了)。
那么只要加上n-(i-mp[x])就是未读消息的量了。
边栏推荐
- 力扣刷题记录
- Accounting regulations and professional ethics [1]
- Market trend report, technical innovation and market forecast of Chinese hospital respiratory humidification equipment
- 0-1背包問題(一)
- Es6--- two methods of capturing promise status as failed
- mysql导入数据库报错 [Err] 1273 – Unknown collation: ‘utf8mb4_0900_ai_ci’
- csapp shell lab
- Cost accounting [14]
- Learning record: how to perform PWM output
- D - Function(HDU - 6546)女生赛
猜你喜欢
1010 things that college students majoring in it must do before graduation
STM32 learning record: input capture application
LeetCode#62. Different paths
Learning record: STM32F103 clock system overview working principle
洛谷P1102 A-B数对(二分,map,双指针)
FSM and I2C experiment report
JS --- all knowledge of JS objects and built-in objects (III)
JS --- all basic knowledge of JS (I)
Stm32 dossiers d'apprentissage: saisie des applications
MATLAB综合练习:信号与系统中的应用
随机推荐
Research Report on pharmaceutical R & D outsourcing service industry - market status analysis and development prospect forecast
Flink 使用之 CEP
想应聘程序员,您的简历就该这样写【精华总结】
Research Report of exterior wall insulation system (ewis) industry - market status analysis and development prospect prediction
Learning record: Tim - capacitive key detection
Opencv learning log 16 paperclip count
Record of brushing questions with force deduction -- complete knapsack problem (I)
Cost accounting [13]
cs零基础入门学习记录
C 基本语法
差分(一维,二维,三维) 蓝桥杯三体攻击
Shell脚本编程
力扣刷题记录--完全背包问题(一)
STM32学习记录:玩转按键控制蜂鸣器和LED
Indonesian medical sensor Industry Research Report - market status analysis and development prospect forecast
区间和------离散化
Perinatal Software Industry Research Report - market status analysis and development prospect forecast
Accounting regulations and professional ethics [2]
China medical check valve market trend report, technical dynamic innovation and market forecast
ucorelab3