当前位置:网站首页>HDU-6025-Coprime Sequence(女生赛)
HDU-6025-Coprime Sequence(女生赛)
2022-07-06 09:25:00 【是小张张呀 zsy】
Coprime Sequence
Do you know what is called "Coprime Sequence’’? That is a sequence consists of nn positive integers, and the GCD (Greatest Common Divisor) of them is equal to 1."Coprime Sequence’’ is easy to find because of its restriction. But we can try to maximize the GCD of these integers by removing exactly one integer. Now given a sequence, please maximize the GCD of its elements.
Input
The first line of the input contains an integer T(1≤T≤10),
denoting the number of test cases.
In each test case, there is an integer n(3≤n≤100000) in the first line, denoting the number of integers in the sequence.
Then the following line consists of n integers
a1,a2,…,an (1<=ai<=1e9) denoting the elements in the sequence.
Output
For each test case, print a single line containing a single integer, denoting the maximum GCD.
Sample Input
3
3
1 1 1
5
2 2 2 3 2
4
1 2 4 8
Sample Output
1
2
2
#include <iostream>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <algorithm>
using namespace std;
int const N=1e5+10;
typedef long long ll;
int a[N],b[N],c[N];
int gcd(ll x,ll y)
{
return y==0?x:gcd(y,x%y);
}
int main()
{
int t;
scanf("%d",&t);
while(t--){
int n,ans=1;
scanf("%d",&n);
memset(a,0,sizeof(a));
memset(b,0,sizeof(b));
memset(c,0,sizeof(c));
for(int i=1;i<=n;i++)
{
scanf("%d",&a[i]);
}
sort(a+1,a+1+n);
b[1]=a[1];
c[n]=a[n];
for(int i=2;i<=n;i++)
{
b[i]=gcd(b[i-1],a[i]);//前缀
}
for(int i=n-1;i>=1;i--)
{
c[i]=gcd(c[i+1],a[i]);//后缀
}
for(int i=1;i<=n;i++)
{
ans=max(ans,gcd(c[i+1],b[i-1]));
}//每次除去第i个数后的最大公约数
printf("%d\n",ans);
}
return 0;
}
边栏推荐
- China's earthwork equipment market trend report, technical dynamic innovation and market forecast
- JS --- all knowledge of JS objects and built-in objects (III)
- 动态规划前路径问题
- LeetCode#268. Missing numbers
- cs零基础入门学习记录
- C语言是低级和高级的分水岭
- C4D quick start tutorial - creating models
- Scoring system based on 485 bus
- Cost accounting [23]
- Cost accounting [20]
猜你喜欢
基于485总线的评分系统
Brief introduction to libevent
Introduction to safety testing
LeetCode#237. Delete nodes in the linked list
Learning record: Tim - Basic timer
csapp shell lab
STM32 learning record: input capture application
How to build a nail robot that can automatically reply
学习记录:TIM—电容按键检测
Scoring system based on 485 bus
随机推荐
Perinatal Software Industry Research Report - market status analysis and development prospect forecast
STM32學習記錄:輸入捕獲應用
Learning record: how to perform PWM output
The wechat red envelope cover designed by the object is free! 16888
Cost accounting [23]
ArrayList集合
Cost accounting [13]
Research Report on market supply and demand and strategy of China's land incineration plant industry
Research Report on market supply and demand and strategy of geosynthetics industry in China
What to do when programmers don't modify bugs? I teach you
How to write the bug report of software test?
Research Report on market supply and demand and strategy of Chinese graphic screen printing equipment industry
ucore lab 6
csapp shell lab
动态规划前路径问题优化方式
Printing quality inspection and verification system Industry Research Report - market status analysis and development prospect forecast
基于485总线的评分系统
Interview answering skills for software testing
Market trend report, technical innovation and market forecast of lip care products in China and Indonesia
C语言是低级和高级的分水岭