当前位置:网站首页>HDU-6025-Coprime Sequence(女生赛)
HDU-6025-Coprime Sequence(女生赛)
2022-07-06 09:25:00 【是小张张呀 zsy】
Coprime Sequence
Do you know what is called "Coprime Sequence’’? That is a sequence consists of nn positive integers, and the GCD (Greatest Common Divisor) of them is equal to 1."Coprime Sequence’’ is easy to find because of its restriction. But we can try to maximize the GCD of these integers by removing exactly one integer. Now given a sequence, please maximize the GCD of its elements.
Input
The first line of the input contains an integer T(1≤T≤10),
denoting the number of test cases.
In each test case, there is an integer n(3≤n≤100000) in the first line, denoting the number of integers in the sequence.
Then the following line consists of n integers
a1,a2,…,an (1<=ai<=1e9) denoting the elements in the sequence.
Output
For each test case, print a single line containing a single integer, denoting the maximum GCD.
Sample Input
3
3
1 1 1
5
2 2 2 3 2
4
1 2 4 8
Sample Output
1
2
2
#include <iostream>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <algorithm>
using namespace std;
int const N=1e5+10;
typedef long long ll;
int a[N],b[N],c[N];
int gcd(ll x,ll y)
{
return y==0?x:gcd(y,x%y);
}
int main()
{
int t;
scanf("%d",&t);
while(t--){
int n,ans=1;
scanf("%d",&n);
memset(a,0,sizeof(a));
memset(b,0,sizeof(b));
memset(c,0,sizeof(c));
for(int i=1;i<=n;i++)
{
scanf("%d",&a[i]);
}
sort(a+1,a+1+n);
b[1]=a[1];
c[n]=a[n];
for(int i=2;i<=n;i++)
{
b[i]=gcd(b[i-1],a[i]);//前缀
}
for(int i=n-1;i>=1;i--)
{
c[i]=gcd(c[i+1],a[i]);//后缀
}
for(int i=1;i<=n;i++)
{
ans=max(ans,gcd(c[i+1],b[i-1]));
}//每次除去第i个数后的最大公约数
printf("%d\n",ans);
}
return 0;
}
边栏推荐
- 12306: mom, don't worry about me getting the ticket any more (1)
- Cost accounting [15]
- JDBC introduction
- 学习记录:使用STM32外部输入中断
- ucore lab 6
- What are the commonly used SQL statements in software testing?
- STM32学习记录:输入捕获应用
- UCORE LaB6 scheduler experiment report
- Stm32 dossiers d'apprentissage: saisie des applications
- Cost accounting [13]
猜你喜欢
C语言数组的概念
Learning record: STM32F103 clock system overview working principle
FSM and I2C experiment report
ucore lab5
Jupyter installation and use tutorial
Knowledge that you need to know when changing to software testing
C4D quick start tutorial - creating models
csapp shell lab
程序员的你,有哪些炫技的代码写法?
Learning records: serial communication and solutions to errors encountered
随机推荐
Your wechat nickname may be betraying you
Learning record: USART serial communication
ucorelab4
China's salt water membrane market trend report, technological innovation and market forecast
Brief introduction to libevent
Do you know the performance testing terms to be asked in the software testing interview?
JS --- all knowledge of JS objects and built-in objects (III)
ucorelab3
ucore lab 2
Learning record: use stm32f1 watchdog
Medical colposcope Industry Research Report - market status analysis and development prospect forecast
力扣刷题记录
China's earthwork tire market trend report, technical dynamic innovation and market forecast
Research Report on market supply and demand and strategy of Chinese hospital cleaning chemicals industry
51 lines of code, self-made TX to MySQL software!
MATLAB实例:阶跃函数的两种表达方式
JDBC introduction
Cost accounting [15]
China chart recorder market trend report, technology dynamic innovation and market forecast
Printing quality inspection and verification system Industry Research Report - market status analysis and development prospect forecast