当前位置:网站首页>HOJ 2245 浮游三角胞(数学啊 )
HOJ 2245 浮游三角胞(数学啊 )
2022-07-07 20:57:00 【全栈程序员站长】
大家好,又见面了,我是全栈君。
Time Limit: 500 MS Memory Limit: 50000 K Total Submit: 129(38 users) Total Accepted: 66(34 users) Rating: Special Judge: No | Time Limit: 500 MS | Memory Limit: 50000 K | Total Submit: 129(38 users) | Total Accepted: 66(34 users) | Rating: | Special Judge: No |
---|---|---|---|---|---|---|
Time Limit: 500 MS | Memory Limit: 50000 K | |||||
Total Submit: 129(38 users) | Total Accepted: 66(34 users) | Rating: | Special Judge: No | |||
Description | ||||||
如图所看到的。Zoidtrip是一个休闲向小游戏…… 玩家须要操纵一个以斜向下四十五度速度v不停前进的三角胞,不停地避开水平障碍物,每次点击屏幕能够变换行进方向。[能够将斜向左(右)45°变换为斜向右(左)45°] 如今,有n层障碍物。第i层障碍物能够从横坐标l[i]~r[i]的范围内穿过去(包含l[i]与r[i]),第i层障碍物与第i-1层障碍物之间的距离为d[i]。 请问,假定在能够无限变换方向的条件下,最多能够前进至第几层? 我们规定玩家出生位置为第0层、横坐标为0的地方。 你能够在随意实数时刻进行方向变换。 | ||||||
Input | ||||||
多组測试数据。 每组測试数据第一行为两个正整数 n和v。 接下来n行,每行3个整数l[i] , r[i] , d[i]。 ( N <= 2000000。0 <= 全部数据 < 2^31 ) | ||||||
Output | ||||||
对于每组数据。输出一行,包括一个整数,代表最多前进至的层数。 | ||||||
Sample Input | ||||||
3 7 1 3 1 4 10 5 8 10 1 4 1 1 1 1 2 5 10 1 1 1 3 5 2 | ||||||
Sample Output | ||||||
2 4 | ||||||
Hint | ||||||
“第i层障碍物与第i-1层障碍物之间的距离为d[i]” 因此d[1]是第一层和第零层的距离。 例子1解释例如以下: 我们能够出生位置向右下移动至第一层坐标为1的地方。 接下来能够继续一直向右下移动至第二层坐标为6的地方。 但不管怎样也无法移动至第三层的8~10之间。 例子2说明例如以下: (0,0)->(1,1)->(2,2)->(3,1)->(4,3) 因此到达第四层。 | ||||||
Source | ||||||
哈尔滨理工大学第五届ACM程序设计竞赛 |
PS:
把 三角胞在每一层能走到的且满足能避开障碍物的最左和最右的距离找出来!
代码例如以下:
#include <cstdio>
#include <iostream>
#include <algorithm>
using namespace std;
#define LL long long
#define maxn 2000047
LL l[maxn], r[maxn], d[maxn];
int main()
{
LL n, v;
while(scanf("%lld%lld",&n,&v)!=EOF)
{
LL L = 0,R = 0;
int ans = 0;
for(int i=0; i<n; i++)
{
scanf("%lld%lld%lld",&l[i],&r[i],&d[i]);
}
for(int i = 0; i < n; i++)
{
if(l[i] > r[i])
{
LL t = r[i];
r[i] = l[i];
l[i] = t;
}
L-=d[i];
R+=d[i];
L = max(l[i],L);
R = min(r[i],R);
if(L > R)
{
break;
}
ans++;
}
if(v == 0)
ans = 0;
printf("%d\n",ans);
}
return 0;
}
发布者:全栈程序员栈长,转载请注明出处:https://javaforall.cn/116288.html原文链接:https://javaforall.cn
边栏推荐
- How to meet the dual needs of security and confidentiality of medical devices?
- Intelligent transportation is full of vitality. What will happen in the future? [easy to understand]
- C语言多角度帮助你深入理解指针(1. 字符指针2. 数组指针和 指针数组 、数组传参和指针传参3. 函数指针4. 函数指针数组5. 指向函数指针数组的指针6. 回调函数)
- 如何满足医疗设备对安全性和保密性的双重需求?
- 让这个CRMEB单商户微信商城系统火起来,太好用了!
- Codesonar enhances software reliability through innovative static analysis
- [function recursion] do you know all five classic examples of simple recursion?
- 现在网上开户安全么?想知道我现在在南宁,到哪里开户比较好?
- 凌云出海记 | 赛盒&华为云:共助跨境电商行业可持续发展
- 微服务远程Debug,Nocalhost + Rainbond微服务开发第二弹
猜你喜欢
MySQL storage expression error
机械臂速成小指南(十二):逆运动学分析
OneSpin | 解决IC设计中的硬件木马和安全信任问题
Intelligent software analysis platform embold
神兵利器——敏感文件发现工具
I Basic concepts
不落人后!简单好用的低代码开发,快速搭建智慧管理信息系统
Nebula importer data import practice
C语言多角度帮助你深入理解指针(1. 字符指针2. 数组指针和 指针数组 、数组传参和指针传参3. 函数指针4. 函数指针数组5. 指向函数指针数组的指针6. 回调函数)
CodeSonar通过创新型静态分析增强软件可靠性
随机推荐
How to choose fund products? What fund is suitable to buy in July 2022?
复杂因子计算优化案例:深度不平衡、买卖压力指标、波动率计算
H3C s7000/s7500e/10500 series post stack BFD detection configuration method
Phoenix JDBC
神兵利器——敏感文件发现工具
上海交大最新《标签高效深度分割》研究进展综述,全面阐述无监督、粗监督、不完全监督和噪声监督的深度分割方法
Small guide for rapid formation of manipulator (12): inverse kinematics analysis
数值法求解最优控制问题(〇)——定义
Mongodb learn from simple to deep
Dachang classic pointer written test questions
Apifox 接口一体化管理新神器
[matrix multiplication] [noi 2012] [cogs963] random number generator
Optimization cases of complex factor calculation: deep imbalance, buying and selling pressure index, volatility calculation
MySQL约束之默认约束default与零填充约束zerofill
Tensorflow2. How to run under x 1 Code of X
How to meet the dual needs of security and confidentiality of medical devices?
Micro service remote debug, nocalhost + rainbow micro service development second bullet
FTP steps for downloading files from Huawei CE switches
权限不足
Onespin | solve the problems of hardware Trojan horse and security trust in IC Design