当前位置:网站首页>Haut OJ 1321: mode problem of choice sister
Haut OJ 1321: mode problem of choice sister
2022-07-05 05:17:00 【hunziHang】
Problem description :
Choice The elder sister returned home , hold n Put candies in boxes , The first i What kinds of candy do you have mi individual , She wants to know mi What is the number that appears most in , Can you tell her ? Ensure that the number with the most occurrences occurs more than n/2.
Input :
Enter an integer in the first line n(1 <= n <= 1e6).
Next line n It's an integer mi(1<= mi <= 1e9), It means the first one i The number of candies , Integers are separated by spaces .
( Pay attention to memory limitations , Mode occurs more than n/2)
Output :
Output mi The number that appears most in , Occupy a line .
The sample input :
5 10 10 10 20 30
Sample output :
10
Cause analysis :
data n Too big , The array stores the number of occurrences of each , Then cycle again to find the maximum , Time must have expired .
So you can One by one , Take a variable and save times , If equal, then the number ++, Otherwise times --, If it's reduced to 0 It means that this number is not a mode , Of course, the number of times -- The number of is certainly not the mode , for instance : 3 3 3 2 2 1 The last number is reduced to 0, 3 2 1 Certainly not the mode
Solution :
#include <stdio.h>
int main()
{
int n, t, x, top;
scanf("%d", &n);
top = t = 0;
for(int i = 1;i <= n; i++){
scanf("%d",&x);
if(x == t)
top++;
else if(top == 0) {
t=x;
top=1;
}
else
top--;
}
printf("%d\n", t);
return 0;
}
边栏推荐
猜你喜欢
GBase数据库助力湾区数字金融发展
The present is a gift from heaven -- a film review of the journey of the soul
【论文笔记】Multi-Goal Reinforcement Learning: Challenging Robotics Environments and Request for Research
win10虚拟机集群优化方案
Unity check whether the two objects have obstacles by ray
[turn to] MySQL operation practice (III): table connection
[to be continued] [depth first search] 547 Number of provinces
Magnifying glass effect
Heap sort summary
LeetCode之單詞搜索(回溯法求解)
随机推荐
[speed pointer] 142 circular linked list II
[to be continued] I believe that everyone has the right to choose their own way of life - written in front of the art column
【论文笔记】Multi-Goal Reinforcement Learning: Challenging Robotics Environments and Request for Research
cocos_ Lua loads the file generated by bmfont fnt
[allocation problem] 455 Distribute cookies
远程升级怕截胡?详解FOTA安全升级
Unity intelligent NPC production -- pre judgment walking (method 1)
Database under unity
[merge array] 88 merge two ordered arrays
PMP考生,请查收7月PMP考试注意事项
[interval problem] 435 Non overlapping interval
2022/7/1 learning summary
Download xftp7 and xshell7 (official website)
Insert sort
Three dimensional dice realize 3D cool rotation effect (with complete source code) (with animation code)
Shell Sort
Personal required code
Bubble sort summary
Es module and commonjs learning notes
Collapse of adjacent vertical outer margins