当前位置:网站首页>Haut OJ 1321: mode problem of choice sister
Haut OJ 1321: mode problem of choice sister
2022-07-05 05:17:00 【hunziHang】
Problem description :
Choice The elder sister returned home , hold n Put candies in boxes , The first i What kinds of candy do you have mi individual , She wants to know mi What is the number that appears most in , Can you tell her ? Ensure that the number with the most occurrences occurs more than n/2.
Input :
Enter an integer in the first line n(1 <= n <= 1e6).
Next line n It's an integer mi(1<= mi <= 1e9), It means the first one i The number of candies , Integers are separated by spaces .
( Pay attention to memory limitations , Mode occurs more than n/2)
Output :
Output mi The number that appears most in , Occupy a line .
The sample input :
5 10 10 10 20 30
Sample output :
10
Cause analysis :
data n Too big , The array stores the number of occurrences of each , Then cycle again to find the maximum , Time must have expired .
So you can One by one , Take a variable and save times , If equal, then the number ++, Otherwise times --, If it's reduced to 0 It means that this number is not a mode , Of course, the number of times -- The number of is certainly not the mode , for instance : 3 3 3 2 2 1 The last number is reduced to 0, 3 2 1 Certainly not the mode
Solution :
#include <stdio.h>
int main()
{
int n, t, x, top;
scanf("%d", &n);
top = t = 0;
for(int i = 1;i <= n; i++){
scanf("%d",&x);
if(x == t)
top++;
else if(top == 0) {
t=x;
top=1;
}
else
top--;
}
printf("%d\n", t);
return 0;
}
边栏推荐
- Use the command character to close the keyboard command of the notebook
- Unity enables mobile phone vibration
- TF-A中的工具介绍
- Kali 2018 full image download
- Insert sort
- Unity check whether the two objects have obstacles by ray
- Three dimensional dice realize 3D cool rotation effect (with complete source code) (with animation code)
- [paper notes] multi goal reinforcement learning: challenging robotics environments and request for research
- [binary search] 69 Square root of X
- django连接数据库报错,这是什么原因
猜你喜欢
随机推荐
BUUCTF MISC
Use the command character to close the keyboard command of the notebook
Personal required code
2022上半年全国教师资格证下
Judge the position of the monster in the role under unity3d
[转]:Apache Felix Framework配置属性
Applet Live + e - commerce, si vous voulez être un nouveau e - commerce de détail, utilisez - le!
Solon Logging 插件的添加器级别控制和日志器的级别控制
Embedded database development programming (zero)
Unity find the coordinates of a point on the circle
Solon Auth 认证框架使用演示(更简单的认证框架)
Transport connection management of TCP
Bubble sort summary
Unity get component
Vs2015 secret key
Es module and commonjs learning notes
django连接数据库报错,这是什么原因
[转]MySQL操作实战(一):关键字 & 函数
Embedded database development programming (V) -- DQL
Time format conversion