当前位置:网站首页>7-1 懂的都懂 (20 分)
7-1 懂的都懂 (20 分)
2022-07-06 09:25:00 【是小张张呀 zsy】
2021 RoboCom 世界机器人开发者大赛-本科组(初赛)
7-1 懂的都懂 (20 分)
众所周知,在互联网上有很多话是不好直接说出来的,不过一些模糊的图片仍然能让网友看懂你在说什么。然而对这种言论依然一定要出重拳,所以请你实现一个简单的匹配算法。
现在我们采集了原图的一些特征数据,由 N 个小于 255 的非负整数组成,假设对于给定的若干张由 M个同样小于 255 的非负整数组成的新图的特征数据,每个数据都可以由原图中任意四个不同数据的平均值计算而来,则称新图为原图的相似图片。对于给出的数据,请你判断是不是相似图片。
注意,不同数据指的并非是数据的值不同,而是不能取同一个数据多次。对于两个相同值的数据,如果给出两次,则可以取两次。
输入格式:
输入第一行是两个整数 N,K (1 ≤ N ≤ 50, 1 ≤ K ≤ 200),表示采集的原图的特征数据个数和新图的张数。
接下来一行为 N 个小于 255 的非负整数,表示原图的特征数据。
最后的 K 行,每行第一个数是 M 表示新图的特征数据个数。然后是 M 个小于 255 的非负整数,表示新图的特征数据。
输出格式:
对于每一张新图,如果为相似图片,则在一行中输出 Yes,否则输出 No。
输入样例:
5 3
4 8 12 20 40
3 11 16 19
3 12 16 19
10 11 11 11 11 11 11 11 11 11 11
输出样例:
Yes
No
Yes
#include <bits/stdc++.h>
using namespace std;
double a[8000000],b[205],c[205];
int main(){
int m,n;
cin>>m>>n;
for(int i=0;i<m;i++){
cin>>b[i];
}
int kk=0;
for(int i=0;i<m;i++){
for(int j=i+1;j<m;j++){
for(int k=j+1;k<m;k++){
for(int h=k+1;h<m;h++){
a[kk++]=b[i]+b[j]+b[k]+b[h];
}
}
}
}
sort(a,a+kk);
while(n--){
int ss;
cin>>ss;
for(int i=0;i<ss;i++){
cin>>c[i];
}
int oo=0;
for(int i=0;i<ss;i++){
int h=lower_bound(a,a+kk,c[i]*4.0)-a;
if(a[h]!=c[i]*4.0){
oo=1;
break;
}
}
if(oo==1)
cout<<"No"<<endl;
else
cout<<"Yes"<<endl;
}
return 0;
}
边栏推荐
- Eslint--- error: newline required at end of file but not found (EOL last) solution
- Market trend report, technical innovation and market forecast of geosynthetic clay liner in China
- 入门C语言基础问答
- 数据在内存中的存储&载入内存,让程序运行起来
- ArrayList set
- Cost accounting [21]
- Introduction to safety testing
- FSM and I2C experiment report
- 学习记录:USART—串口通讯
- JS --- BOM details of JS (V)
猜你喜欢
Take you to use wxpy to create your own chat robot (plus wechat interface basic data visualization)
Introduction to safety testing
Word macro operation: convert the automatic number in the document into editable text type
Matlab example: two expressions of step function
ucore lab 2
Winter vacation daily question - maximum number of balloons
C语言数组的概念
差分(一维,二维,三维) 蓝桥杯三体攻击
毕业才知道IT专业大学生毕业前必做的1010件事
JS --- all basic knowledge of JS (I)
随机推荐
Market trend report, technical innovation and market forecast of lip care products in China and Indonesia
Cost accounting [16]
UCORE lab5 user process management experiment report
通俗地理解什么是编程语言
STM32学习记录:输入捕获应用
Research Report on market supply and demand and strategy of China's Medical Automation Industry
动态规划前路径问题
Accounting regulations and professional ethics [2]
Preface to the foundations of Hilbert geometry
0-1背包問題(一)
学习记录:USART—串口通讯
Lab 8 文件系统
入门C语言基础问答
Determine the Photo Position
Cost accounting [22]
[C language] twenty two steps to understand the function stack frame (pressing the stack, passing parameters, returning, bouncing the stack)
CSAPP shell lab experiment report
C4D quick start tutorial - Introduction to software interface
STM32学习记录:玩转按键控制蜂鸣器和LED
Matlab example: two expressions of step function