当前位置:网站首页>Haut OJ 1352: string of choice
Haut OJ 1352: string of choice
2022-07-05 05:17:00 【hunziHang】
Problem description :
Choice Like to convert consecutive and identical characters into characters and numbers , And the number she expressed is one , such as ”c22” Namely ”ccccc”, That is, each number represents the number of times to repeat the last most recent character . You can Choice Restore the written string ?
Input :
Enter an integer in the first line T, Represents the number of test groups .
Each set of data includes a row , Enter a Choice Write string , The length is less than 100( No number will appear in the first place )
Output :
Each group outputs one line , Represents the expanded string .
The sample input :
1 a3b4c22
Sample output :
aaaabbbbbccccc
Cause analysis :
Multiple instances Pay attention to whether line wrapping is required ( Generally ), It's definitely wrong not to change lines .
Solution :
#include<bits/stdc++.h>
using namespace std;
#define endl "\n"
int main(void)
{
ios::sync_with_stdio(false);
cin.tie(0);
cout.tie(0);
int t;
cin>>t;
while(t--)
{
char c;
string str;
int num,i,j,k;
cin>>str;
k=str.length();
for(i=0;i<k;i++)
{
if(str[i]>='0'&&str[i]<='9')
{
num=str[i]-'0';
for(j=1;j<=num;j++)
cout<<c;
}
else
{
c=str[i];
cout<<c;
}
}
cout<<endl;
}
return 0;
}
边栏推荐
猜你喜欢
随机推荐
cocos2dx_ Lua particle system
2022/7/1学习总结
2022/7/2 question summary
对象的序列化
Unity check whether the two objects have obstacles by ray
Lua wechat avatar URL
National teacher qualification examination in the first half of 2022
Merge sort
[turn to] MySQL operation practice (I): Keywords & functions
Solon 框架如何方便获取每个请求的响应时间?
Django reports an error when connecting to the database. What is the reason
stm32Cubemx(8):RTC和RTC唤醒中断
Ue4/ue5 illusory engine, material part (III), material optimization at different distances
Magnifying glass effect
[轉]: OSGI規範 深入淺出
[转]MySQL操作实战(三):表联结
Ue4/ue5 illusory engine, material chapter, texture, compression and memory compression and memory
LeetCode之單詞搜索(回溯法求解)
Time format conversion
Out and ref functions of unity