当前位置:网站首页>Haut OJ 1352: string of choice

Haut OJ 1352: string of choice

2022-07-05 05:17:00 hunziHang

Problem description :

Choice Like to convert consecutive and identical characters into characters and numbers , And the number she expressed is one , such as ”c22” Namely ”ccccc”, That is, each number represents the number of times to repeat the last most recent character . You can Choice Restore the written string ?

Input :

Enter an integer in the first line T, Represents the number of test groups .

Each set of data includes a row , Enter a Choice Write string , The length is less than 100( No number will appear in the first place )

Output :

Each group outputs one line , Represents the expanded string .

The sample input :

1
a3b4c22

Sample output :

aaaabbbbbccccc

Cause analysis :

Multiple instances Pay attention to whether line wrapping is required ( Generally ), It's definitely wrong not to change lines .


Solution :

#include<bits/stdc++.h>
using namespace std;
#define endl "\n"
int main(void)
{
    ios::sync_with_stdio(false);
    cin.tie(0);
    cout.tie(0);
    int t;
    cin>>t;
    while(t--)
    {
        char c;
        string str;
        int num,i,j,k;
        cin>>str;
        k=str.length();
        for(i=0;i<k;i++)
        {
            if(str[i]>='0'&&str[i]<='9')
            {
                num=str[i]-'0';
                for(j=1;j<=num;j++)
                    cout<<c;
            }
            else
                {
                    c=str[i];
                    cout<<c;
                }
        }
        cout<<endl;
    }

    return 0;
}


原网站

版权声明
本文为[hunziHang]所创,转载请带上原文链接,感谢
https://yzsam.com/2022/02/202202140622509359.html