当前位置:网站首页>[exercise -10] unread messages
[exercise -10] unread messages
2022-07-06 15:57:00 【Flame car】
Title Description
There is a group of people in an internet email message group. Messages are sent to all members of the group, and no two messages are sent at the same time.
Immediately before a person sends a message, they read all their unread messages up to that point.
Each sender also reads their own message the moment it is sent. Therefore, a person’s unread messages are exactly the set of messages sent after that person’s last message.
Each time a message is sent, compute the total number of unread messages over all group members.
Input
The first line of input contains two integers n (1 ≤ n ≤ 109 ) and m (1 ≤ m ≤ 1,000), where n is the number of people in the group, and m is the number of messages sent. The group members are
identified by number, 1 through n.
Each of the next m lines contains a single integer s (1 ≤ s ≤ n), which is the sender of that message. These lines are in chronological order.
Output
Output m lines, each with a single integer, indicating the total number of unread messages over all group members, immediately after each message is sent.
The sample input
【 Examples 1】
2 4
1
2
1
2
【 Examples 2】
3 9
1
2
3
2
1
3
3
2
1
Sample output
【 Examples 1】
1
1
1
1
【 Examples 2】
2
3
3
4
3
3
5
4
3
The main idea of the topic :
Yes n Personal hair m The second news ( Only one person at a time ), Next m Line no line input is sent by the first person .
When a person sends a message , Everyone else will have an unread message , When a person sends a message , His unread news will be cleared 0.
AC Code :
#include<bits/stdc++.h>
using namespace std;
#define CLEAR(a) memset(a,0,sizeof a);
typedef long long ll;
const int N = 1e5+5;
const ll mod = 1e9+7;
map<ll,ll> mp;
int main()
{
ll n,m,x,res=0;
cin>>n>>m;
for(int i=1;i<=m;i++)
{
cin>>x;
res+=(n-(i-mp[x]));
mp[x]=i;
cout<<res<<endl;
}
return 0;
}
Ideas :
Because when sending a message , Everyone's unread messages except myself will +1. Let's assume that everyone will +1, That is, the total number of unread messages +n.
Then we subtract the message that the sender has read , use map Record the last time you read the message , use i-mp[x] It's the news that I've read ( No extra -1, because A When sending messages A also +1 了 ).
Then just add n-(i-mp[x]) Is the amount of unread messages .
边栏推荐
- 毕业才知道IT专业大学生毕业前必做的1010件事
- [analysis of teacher Gao's software needs] collection of exercises and answers for level 20 cloud class
- Cost accounting [14]
- Information security - threat detection engine - common rule engine base performance comparison
- Penetration test (7) -- vulnerability scanning tool Nessus
- 信息安全-威胁检测-flink广播流BroadcastState双流合并应用在过滤安全日志
- 【练习-5】(Uva 839)Not so Mobile(天平)
- Opencv learning log 16 paperclip count
- Opencv learning log 18 Canny operator
- Research Report on market supply and demand and strategy of Chinese graphic screen printing equipment industry
猜你喜欢
Penetration test (3) -- Metasploit framework (MSF)
力扣刷题记录
【练习-4】(Uva 11988)Broken Keyboard(破损的键盘) ==(链表)
C语言必背代码大全
Gartner: five suggestions on best practices for zero trust network access
B - 代码派对(女生赛)
D - Function(HDU - 6546)女生赛
STM32 learning record: play with keys to control buzzer and led
渗透测试 ( 2 ) --- 渗透测试系统、靶机、GoogleHacking、kali工具
【练习-5】(Uva 839)Not so Mobile(天平)
随机推荐
【练习-7】Crossword Answers
MATLAB综合练习:信号与系统中的应用
Matlab comprehensive exercise: application in signal and system
Cost accounting [13]
用C语言写网页游戏
China's earthwork tire market trend report, technical dynamic innovation and market forecast
信息安全-威胁检测引擎-常见规则引擎底座性能比较
【练习-4】(Uva 11988)Broken Keyboard(破损的键盘) ==(链表)
Learning record: understand systick system timer and write delay function
渗透测试 ( 2 ) --- 渗透测试系统、靶机、GoogleHacking、kali工具
STM32 learning record: play with keys to control buzzer and led
Flink 使用之 CEP
Information security - threat detection engine - common rule engine base performance comparison
通俗地理解什么是编程语言
Opencv learning log 33 Gaussian mean filtering
Shell脚本编程
Penetration test (3) -- Metasploit framework (MSF)
VS2019初步使用
想应聘程序员,您的简历就该这样写【精华总结】
B - 代码派对(女生赛)