当前位置:网站首页>[蓝桥杯2021初赛] 砝码称重
[蓝桥杯2021初赛] 砝码称重
2022-07-06 09:14:00 【%xiao Q】
题目
题目描述
你有一架天平和N 个砝码,这N 个砝码重量依次是W1, W2, … , WN。
请你计算一共可以称出多少种不同的重量?
注意砝码可以放在天平两边。
输入格式
输入的第一行包含一个整数N。
第二行包含N 个整数:W1, W2, W3, … , WN。
对于50% 的评测用例,1 ≤ N ≤ 15。
对于所有评测用例,1 ≤ N ≤ 100,N 个砝码总重不超过100000。
输出格式
输出一个整数代表答案。
输入样例
3
1 4 6
输出样例
10
分析
这道题暴力搜索肯定是会超时的,dfs大概的话,能过50%的点。
这题的正解为dp(奈何菜鸡不会dp),那么接下来就来分析dp的做法:
- 状态表示f[i][j]:表示前i个砝码中选,称出的重量为j的状态,为1表示可以称出,为0则不能称出。
- 状态转移:
- a[i] == j,那么f[i][j]一定可以被称出
- a[i] != j,那么就可以从f[i - 1][j],f[i - 1][abs(j - a[i])](本质为f[i - 1][j - a[i]],为了防止出现负的下标,所以取绝对值),f[i - 1][j + a[i]]这3种情况中转移过来。
f[i - 1][j]:i - 1个砝码能称出的,i个也能称出
f[i - 1][j - a[i]]:加上当前的砝码
f[i - 1][j + a[i]]:减去当前的砝码
满足3种的任意一种,即可判断f[i][j]的重量为j的能否被称出
参考代码1(dfs)---- 过50%的样例(O(3^n))
#include <iostream>
#include <cstdio>
#include <set>
#include <map>
#include <vector>
#include <cstring>
#include <cmath>
#include <queue>
#include <stack>
#include <algorithm>
#include <unordered_map>
#define LL long long
#define rep(i, a, b) for(int i = a; i <= b; i++)
#define reps(i, a, b) for(int i = a; i < b; i++)
#define pre(i, a, b) for(int i = b; i >= a; i--)
using namespace std;
const int N = 110, M = 1e5 + 10;
int n, ans = 0;
int a[N];
bool st[M];
void dfs(int u, int sum)
{
if(!st[sum] && sum > 0) ans++, st[sum] = true;
if(u == n + 1) return ;
dfs(u + 1, sum + a[u]);
dfs(u + 1, sum - a[u]);
dfs(u + 1, sum);
}
int main()
{
cin >> n;
rep(i, 1, n) cin >> a[i];
dfs(1, 0);
cout << ans << endl;
return 0;
}
参考代码2(dp)---- O(nm)
#include <iostream>
#include <cstdio>
#include <set>
#include <map>
#include <vector>
#include <cstring>
#include <cmath>
#include <queue>
#include <stack>
#include <algorithm>
#include <unordered_map>
#define LL long long
#define rep(i, a, b) for(int i = a; i <= b; i++)
#define reps(i, a, b) for(int i = a; i < b; i++)
#define pre(i, a, b) for(int i = b; i >= a; i--)
using namespace std;
const int N = 110, M = 1e5 + 10;
int n, m;
int a[N];
int f[N][M];
int main()
{
cin >> n;
rep(i, 1, n) cin >> a[i], m += a[i];
rep(i, 1, n)
rep(j, 1, m)
{
if(a[i] == j) f[i][j] = 1;
else f[i][j] = f[i - 1][j] | f[i - 1][abs(j - a[i])] | f[i - 1][j + a[i]];
}
int ans = 0;
rep(i, 1, m)
if(f[n][i]) ans++;
cout << ans << endl;
return 0;
}
边栏推荐
- Are you monitored by the company for sending resumes and logging in to job search websites? Deeply convinced that the product of "behavior awareness system ba" has not been retrieved on the official w
- Development of C language standard
- MySQL completely uninstalled (windows, MAC, Linux)
- Remember the interview algorithm of a company: find the number of times a number appears in an ordered array
- [free setup] asp Net online course selection system design and Implementation (source code +lunwen)
- JDBC principle
- Postman environment variable settings
- TCP/IP协议(UDP)
- 项目实战-后台员工信息管理(增删改查登录与退出)
- error C4996: ‘strcpy‘: This function or variable may be unsafe. Consider using strcpy_s instead
猜你喜欢
[recommended by bloggers] asp Net WebService background data API JSON (with source code)
Rhcsa certification exam exercise (configured on the first host)
Installation and use of MySQL under MySQL 19 Linux
QT creator create button
Postman uses scripts to modify the values of environment variables
[ahoi2009]chess Chinese chess - combination number optimization shape pressure DP
学习问题1:127.0.0.1拒绝了我们的访问
自动机器学习框架介绍与使用(flaml、h2o)
Deoldify项目问题——OMP:Error#15:Initializing libiomp5md.dll,but found libiomp5md.dll already initialized.
QT creator custom build process
随机推荐
Asp access Shaoxing tourism graduation design website
MySQL master-slave replication, read-write separation
引入了junit为什么还是用不了@Test注解
frp内网穿透那些事
Principes JDBC
Windows下安装MongDB教程、Redis教程
记一次某公司面试题:合并有序数组
Armv8-a programming guide MMU (2)
Attention apply personal understanding to images
Copie maître - esclave MySQL, séparation lecture - écriture
自动机器学习框架介绍与使用(flaml、h2o)
Base de données Advanced Learning Notes - - SQL statements
Swagger, Yapi interface management service_ SE
一键提取pdf中的表格
记某公司面试算法题:查找一个有序数组某个数字出现的次数
虚拟机Ping通主机,主机Ping不通虚拟机
Number game
MySQL主從複制、讀寫分離
Postman uses scripts to modify the values of environment variables
QT creator specify editor settings