当前位置:网站首页>1039 Course List for Student
1039 Course List for Student
2022-07-05 05:51:00 【Brosto_Cloud】
Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.
Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤40,000), the number of students who look for their course lists, and K (≤2,500), the total number of courses. Then the student name lists are given for the courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students Ni (≤200) are given in a line. Then in the next line, Ni student names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.
Output Specification:
For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student's name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.
Sample Input:
11 5
4 7
BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
1 4
ANN0 BOB5 JAY9 LOR6
2 7
ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
3 1
BOB5
5 9
AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9
Sample Output:
ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0
使用map、set容器;
map实现字符串映射,set实现课程从小到大自动排序。
#include <iostream>
#include <vector>
#include <algorithm>
#include <string>
#include <set>
#include <map>
using namespace std;
map<string, set<int>>m;
int n, k;
map<string, int>cnt;
int main() {
cin >> n >> k;
int c, num; //课程编号,选课人数
string name;
for (int i = 0; i < k; i++) {
cin >> c >> num;
for (int j = 0; j < num; j++) {
cin >> name;
cnt[name]++;
m[name].insert(c);
}
}
for (int i = 0; i < n; i++) {
cin >> name;
cout << name << ' ' << cnt[name];
for (set<int>::iterator it = m[name].begin(); it != m[name].end(); it++) {
cout << ' ' << *it;
}
if (i != n - 1) {
cout << endl;
}
}
return 0;
}
边栏推荐
- 6. Logistic model
- R语言【数据集的导入导出】
- 剑指 Offer II 058:日程表
- Time of process
- A misunderstanding about the console window
- Detailed explanation of expression (csp-j 2021 expr) topic
- Daily question - Search two-dimensional matrix PS two-dimensional array search
- Over fitting and regularization
- Smart construction site "hydropower energy consumption online monitoring system"
- Configuration and startup of kubedm series-02-kubelet
猜你喜欢
Dichotomy, discretization, etc
EOJ 2021.10 E. XOR tree
LaMDA 不可能觉醒吗?
Sword finger offer 04 Search in two-dimensional array
[jailhouse article] look mum, no VM exits
Analysis of backdoor vulnerability in remote code execution penetration test / / phpstudy of national game title of national secondary vocational network security B module
Time of process
1.15 - 输入输出系统
CF1634 F. Fibonacci Additions
Full Permutation Code (recursive writing)
随机推荐
Some common problems in the assessment of network engineers: WLAN, BGP, switch
2020ccpc Qinhuangdao J - Kingdom's power
Time of process
The sum of the unique elements of the daily question
Codeforces round 712 (Div. 2) d. 3-coloring (construction)
【Jailhouse 文章】Jailhouse Hypervisor
Binary search template
对for(var i = 0;i < 5;i++) {setTimeout(() => console.log(i),1000)}的深入分析
全国中职网络安全B模块之国赛题远程代码执行渗透测试 //PHPstudy的后门漏洞分析
Typical use cases for knapsacks, queues, and stacks
The number of enclaves
CCPC Weihai 2021m eight hundred and ten thousand nine hundred and seventy-five
Annotation and reflection
Over fitting and regularization
Personal developed penetration testing tool Satania v1.2 update
【Rust 笔记】14-集合(上)
Individual game 12
Simply sort out the types of sockets
Transform optimization problems into decision-making problems
Educational Codeforces Round 116 (Rated for Div. 2) E. Arena