当前位置:网站首页>1039 Course List for Student
1039 Course List for Student
2022-07-05 05:51:00 【Brosto_Cloud】
Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.
Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤40,000), the number of students who look for their course lists, and K (≤2,500), the total number of courses. Then the student name lists are given for the courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students Ni (≤200) are given in a line. Then in the next line, Ni student names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.
Output Specification:
For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student's name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.
Sample Input:
11 5
4 7
BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
1 4
ANN0 BOB5 JAY9 LOR6
2 7
ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
3 1
BOB5
5 9
AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9
Sample Output:
ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0
使用map、set容器;
map实现字符串映射,set实现课程从小到大自动排序。
#include <iostream>
#include <vector>
#include <algorithm>
#include <string>
#include <set>
#include <map>
using namespace std;
map<string, set<int>>m;
int n, k;
map<string, int>cnt;
int main() {
cin >> n >> k;
int c, num; //课程编号,选课人数
string name;
for (int i = 0; i < k; i++) {
cin >> c >> num;
for (int j = 0; j < num; j++) {
cin >> name;
cnt[name]++;
m[name].insert(c);
}
}
for (int i = 0; i < n; i++) {
cin >> name;
cout << name << ' ' << cnt[name];
for (set<int>::iterator it = m[name].begin(); it != m[name].end(); it++) {
cout << ' ' << *it;
}
if (i != n - 1) {
cout << endl;
}
}
return 0;
}
边栏推荐
猜你喜欢
Little known skills of Task Manager
leetcode-6111:螺旋矩阵 IV
wordpress切换页面,域名变回了IP地址
Sword finger offer 53 - ii Missing numbers from 0 to n-1
[jailhouse article] look mum, no VM exits
剑指 Offer 05. 替换空格
Pointnet++ learning
Graduation project of game mall
Typical use cases for knapsacks, queues, and stacks
leetcode-6108:解密消息
随机推荐
【Rust 笔记】17-并发(上)
数据可视化图表总结(一)
网络工程师考核的一些常见的问题:WLAN、BGP、交换机
个人开发的渗透测试工具Satania v1.2更新
leetcode-556:下一个更大元素 III
[practical skills] technical management of managers with non-technical background
【Jailhouse 文章】Performance measurements for hypervisors on embedded ARM processors
Maximum number of "balloons"
Educational Codeforces Round 116 (Rated for Div. 2) E. Arena
“磐云杯”中职网络安全技能大赛A模块新题
【Rust 笔记】15-字符串与文本(上)
In this indifferent world, light crying
Collection: programming related websites and books
Sword finger offer 35 Replication of complex linked list
Mysql database (I)
leetcode-31:下一个排列
Alu logic operation unit
剑指 Offer 58 - II. 左旋转字符串
2017 USP Try-outs C. Coprimes
leetcode-9:回文数