当前位置:网站首页>1089 insert or merge, including test point 5
1089 insert or merge, including test point 5
2022-07-05 07:44:00 【Study hard 867】
According to Wikipedia:
Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.
Merge sort works as follows: Divide the unsorted list into N sublists, each containing 1 element (a list of 1 element is considered sorted). Then repeatedly merge two adjacent sublists to produce new sorted sublists until there is only 1 sublist remaining.
Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print in the first line either "Insertion Sort" or "Merge Sort" to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resuling sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.
Sample Input 1:
10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0
Sample Output 1:
Insertion Sort
1 2 3 5 7 8 9 4 6 0
Sample Input 2:
10
3 1 2 8 7 5 9 4 0 6
1 3 2 8 5 7 4 9 0 6
Sample Output 2:
Merge Sort
1 2 3 8 4 5 7 9 0 6
Thank the user Muzi Supplementary data !
Code length limit
16 KB
The time limit
200 ms
Memory limit
The main idea of the topic : Determine whether to merge sort or insert sort .
Insert sorting to judge , The principle is to sort the first few elements according to this , So the elements after insertion and sorting are not arranged well , So we can judge whether it is insertion sort based on this , Either insert sort or merge sort , Merge and sort , Just follow the simulation , In fact, both can be simulated , Enough time .
Code :
#include <bits/stdc++.h>
using namespace std;
int a[101];
int b[101];
int n;
int work[101];
bool issame(){// Determine whether the array is the same
int i;
for(i=0;i<n;i++){
if(b[i]!=work[i])return false;
}
return true;
}
void merge(int l,int r,int sz){// Merge sort l+sz, Is the range of the left sequence .
int i;
int start=l;
int temp[n];
for(i=0;i<n;i++)temp[i]=work[i];
int k=min(l+sz,r-1);
int u=min(r+sz,n-1);
while(l<=k&&r<=u){
if(temp[l]<=temp[r])work[start++]=temp[l++];
else work[start++]=temp[r++];
}
while(l<=k){
work[start++]=temp[l++];
}
while(r<=u){
work[start++]=temp[r++];
}
return ;
}
int main(){
scanf("%d",&n);
int i;
for(i=0;i<n;i++){
scanf("%d",&a[i]);
work[i]=a[i];
}
for(i=0;i<n;i++){
scanf("%d",&b[i]);
}
for(i=0;b[i]<=b[i+1];i++);// Find the first different element
sort(work,work+i+1);
if(issame()){
printf("Insertion Sort\n");
sort(work,work+i+2);
for(i=0;i<n;i++){
if(i!=0)printf(" ");
printf("%d",work[i]);
}
system("pause");
return 0;
}
printf("Merge Sort\n");
int j;
for(i=0;i<n;i++)work[i]=a[i];
for(i=1;i<n/2;i*=2){//i For scale
for(j=0;j<n;j+=2*i){//j It's the left border
if(j+i<n)merge(j,j+i,i-1);
else merge(j,(j+n)/2,(n-j)/2);// To prevent cross-border
}
if(issame()){// Find the same as the original sequence and rearrange .
i*=2;
for(j=0;j<n;j+=2*i){
merge(j,j+i,i-1);
}
for(j=0;j<n;j++){
if(j!=0)printf(" ");
printf("%d",work[j]);
}
system("pause");
return 0;
}
}
system("pause");
}
Test points in the process 5 error , The reason is that there is no discussion about the boundary , else merge(j,(j+n)/2,(n-j)/2);// To prevent cross-border , This statement solves this problem well .
Test point 5 Test samples for
10
3 1 2 8 7 5 9 4 6 0
1 2 3 4 5 7 8 9 0 6
Running results :
Merge Sort
0 1 2 3 4 5 6 7 8 9
I found the problem through debugging , If the boundary is not restricted , Random values will appear during debugging , Test points after correction 5 That's how it works .
边栏推荐
- Day06 class variables instance variables local variables constant variables naming conventions
- II Simple NSIS installation package
- Day07 type of mathematical operator automatic conversion relational operator bitwise operator blind date math
- A complete set of indicators for the 10000 class clean room of electronic semiconductors
- Function and usage of function pointer
- Calibre garbled
- Simple use of timeunit
- Global and Chinese market of digital shore durometer 2022-2028: Research Report on technology, participants, trends, market size and share
- GBK error in web page Chinese display (print, etc.), solution
- When jupyter notebook is encountered, erroe appears in the name and is not output after running, but an empty line of code is added downward, and [] is empty
猜你喜欢
Close of office 365 reading
Clickhouse database installation deployment and remote IP access
CADD课程学习(5)-- 构建靶点已知的化合结构(ChemDraw)
Scm-05 basis of independent keyboard
How to modify the file path of Jupiter notebook under miniconda
I 用c l 栈与队列的相互实现
Leetcode solution - number of islands
Graduation thesis project local deployment practice
Use of orbbec Astra depth camera of OBI Zhongguang in ROS melody
[neo4j] common operations of neo4j cypher and py2neo
随机推荐
Altium Designer 19.1.18 - 清除测量距离产生的信息
mysql 盲注常见函数
公安专业知识--哔哩桐老师
I 用c l 栈与队列的相互实现
Day08 ternary operator extension operator character connector symbol priority
Day06 class variables instance variables local variables constant variables naming conventions
Day07 type of mathematical operator automatic conversion relational operator bitwise operator blind date math
公安基础知识--fb
[neo4j] common operations of neo4j cypher and py2neo
Differences between pycharm and idle and process -- join() in vs Code
Daily Practice:Codeforces Round #794 (Div. 2)(A~D)
Play with grpc - go deep into concepts and principles
Use stm32cubemx tool to write the demo program of FreeRTOS
Altium Designer 19.1.18 - 更改铺铜的透明度
Scm-05 basis of independent keyboard
Function and usage of function pointer
Ugnx12.0 initialization crash, initialization error (-15)
Deepin get file (folder) list
Day09 how to create packages import package naming conventions Alibaba Development Manual
Ue5 hot update - remote server automatic download and version detection (simplehotupdate)