当前位置:网站首页>HDU - 1260 tickets (linear DP)

HDU - 1260 tickets (linear DP)

2022-07-07 23:42:00 WA_ automata

HDU - 1260 Tickets( linear DP)

Problem Description
Jesus, what a great movie! Thousands of people are rushing to the cinema. However, this is really a tuff time for Joe who sells the film tickets. He is wandering when could he go back home as early as possible.
A good approach, reducing the total time of tickets selling, is let adjacent people buy tickets together. As the restriction of the Ticket Seller Machine, Joe can sell a single ticket or two adjacent tickets at a time.
Since you are the great JESUS, you know exactly how much time needed for every person to buy a single ticket or two tickets for him/her. Could you so kind to tell poor Joe at what time could he go back home as early as possible? If so, I guess Joe would full of appreciation for your help.

Input
There are N(1<=N<=10) different scenarios, each scenario consists of 3 lines:

  1. An integer K(1<=K<=2000) representing the total number of people;
  2. K integer numbers(0s<=Si<=25s) representing the time consumed to buy a ticket for each person;
  3. (K-1) integer numbers(0s<=Di<=50s) representing the time needed for two adjacent people to buy two tickets together.

Output
For every scenario, please tell Joe at what time could he go back home as early as possible. Every day Joe started his work at 08:00:00 am. The format of time is HH:MM:SS am|pm.

Sample Input
2
2
20 25
40
1
8

Sample Output
08:00:40 am
08:00:08 am

The question : Yes K Individuals queue up to buy movie tickets , Everyone can choose to buy by themselves or form a two person team with neighboring people , The time for separate purchase is si, Team up to buy from 2 Personal start , The total time spent buying with the previous person is di( The unit of time is seconds ).8 Ticket sales begin at , Ask everyone the earliest end time of buying tickets (12 hourly , The morning is am, The afternoon is pm).

  1. State means :dp[i] Before presentation i It takes the least total time for individuals to buy tickets
  2. Dynamic transfer : When the first i When individuals buy tickets , There are two options , Buy alone or in a team with the previous person
  3. Buy it alone :dp[i-1] + s[i](s[i] It means the first one i It takes time for individuals to buy alone )
  4. Group purchase :dp[i-2] + d[i](d[i] It means the first one i It takes time for an individual to team up with the previous person )
  5. State transition equation dp[i] = min(dp[i-1] + s[i], dp[i-2] + d[i])
#include<iostream>
using namespace std;

const int N = 2010;
int dp[N],a[N],b[N];

int main()
{
    
	int T;scanf("%d",&T);
	while(T--)
	{
    
		int k;scanf("%d",&k);
		for(int i=1;i<=k;i++) scanf("%d",&a[i]);
		for(int i=2;i<=k;i++) scanf("%d",&b[i]);
		dp[1]=a[1],dp[2]=min(a[1]+a[2],b[2]);
		for(int i=3;i<=k;i++)
			dp[i]=min(dp[i-1]+a[i],dp[i-2]+b[i]);
		int h=8+dp[k]/3600,m=dp[k]%3600/60,s=dp[k]%60;
		printf("%02d:%02d:%02d am\n",h,m,s);
	}
	return 0;
}
原网站

版权声明
本文为[WA_ automata]所创,转载请带上原文链接,感谢
https://yzsam.com/2022/188/202207072126467167.html