当前位置:网站首页>HDU - 1260 tickets (linear DP)
HDU - 1260 tickets (linear DP)
2022-07-07 23:42:00 【WA_ automata】
HDU - 1260 Tickets( linear DP)
Problem Description
Jesus, what a great movie! Thousands of people are rushing to the cinema. However, this is really a tuff time for Joe who sells the film tickets. He is wandering when could he go back home as early as possible.
A good approach, reducing the total time of tickets selling, is let adjacent people buy tickets together. As the restriction of the Ticket Seller Machine, Joe can sell a single ticket or two adjacent tickets at a time.
Since you are the great JESUS, you know exactly how much time needed for every person to buy a single ticket or two tickets for him/her. Could you so kind to tell poor Joe at what time could he go back home as early as possible? If so, I guess Joe would full of appreciation for your help.
Input
There are N(1<=N<=10) different scenarios, each scenario consists of 3 lines:
- An integer K(1<=K<=2000) representing the total number of people;
- K integer numbers(0s<=Si<=25s) representing the time consumed to buy a ticket for each person;
- (K-1) integer numbers(0s<=Di<=50s) representing the time needed for two adjacent people to buy two tickets together.
Output
For every scenario, please tell Joe at what time could he go back home as early as possible. Every day Joe started his work at 08:00:00 am. The format of time is HH:MM:SS am|pm.
Sample Input
2
2
20 25
40
1
8
Sample Output
08:00:40 am
08:00:08 am
The question : Yes K Individuals queue up to buy movie tickets , Everyone can choose to buy by themselves or form a two person team with neighboring people , The time for separate purchase is si, Team up to buy from 2 Personal start , The total time spent buying with the previous person is di( The unit of time is seconds ).8 Ticket sales begin at , Ask everyone the earliest end time of buying tickets (12 hourly , The morning is am, The afternoon is pm).
- State means :
dp[i]
Before presentationi
It takes the least total time for individuals to buy tickets - Dynamic transfer : When the first i When individuals buy tickets , There are two options , Buy alone or in a team with the previous person
- Buy it alone :
dp[i-1] + s[i]
(s[i] It means the first one i It takes time for individuals to buy alone ) - Group purchase :
dp[i-2] + d[i]
(d[i] It means the first one i It takes time for an individual to team up with the previous person ) - State transition equation
dp[i] = min(dp[i-1] + s[i], dp[i-2] + d[i])
#include<iostream>
using namespace std;
const int N = 2010;
int dp[N],a[N],b[N];
int main()
{
int T;scanf("%d",&T);
while(T--)
{
int k;scanf("%d",&k);
for(int i=1;i<=k;i++) scanf("%d",&a[i]);
for(int i=2;i<=k;i++) scanf("%d",&b[i]);
dp[1]=a[1],dp[2]=min(a[1]+a[2],b[2]);
for(int i=3;i<=k;i++)
dp[i]=min(dp[i-1]+a[i],dp[i-2]+b[i]);
int h=8+dp[k]/3600,m=dp[k]%3600/60,s=dp[k]%60;
printf("%02d:%02d:%02d am\n",h,m,s);
}
return 0;
}
边栏推荐
- 【路径规划】使用垂距限值法与贝塞尔优化A星路径
- [stm32+esp8266 connect Tencent cloud IOT development platform 2] stm32+esp8266-01s connect Tencent cloud
- Anxinco EC series modules are connected to the multi protocol access products of onenet Internet of things open platform
- Where are you going
- Anti climbing means cracking the second
- P1055 [noip2008 popularization group] ISBN number
- Interface
- [untitled]
- 通达信买基金安全吗?
- 0-1 knapsack problem
猜你喜欢
SAP HR reward and punishment information export
Design and implementation of spark offline development framework
Summary of SQL single table query 2020.7.27
Open source hardware small project: anxinco esp-c3f control ws2812
Live server usage
Chisel tutorial - 02 Chisel environment configuration and implementation and testing of the first chisel module
SAP memory parameter tuning process
SRM supplier cloud collaborative management platform solution for building materials industry to realize business application scalability and configuration
P1067 [noip2009 popularity group] polynomial output (difficult, pit)
Take you hand in hand to build Eureka client with idea
随机推荐
Sequence of entity layer, Dao layer, service layer and controller layer
Get started with mongodb
KeePass realizes automatic input of web pages
How to change the formula picture in the paper directly into the formula in word
Oracle statistics by time
C language greedy snake
Reverse output three digit and arithmetic sequence
Display the server hard disk image to the browser through Servlet
archery安装测试
How to login and enable synchronization function in Google browser
一份假Offer如何盗走了「Axie infinity」5.4亿美元?
平衡二叉樹【AVL樹】——插入、删除
关于CH32库函数与STM32库函数的区别
SLAM面试总结
Lm12 rolling heikin Ashi double K-line filter
8.31 Tencent interview
[experiment sharing] log in to Cisco devices through the console port
【路径规划】使用垂距限值法与贝塞尔优化A星路径
SAP 内存参数调优过程
One of the anti climbing methods