当前位置:网站首页>MPLS experiment
MPLS experiment
2022-07-06 03:11:00 【4o4-】
1. The experimental requirements
2. The experimental steps
The topology is as follows
The configuration is as follows :
R1
R1
sysname R1
#
interface GigabitEthernet0/0/0
ip address 192.168.2.1 255.255.255.0
#
interface LoopBack0
ip address 192.168.1.1 255.255.255.0
#
ip route-static 192.168.3.0 255.255.255.0 192.168.2.2
ip route-static 192.168.4.0 255.255.255.0 192.168.2.2
R2
sysname R2
#
ip vpn-instance a1 // establish VPN Space
ipv4-family //DR value
route-distinguisher 2:2
vpn-target 2:2 export-extcommunity //TR value
vpn-target 2:2 import-extcommunity
#
ip vpn-instance b1
ipv4-family
route-distinguisher 1:1
vpn-target 1:1 export-extcommunity
vpn-target 1:1 import-extcommunity
#
mpls lsr-id 2.2.2.2 // Appoint mplsid1 Number
mpls // Turn on mpls
#
mpls ldp
#
interface GigabitEthernet0/0/0
ip address 23.1.1.1 255.255.255.0
mpls // On the interface mpls
mpls ldp
#
interface GigabitEthernet0/0/1
ip binding vpn-instance b1 // To put VPN Bind the port first and then configure the address , Otherwise IP The address will appear in the common routing table
ip address 192.168.2.2 255.255.255.0
#
interface GigabitEthernet0/0/2
ip binding vpn-instance a1
ip address 192.168.2.2 255.255.255.0
#
interface LoopBack0
ip address 2.2.2.2 255.255.255.255
#
bgp 1
router-id 2.2.2.2
peer 4.4.4.4 as-number 1
peer 4.4.4.4 connect-interface LoopBack0
#
ipv4-family unicast
undo synchronization
peer 4.4.4.4 enable
#
ipv4-family vpnv4
policy vpn-target
peer 4.4.4.4 enable
#
ipv4-family vpn-instance a1 // stay bgp Import VPN a1 The routing
import-route rip 1
#
ipv4-family vpn-instance b1
import-route direct // stay bgp towards VPN b1 Import static and direct routes , Can't write , Because handwriting bgp Can't label the second layer
import-route static
#
ospf 1 router-id 2.2.2.2
area 0.0.0.0
network 2.2.2.2 0.0.0.0
network 23.1.1.1 0.0.0.0
#
rip 1 vpn-instance a1 // by VPN Spatial dynamic routing protocol
undo summary
version 2
network 192.168.2.0
import-route bgp
#
ip route-static vpn-instance b1 192.168.1.0 255.255.255.0 192.168.2.1
R3
sysname R3
#
mpls lsr-id 3.3.3.3
mpls
#
mpls ldp
#
interface GigabitEthernet0/0/0
ip address 34.1.1.1 255.255.255.0
mpls
mpls ldp
#
interface GigabitEthernet0/0/1
ip address 23.1.1.2 255.255.255.0
mpls
mpls ldp
#
interface GigabitEthernet0/0/2
#
interface LoopBack0
ip address 3.3.3.3 255.255.255.255
#
ospf 1 router-id 3.3.3.3
area 0.0.0.0
network 3.3.3.3 0.0.0.0
network 23.1.1.2 0.0.0.0
network 34.1.1.1 0.0.0.0
R4
R4
sysname R4
#
ip vpn-instance a1
ipv4-family
route-distinguisher 2:2
vpn-target 2:2 export-extcommunity
vpn-target 2:2 import-extcommunity
#
ip vpn-instance b1
ipv4-family
route-distinguisher 1:1
vpn-target 1:1 export-extcommunity
vpn-target 1:1 import-extcommunity
#
mpls lsr-id 4.4.4.4
mpls
#
mpls ldp
#
interface GigabitEthernet0/0/0
ip binding vpn-instance b1
ip address 192.168.3.2 255.255.255.0
#
interface GigabitEthernet0/0/1
ip address 34.1.1.2 255.255.255.0
mpls
mpls ldp
#
interface GigabitEthernet0/0/2
ip binding vpn-instance a1
ip address 192.168.3.2 255.255.255.0
#
interface GigabitEthernet4/0/0
ip address 47.1.1.1 255.255.255.0
#
interface NULL0
#
interface LoopBack0
ip address 4.4.4.4 255.255.255.255
#
bgp 1
router-id 4.4.4.4
peer 2.2.2.2 as-number 1
peer 2.2.2.2 connect-interface LoopBack0
#
ipv4-family unicast
undo synchronization
peer 2.2.2.2 enable
#
ipv4-family vpnv4
policy vpn-target
peer 2.2.2.2 enable
#
ipv4-family vpn-instance a1
import-route ospf 2
#
ipv4-family vpn-instance b1
import-route direct
import-route static
#
ospf 1 router-id 4.4.4.4
area 0.0.0.0
network 4.4.4.4 0.0.0.0
network 34.1.1.2 0.0.0.0
#
ospf 2 router-id 4.4.4.4 vpn-instance a1
import-route bgp
area 0.0.0.0
network 192.168.3.2 0.0.0.0
#
ip route-static vpn-instance a1 192.168.4.0 255.255.255.0 192.168.3.1
ip route-static vpn-instance b1 192.168.4.0 255.255.255.0 192.168.3.1
R5
sysname R5
#
interface GigabitEthernet0/0/1
ip address 192.168.3.1 255.255.255.0
#
interface LoopBack0
ip address 192.168.4.1 255.255.255.0
#
ip route-static 192.168.1.0 255.255.255.0 192.168.3.2
ip route-static 192.168.2.0 255.255.255.0 192.168.3.2
R6
sysname R6
#
interface GigabitEthernet0/0/0
ip address 192.168.2.1 255.255.255.0
#
interface LoopBack0
ip address 192.168.1.1 255.255.255.0
#
rip 1
undo summary
version 2
network 192.168.1.0
network 192.168.2.0
R7
sysname R7
#
interface GigabitEthernet0/0/0
ip address 192.168.3.1 255.255.255.0
#
interface GigabitEthernet0/0/1
ip address 47.1.1.2 255.255.255.0
#
interface GigabitEthernet0/0/2
#
interface LoopBack0
ip address 192.168.4.2 255.255.255.0
#
ospf 1 router-id 7.7.7.7
area 0.0.0.0
network 192.168.3.1 0.0.0.0
network 192.168.4.2 0.0.0.0
#
ip route-static 0.0.0.0 0.0.0.0 192.168.3.2
边栏推荐
猜你喜欢
【Unity3D】GUI控件
[pointer training - eight questions]
1. Dynamic parameters of function: *args, **kwargs
Mysql database operation
[network security interview question] - how to penetrate the test file directory through
2022工作中遇到的问题四
Résumé des méthodes de reconnaissance des caractères ocr
【若依(ruoyi)】设置主题样式
Era5 reanalysis data download strategy
Deeply analyze the chain 2+1 mode, and subvert the traditional thinking of selling goods?
随机推荐
Erreur de la carte SD "erreur - 110 whilst initialisation de la carte SD
【RISC-V】外部中断
Installation and use tutorial of cobaltstrike-4.4-k8 modified version
不赚钱的科大讯飞,投资价值该怎么看?
resulttype和resultmap的区别和应用场景
Jenkins basic knowledge ----- detailed explanation of 03pipeline code
Descriptor implements ORM model
Distributed service framework dobbo
Tomb. Weekly update of Finance (February 7 - February 13)
codeforces每日5题(均1700)-第六天
Era5 reanalysis data download strategy
Custom attribute access__ getattribute__/ Settings__ setattr__/ Delete__ delattr__ method
Master data management theory and Practice
Microservice registration and discovery
Polymorphic day02
Atcoder beginer contest 233 (a~d) solution
2.13 simulation summary
Pat 1046 shortest distance (20 points) simulation
My C language learning records (blue bridge) -- files and file input and output
Performance analysis of user login TPS low and CPU full