当前位置:网站首页>Acwing 4300. Two operations
Acwing 4300. Two operations
2022-07-05 05:20:00 【hunziHang】
Given a positive integer n, We hope you can through a series of operations , Change it to another positive integer m.
There are two kinds of operations :
1. Multiply the current number by 2
2. Subtract... From the current number 1
requirement , During the transformation , The number is always positive .
Please calculate , The minimum number of operations required .
Input format :
a line , Two different positive integers n and m.
Output format :
An integer , Indicates the minimum number of operations required .
Data range :
front 6 Test points meet 1≤n,m≤10.
All test points meet 1≤n,m≤10000.
sample input 1:
4 6
sample output 1:
2
sample input 2:
10 1
sample output 2:
9
1. greedy
prove : When n>m when , And m For even when , be /2.
#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
const int N=1e6+100;
typedef pair<int,int> PII;
#define x first
#define y second
#define INF 0x3f3f3f3f
int dx[4]={-1,0,1,0};
int dy[4]={0,1,0,-1};
const int mod=1e9+7;
int n,m;
int cnt;
int main()
{
cin>>n>>m;
if(n>=m) cout<<n-m<<endl;
else // Back to
{
while(n<m) //n>=m It can be converted to the first two cases
{
if(m&1) m++; // If m It's odd , Can not /2,n*2 The number changed must be even .
else m/=2; // An even number is ok /2.
cnt++;
}
cout<<cnt+n-m<<endl; // Switch to the first two cases
}
return 0;
}
2. Search for Wide search
#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
const int N=20100;
typedef pair<int,int> PII;
#define x first
#define y second
#define INF 0x3f3f3f3f
int dx[4]={-1,0,1,0};
int dy[4]={0,1,0,-1};
const int mod=1e9+7;
int n,m;
int d[N],q[N];
int main()
{
cin>>n>>m;
int hh=0,tt=0;
memset(d,0x3f,sizeof d); // Initial array , Easy to update
d[n]=0; // Starting from 0.
q[0]=n; // The starting point joins the queue .
while(hh<=tt)
{
int t=q[hh++];
int change[]={t-1,t*2}; // Use an array to represent two operations , Convenient operation
for(auto i:change)
{
if(i>=1&i<N&&d[i]>d[t]+1) // 2*n<2*m Maximum enumeration to 2e4
{
d[i]=d[t]+1; // If the conditions are met, it will be updated
q[++tt]=i; // Join the queue
}
}
}
cout<<d[m]<<endl;
return 0;
}
边栏推荐
- Haut OJ 1347: addition of choice -- high progress addition
- Simple modal box
- YOLOv5添加注意力機制
- Haut OJ 1245: large factorial of CDs --- high precision factorial
- 2022/7/1學習總結
- [allocation problem] 135 Distribute candy
- Page countdown
- object serialization
- Ue4/ue5 illusory engine, material part (III), material optimization at different distances
- win10虚拟机集群优化方案
猜你喜欢
Improvement of pointnet++
UE fantasy engine, project structure
Applet Live + e - commerce, si vous voulez être un nouveau e - commerce de détail, utilisez - le!
YOLOv5添加注意力機制
To be continued] [UE4 notes] L4 object editing
win10虚拟机集群优化方案
Quick sort summary
十年不用一次的JVM调用
Pointnet++学习
Data is stored in the form of table
随机推荐
JVM call not used once in ten years
使用Room数据库报警告: Schema export directory is not provided to the annotation processor so we cannot expor
Bubble sort summary
lxml.etree.XMLSyntaxError: Opening and ending tag mismatch: meta line 6 and head, line 8, column 8
Download and use of font icons
Haut OJ 1357: lunch question (I) -- high precision multiplication
PMP candidates, please check the precautions for PMP examination in July
What is the agile proportion of PMP Exam? Dispel doubts
Embedded database development programming (zero)
Ue4/ue5 illusory engine, material part (III), material optimization at different distances
win10虚拟机集群优化方案
Find a good teaching video for Solon framework test (Solon, lightweight application development framework)
第六章 数据流建模—课后习题
[leetcode] integer inversion [7]
Development error notes
Use of snippets in vscode (code template)
[to be continued] [depth first search] 547 Number of provinces
Haut OJ 1347: addition of choice -- high progress addition
2022年上半年国家教师资格证考试
一个新的微型ORM开源框架