当前位置:网站首页>HZOJ #235. 递归实现指数型枚举
HZOJ #235. 递归实现指数型枚举
2022-07-07 10:36:00 【段舸】
题目:235. 递归实现指数型枚举
题目传送门:235题
题目描述
从 1−n1−n 这 nn 个整数中随机选取任意多个,每种方案里的数从小到大排列,按字典序输出所有可能的选择方案。
输入
输入一个整数 nn。(1≤n≤10)(1≤n≤10)
输出
每行一组方案,每组方案中两个数之间用空格分隔。
注意每行最后一个数后没有空格。
输入样例
3
样例输出
1
1 2
1 2 3
1 3
2
2 3
3
样例输入
4
样例输出
1
1 2
1 2 3
1 2 3 4
1 2 4
1 3
1 3 4
1 4
2
2 3
2 3 4
2 4
3
3 4
4
代码1
#include <iostream>
#include <stdio.h>
#include <stdlib.h>
using namespace std;
int n, num[15];
void print(int ind)
{
for (int i = 0; i <= ind; i++)
{
if (i) cout << " ";
cout << num[i];
}
cout << endl;
}
void func(int start, int ind)
{
for (int i = start; i <= n; i++)
{
num[ind] = i;
print(ind);
func(i + 1, ind + 1);
}
}
int main()
{
cin >> n;
func(1, 0);
return 0;
}
代码2
#include <iostream>
#include <stdio.h>
#include <stdlib.h>
using namespace std;
int n, num[15],cnt;
void print()
{
for (int i = 0; i <= cnt; i++)
{
if (i) cout << " ";
cout << num[i];
}
cout << endl;
}
void func(int start)
{
for (int i = start; i <= n; i++)
{
num[cnt] = i;
print();
cnt++;
func(i + 1);
cnt--;
}
}
int main()
{
cin >> n;
func(1);
return 0;
}
边栏推荐
- SQL injection -- Audit of PHP source code (take SQL lab 1~15 as an example) (super detailed)
- leetcode刷题:二叉树26(二叉搜索树中的插入操作)
- NPM instal reports agent or network problems
- Using stack to convert binary to decimal
- 普乐蛙小型5d电影设备|5d电影动感电影体验馆|VR景区影院设备
- Cookie
- DOM parsing XML error: content is not allowed in Prolog
- Cryptography series: detailed explanation of online certificate status protocol OCSP
- Tutorial on the principle and application of database system (008) -- exercises on database related concepts
- H3C HCl MPLS layer 2 dedicated line experiment
猜你喜欢
leetcode刷题:二叉树26(二叉搜索树中的插入操作)
idm服务器响应显示您没有权限下载解决教程
Dialogue with Wang Wenyu, co-founder of ppio: integrate edge computing resources and explore more audio and video service scenarios
Polymorphism, final, etc
2022聚合工艺考试题模拟考试题库及在线模拟考试
[statistical learning method] learning notes - support vector machine (Part 2)
Several methods of checking JS to judge empty objects
leetcode刷题:二叉树20(二叉搜索树中的搜索)
Airserver automatically receives multi screen projection or cross device projection
How to use PS link layer and shortcut keys, and how to do PS layer link
随机推荐
图形对象的创建与赋值
ENSP MPLS layer 3 dedicated line
牛客网刷题网址
Static routing assignment of network reachable and telent connections
Object. Simple implementation of assign()
Realize a simple version of array by yourself from
[疑难杂症]pip运行突然出现ModuleNotFoundError: No module named ‘pip‘
Common knowledge of one-dimensional array and two-dimensional array
【统计学习方法】学习笔记——支持向量机(下)
What is an esp/msr partition and how to create an esp/msr partition
【从 0 开始学微服务】【02】从单体应用走向服务化
How to use PS link layer and shortcut keys, and how to do PS layer link
Using stack to convert binary to decimal
leetcode刷题:二叉树23(二叉搜索树中的众数)
IPv6 experiment
DOM parsing XML error: content is not allowed in Prolog
ps链接图层的使用方法和快捷键,ps图层链接怎么做的
Ctfhub -web SSRF summary (excluding fastcgi and redI) super detailed
leetcode刷题:二叉树22(二叉搜索树的最小绝对差)
The left-hand side of an assignment expression may not be an optional property access. ts(2779)