当前位置:网站首页>电子协会 C语言 1级 34 、分段函数
电子协会 C语言 1级 34 、分段函数
2022-07-04 06:57:00 【dllglvzhenfeng】
电子协会 C语言 1级 34 、分段函数
C++代码:
/*
电子协会 C语言 1级 34 、分段函数
http://noi.openjudge.cn/ch0104/13/
编写程序,计算下列分段函数 y=f(x)的值。
y=-x+2.5; 0 <= x < 5
y=2-1.5(x-3)(x-3); 5 <= x < 10
y=x/2-1.5; 10 <= x < 20
输入
一个浮点数 N,0 <= N < 20
输出
输出 N 对应的分段函数值:f(N)。结果保留到小数点后三位。
样例输入
1.0
样例输出
1.500
*/
#include<iostream>
using namespace std;
int main()
{
double n,y;
cin>>n;
if(n>=0 && n<5)
{
y=-n+2.5;
}
else
{
if(n>=5 && n<10)
{
y=2-1.5*(n-3)*(n-3);
}
if(n>=10 && n<20)
{
y=n/2-1.5;
}
}
printf("%.3lf\n",y);
return 0;
}
python3代码:
n = float(input())
if 0 <= n < 5:
print('%.3f' % (2.5 - n))
elif n < 10:
print('%.3f' % (2 - 1.5*(n - 3)*(n - 3)))
elif n < 20:
print('%.3f' % (n/2 - 1.5))
【强基计划】数学与物理竞赛中的微积分部分视频
【强基计划】数学与物理竞赛中的微积分部分视频_dllglvzhenfeng的博客-CSDN博客
强基计划 数学相关书籍 推荐
强基计划 数学相关书籍 推荐_dllglvzhenfeng的博客-CSDN博客
NOC C++ 全国中小学信息技术创新与实践大赛(NOC):软件创意编程赛道
NOC C++ 全国中小学信息技术创新与实践大赛(NOC):软件创意编程赛道_dllglvzhenfeng的博客-CSDN博客_noc软件创意编程
02赛程安排:
报名时间:2022年1月-4月
选拔赛时间:2022年5月
全国决赛:2022年7月-8月(时间及地点另行通知)
2021年8月NOC全国中小学信息技术创新与实践大赛 软件创意编程小学高年级组Python决赛题解析
2021年8月NOC全国中小学信息技术创新与实践大赛 软件创意编程小学高年级组Python决赛题解析_与非学堂的博客-CSDN博客_noc python
2022年3月电子学会Python等级考试试卷(二级)答案解析
2022年3月电子学会Python等级考试试卷(二级)答案解析_A-别针少儿编程的博客-CSDN博客_中国电子学会python二级
边栏推荐
- Tar source code analysis 4
- Common usage of time library
- Vulhub vulnerability recurrence 76_ XXL-JOB
- 2022 wechat enterprise mailbox login entry introduction, how to open and register enterprise wechat enterprise mailbox?
- uniapp小程序分包
- leetcode825. 适龄的朋友
- Tar source code analysis 9
- 金盾视频播放器拦截的软件关键词和进程信息
- What is the sheji principle?
- 【MySQL】数据库视图的介绍、作用、创建、查看、删除和修改(附练习题)
猜你喜欢
2022 wechat enterprise mailbox login entry introduction, how to open and register enterprise wechat enterprise mailbox?
centos8安装mysql.7 无法开机启动
Selenium driver ie common problem solving message: currently focused window has been closed
selenium驱动IE常见问题解决Message: Currently focused window has been closed.
Set JTAG fuc invalid to normal IO port
regular expression
[GF (q) + LDPC] regular LDPC coding and decoding design and MATLAB simulation based on the GF (q) field of binary graph
Can the out of sequence message complete TCP three handshakes
关于IDEA如何设置快捷键集
用于压缩视频感知增强的多目标网络自适应时空融合
随机推荐
Modify TCP timestamp to optimize transmission performance
移动适配:vw/vh
How notepad++ counts words
Selection (021) - what is the output of the following code?
Vulhub vulnerability recurrence 77_ zabbix
【FPGA教程案例8】基于verilog的分频器设计与实现
tars源码分析之6
Introduction to spark core components
2022 wechat enterprise mailbox login entry introduction, how to open and register enterprise wechat enterprise mailbox?
What is Gibson's law?
leetcode825. Age appropriate friends
在已經知道錶格列勾選一個顯示一列
MySQL 45 lecture learning notes (XIV) count (*)
centos8安装mysql.7 无法开机启动
Flink memory model, network buffer, memory tuning, troubleshooting
leetcode825. 适龄的朋友
Boast about Devops
Campus network problems
Selenium driver ie common problem solving message: currently focused window has been closed
响应式移动Web测试题