当前位置:网站首页>Hdu-6025-prime sequence (girls' competition)
Hdu-6025-prime sequence (girls' competition)
2022-07-06 16:03:00 【It's Xiao Zhang, ZSY】
Coprime Sequence
Do you know what is called "Coprime Sequence’’? That is a sequence consists of nn positive integers, and the GCD (Greatest Common Divisor) of them is equal to 1."Coprime Sequence’’ is easy to find because of its restriction. But we can try to maximize the GCD of these integers by removing exactly one integer. Now given a sequence, please maximize the GCD of its elements.
Input
The first line of the input contains an integer T(1≤T≤10),
denoting the number of test cases.
In each test case, there is an integer n(3≤n≤100000) in the first line, denoting the number of integers in the sequence.
Then the following line consists of n integers
a1,a2,…,an (1<=ai<=1e9) denoting the elements in the sequence.
Output
For each test case, print a single line containing a single integer, denoting the maximum GCD.
Sample Input
3
3
1 1 1
5
2 2 2 3 2
4
1 2 4 8
Sample Output
1
2
2
#include <iostream>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <algorithm>
using namespace std;
int const N=1e5+10;
typedef long long ll;
int a[N],b[N],c[N];
int gcd(ll x,ll y)
{
return y==0?x:gcd(y,x%y);
}
int main()
{
int t;
scanf("%d",&t);
while(t--){
int n,ans=1;
scanf("%d",&n);
memset(a,0,sizeof(a));
memset(b,0,sizeof(b));
memset(c,0,sizeof(c));
for(int i=1;i<=n;i++)
{
scanf("%d",&a[i]);
}
sort(a+1,a+1+n);
b[1]=a[1];
c[n]=a[n];
for(int i=2;i<=n;i++)
{
b[i]=gcd(b[i-1],a[i]);// Prefix
}
for(int i=n-1;i>=1;i--)
{
c[i]=gcd(c[i+1],a[i]);// suffix
}
for(int i=1;i<=n;i++)
{
ans=max(ans,gcd(c[i+1],b[i-1]));
}// Every time you remove the i The greatest common divisor after the number
printf("%d\n",ans);
}
return 0;
}
边栏推荐
- CEP used by Flink
- 【练习-8】(Uva 246)10-20-30==模拟
- Analyse du format protobuf du rideau en temps réel et du rideau historique de la station B
- 信息安全-安全专业名称|CVE|RCE|POC|VUL|0DAY
- JS call camera
- [exercise-7] crossover answers
- [analysis of teacher Gao's software needs] collection of exercises and answers for level 20 cloud class
- [exercise -11] 4 values why sum is 0 (and 4 values of 0)
- 7-1 懂的都懂 (20 分)
- Find 3-friendly Integers
猜你喜欢
基于web的照片数码冲印网站
渗透测试 ( 2 ) --- 渗透测试系统、靶机、GoogleHacking、kali工具
[exercise-4] (UVA 11988) broken keyboard = = (linked list)
【练习-7】Crossword Answers
Analyse du format protobuf du rideau en temps réel et du rideau historique de la station B
动态规划前路径问题优化方式
MySQL import database error [err] 1273 - unknown collation: 'utf8mb4_ 0900_ ai_ ci’
Penetration test (1) -- necessary tools, navigation
信息安全-安全编排自动化与响应 (SOAR) 技术解析
X-forwarded-for details, how to get the client IP
随机推荐
frida hook so层、protobuf 数据解析
0-1 knapsack problem (I)
Ball Dropping
China potato slicer market trend report, technical dynamic innovation and market forecast
编程到底难在哪里?
Accounting regulations and professional ethics [3]
Information security - threat detection engine - common rule engine base performance comparison
VS2019初步使用
【练习-11】4 Values whose Sum is 0(和为0的4个值)
PySide6 信号、槽
Cost accounting [22]
X-Forwarded-For详解、如何获取到客户端IP
Information security - security professional name | CVE | rce | POC | Vul | 0day
【练习-4】(Uva 11988)Broken Keyboard(破损的键盘) ==(链表)
[exercise-2] (UVA 712) s-trees
0 - 1 problème de sac à dos (1)
F - Birthday Cake(山东省赛)
mysql导入数据库报错 [Err] 1273 – Unknown collation: ‘utf8mb4_0900_ai_ci’
Truck History
Nodejs+vue online fresh flower shop sales information system express+mysql