当前位置:网站首页>Truck History
Truck History
2022-07-06 09:25:00 【是小张张呀 zsy】
Truck History
Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vegetable delivery, other for furniture, or for bricks. The company has its own code describing each type of a truck. The code is simply a string of exactly seven lowercase letters (each letter on each position has a very special meaning but that is unimportant for this task). At the beginning of company’s history, just a single truck type was used but later other types were derived from it, then from the new types another types were derived, and so on.
Today, ACM is rich enough to pay historians to study its history. One thing historians tried to find out is so called derivation plan – i.e. how the truck types were derived. They defined the distance of truck types as the number of positions with different letters in truck type codes. They also assumed that each truck type was derived from exactly one other truck type (except for the first truck type which was not derived from any other type). The quality of a derivation plan was then defined as
1/Σ(to,td)d(to,td)
where the sum goes over all pairs of types in the derivation plan such that to is the original type and td the type derived from it and d(to,td) is the distance of the types.
Since historians failed, you are to write a program to help them. Given the codes of truck types, your program should find the highest possible quality of a derivation plan.
Input
The input consists of several test cases. Each test case begins with a line containing the number of truck types, N, 2 <= N <= 2 000. Each of the following N lines of input contains one truck type code (a string of seven lowercase letters). You may assume that the codes uniquely describe the trucks, i.e., no two of these N lines are the same. The input is terminated with zero at the place of number of truck types.
Output
For each test case, your program should output the text “The highest possible quality is 1/Q.”, where 1/Q is the quality of the best derivation plan.
Sample Input
4
aaaaaaa
baaaaaa
abaaaaa
aabaaaa
0
Sample Output
The highest possible quality is 1/3.还是一样的题,我最近做最短生成树都要吐了
题意:给出n个长度为7的字符串,每个字符串代表一个车,定义车的距离是两个字符串间不同字母的个数,题目要求的数不同的车的距离的最小值,即所求的就是最小生成树。
prim算法
换成了字符串,仅此而已,mmp
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<algorithm>
#include<iostream>
using namespace std;
#define INF 0x3f3f3f3f
int n,mp[2001][2001],dis[2001],f;
bool book[2001];
char c[2001][2001];
void prim()
{
memset(book,0,sizeof(book));
for(int i=1;i<=n;i++)
dis[i]=mp[1][i];
book[1]=1;
int ans=0;
for(int i=1;i<n;i++)
{
int minn=INF;
for(int j=1;j<=n;j++)
{
if(book[j]==0&&dis[j]<minn)
{
f=j;
minn=dis[j];
}
}
if(minn==INF)
break;
book[f]=1;
ans+=dis[f];
for(int j=1;j<=n;j++)
{
if(book[j]==0&&dis[j]>mp[f][j])
dis[j]=mp[f][j];
}
}
printf("The highest possible quality is 1/%d.\n",ans);
}
int main()
{
while(~scanf("%d",&n)&&n)
{
for(int i=1;i<=n;i++)
scanf("%s",c[i]);
for(int i=1;i<=n;i++)
{
for(int j=i+1;j<=n;j++)
{
int sum=0;
for(int k=0;k<7;k++)
{
if(c[i][k]!=c[j][k])
sum++;
}
mp[i][j]=mp[j][i]=sum;
}
}
prim();
}
return 0;
}
边栏推荐
- 用C语言写网页游戏
- Cost accounting [13]
- Learning records: serial communication and solutions to errors encountered
- CSAPP shell lab experiment report
- Research Report on market supply and demand and strategy of geosynthetics industry in China
- LeetCode#198. raid homes and plunder houses
- Perinatal Software Industry Research Report - market status analysis and development prospect forecast
- Research Report of pharmaceutical solvent industry - market status analysis and development prospect prediction
- Learning record: STM32F103 clock system overview working principle
- 0 - 1 problème de sac à dos (1)
猜你喜欢
随机推荐
入门C语言基础问答
Accounting regulations and professional ethics [4]
差分(一维,二维,三维) 蓝桥杯三体攻击
C4D quick start tutorial - Introduction to software interface
Research Report on market supply and demand and strategy of China's land incineration plant industry
Indonesian medical sensor Industry Research Report - market status analysis and development prospect forecast
C语言数组的概念
LeetCode#2062. Count vowel substrings in strings
E. Breaking the Wall
LeetCode#204. Count prime
基于485总线的评分系统
cs零基础入门学习记录
Es6--- two methods of capturing promise status as failed
Stm32 dossiers d'apprentissage: saisie des applications
UCORE Lab 1 system software startup process
Crawling cat's eye movie review, data visualization analysis source code operation instructions
STM32 learning record: input capture application
LeetCode#36. Effective Sudoku
Automated testing problems you must understand, boutique summary
Leetcode notes - dynamic planning -day7