当前位置:网站首页>Hangzhou Electric 3711 binary number
Hangzhou Electric 3711 binary number
2022-07-07 04:06:00 【Full stack programmer webmaster】
Hello everyone , I meet you again , I'm the king of the whole stack
Binary Number
Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others) Total Submission(s): 1287 Accepted Submission(s): 807
Problem Description
For 2 non-negative integers x and y, f(x, y) is defined as the number of different bits in the binary format of x and y. For example, f(2, 3)=1,f(0, 3)=2, f(5, 10)=4. Now given 2 sets of non-negative integers A and B, for each integer b in B, you should find an integer a in A such that f(a, b) is minimized. If there are more than one such integer in set A, choose the smallest one.
Input
The first line of the input is an integer T (0 < T ≤ 100), indicating the number of test cases. The first line of each test case contains 2 positive integers m and n (0 < m, n ≤ 100), indicating the numbers of integers of the 2 sets A and B, respectively. Then follow (m + n) lines, each of which contains a non-negative integers no larger than 1000000. The first m lines are the integers in set A and the other n lines are the integers in set B.
Output
For each test case you should output n lines, each of which contains the result for each query in a single line.
Sample Input
2
2 5
1
2
1
2
3
4
5
5 2
1000000
9999
1423
3421
0
13245
353
Sample Output
1
2
1
1
1
9999
0
AC The code is as follows :
#include <stdio.h>
int a[105];
int count(int x)
{
int c = 0;
for(;x;x>>=1) if(x&1) c++;
return c;
}
int main()
{
int b, i, j, n, m, k, min, t,cases;
scanf("%d",&cases);
while(cases--)
{
scanf("%d%d",&n,&m);
for(i=0; i<n; i++) scanf("%d",&a[i]);
for(i=0; i<m; i++)
{
scanf("%d",&b);
min = count(b^a[0]);
k = 0;
for(j=1; j<n; j++)
{
t = count(b^a[j]);
if(t<min||t==min&&a[j]<a[k])
{ min = t;k = j;}
}
printf("%d\n",a[k]);
}
}
return 0;
}
Publisher : Full stack programmer stack length , Reprint please indicate the source :https://javaforall.cn/116703.html Link to the original text :https://javaforall.cn
边栏推荐
猜你喜欢
What is Ba? How about Ba? What is the relationship between Ba and Bi?
opencv第三方库
Analysis on urban transportation ideas of 2022 Zhongqing cup C
2022 electrician cup question B analysis of emergency materials distribution under 5g network environment
Arduino droplet detection
[MySQL] row sorting in MySQL
Redis configuration and optimization of NoSQL
Leetcode: interview question 17.24 Maximum cumulative sum of submatrix (to be studied)
Kotlin Android environment construction
ggplot 分面的细节调整汇总
随机推荐
OSCP工具之一: dirsearch用法大全
使用 Dumpling 备份 TiDB 集群数据到 GCS
Arduino droplet detection
Tflite model transformation and quantification
List interview common questions
C task expansion method
杭州电 3711 Binary Number
机器人(自动化)课程的持续学习-2022-
Codeworks 5 questions per day (1700 average) - day 7
map和set的实现
Quick completion guide of manipulator (10): accessible workspace
2022 electrician cup a question high proportion wind power system energy storage operation and configuration analysis ideas
Implementation steps of docker deploying mysql8
手机号国际区号JSON格式另附PHP获取
数据的存储
Confirm the future development route! Digital economy, digital transformation, data This meeting is very important
How to manage the expiration of enterprise distribution certificates- How to manage Enterprise Distribution certificate expiration?
维护万星开源向量数据库是什么体验
The true face of function pointer in single chip microcomputer and the operation of callback function
ERROR: Could not build wheels for pycocotools which use PEP 517 and cannot be installed directly