当前位置:网站首页>Hangzhou Electric 3711 binary number
Hangzhou Electric 3711 binary number
2022-07-07 04:06:00 【Full stack programmer webmaster】
Hello everyone , I meet you again , I'm the king of the whole stack
Binary Number
Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others) Total Submission(s): 1287 Accepted Submission(s): 807
Problem Description
For 2 non-negative integers x and y, f(x, y) is defined as the number of different bits in the binary format of x and y. For example, f(2, 3)=1,f(0, 3)=2, f(5, 10)=4. Now given 2 sets of non-negative integers A and B, for each integer b in B, you should find an integer a in A such that f(a, b) is minimized. If there are more than one such integer in set A, choose the smallest one.
Input
The first line of the input is an integer T (0 < T ≤ 100), indicating the number of test cases. The first line of each test case contains 2 positive integers m and n (0 < m, n ≤ 100), indicating the numbers of integers of the 2 sets A and B, respectively. Then follow (m + n) lines, each of which contains a non-negative integers no larger than 1000000. The first m lines are the integers in set A and the other n lines are the integers in set B.
Output
For each test case you should output n lines, each of which contains the result for each query in a single line.
Sample Input
2
2 5
1
2
1
2
3
4
5
5 2
1000000
9999
1423
3421
0
13245
353
Sample Output
1
2
1
1
1
9999
0
AC The code is as follows :
#include <stdio.h>
int a[105];
int count(int x)
{
int c = 0;
for(;x;x>>=1) if(x&1) c++;
return c;
}
int main()
{
int b, i, j, n, m, k, min, t,cases;
scanf("%d",&cases);
while(cases--)
{
scanf("%d%d",&n,&m);
for(i=0; i<n; i++) scanf("%d",&a[i]);
for(i=0; i<m; i++)
{
scanf("%d",&b);
min = count(b^a[0]);
k = 0;
for(j=1; j<n; j++)
{
t = count(b^a[j]);
if(t<min||t==min&&a[j]<a[k])
{ min = t;k = j;}
}
printf("%d\n",a[k]);
}
}
return 0;
}
Publisher : Full stack programmer stack length , Reprint please indicate the source :https://javaforall.cn/116703.html Link to the original text :https://javaforall.cn
边栏推荐
- 【knife-4j 快速搭建swagger】
- 二进制、八进制、十六进制
- 【mysql】mysql中行排序
- golang 根据生日计算星座和属相
- UltraEdit-32 温馨提示:右协会,取消 bak文件[通俗易懂]
- Antd Comment 递归循环评论
- 史上最全学习率调整策略lr_scheduler
- When QT uses qtooltip mouse to display text, the picture of the button will also be displayed and the prompt text style will be modified
- Use facet to record operation log
- 史上最全MongoDB之安全认证
猜你喜欢
超越Postman,新一代国产调试工具Apifox,用起来够优雅
机器学习笔记 - 使用机器学习进行鸟类物种分类
What is the experience of maintaining Wanxing open source vector database
Arduino droplet detection
ABAP 動態內錶分組循環
Gpt-3 is a peer review online when it has been submitted for its own research
GPT-3当一作自己研究自己,已投稿,在线蹲一个同行评议
2022 electrician cup question B analysis of emergency materials distribution under 5g network environment
[development software] tilipa Developer Software
链表面试常见题
随机推荐
二进制、八进制、十六进制
SQL injection -day15
复杂因子计算优化案例:深度不平衡、买卖压力指标、波动率计算
The most complete security certification of mongodb in history
Antd Comment 递归循环评论
API data interface of A-share index component data
史上最全MongoDB之Mongo Shell使用
Collection of idea gradle Lombok errors
tflite模型转换和量化
The JSON format of the international area code of the mobile phone number is obtained with PHP
Kotlin Android 环境搭建
Storage of data
Tflite model transformation and quantification
史上最全MongoDB之初识篇
使用 BR 恢复 GCS 上的备份数据
Redis source code learning (31), dictionary learning, dict.c (1)
vim —- 自己主动的按钮indent该命令「建议收藏」
The first introduction of the most complete mongodb in history
Adaptive non European advertising retrieval system amcad
Triple half circle progress bar, you can use it directly