当前位置:网站首页>POJ - 3616 Milking Time(DP+LIS)
POJ - 3616 Milking Time(DP+LIS)
2022-07-07 08:31:00 【WA_ automata】
POJ - 3616 Milking Time
Description
Bessie is such a hard-working cow. In fact, she is so focused on maximizing her productivity that she decides to schedule her next N (1 ≤ N ≤ 1,000,000) hours (conveniently labeled 0…N-1) so that she produces as much milk as possible.
Farmer John has a list of M (1 ≤ M ≤ 1,000) possibly overlapping intervals in which he is available for milking. Each interval i has a starting hour (0 ≤ starting_houri ≤ N), an ending hour (starting_houri < ending_houri ≤ N), and a corresponding efficiency (1 ≤ efficiencyi ≤ 1,000,000) which indicates how many gallons of milk that he can get out of Bessie in that interval. Farmer John starts and stops milking at the beginning of the starting hour and ending hour, respectively. When being milked, Bessie must be milked through an entire interval.
Even Bessie has her limitations, though. After being milked during any interval, she must rest R (1 ≤ R ≤ N) hours before she can start milking again. Given Farmer Johns list of intervals, determine the maximum amount of milk that Bessie can produce in the N hours.
Input
- Line 1: Three space-separated integers: N, M, and R
- Lines 2…M+1: Line i+1 describes FJ’s ith milking interval withthree space-separated integers: starting_houri , ending_houri , and efficiencyi
Output
- Line 1: The maximum number of gallons of milk that Bessie can product in the N hours
Sample Input
12 4 2
1 2 8
10 12 19
3 6 24
7 10 31
Sample Output
43
The cow is in n Milk production in time , Farmers have m You can milk for a while , Every period of time has a starting point strat, The end point end, And the milking volume during this period w. After each milking , Cows must rest r Time . Ask how much milk you can get under the most reasonable milking arrangement ?
First, sort the interval according to the end time , Then according to the i Whether to choose or not to carry out dynamic planning
#include<iostream>
#include<algorithm>
using namespace std;
const int N = 1010;
struct Node
{
int l,r,val;
}a[N];
int dp[N];
bool cmp(Node A,Node B)
{
return A.r<B.r;
}
int main()
{
int n,m,r;cin>>n>>m>>r;
for(int i=1;i<=m;i++)
{
cin>>a[i].l>>a[i].r>>a[i].val;
a[i].r+=r;
}
sort(a+1,a+m+1,cmp);
for(int i=1;i<=m;i++)
{
dp[i]=a[i].val;
for(int j=1;j<i;j++)
if(a[j].r<=a[i].l)
dp[i]=max(dp[i],dp[j]+a[i].val);
}
int ans=0;
for(int i=1;i<=m;i++)
ans=max(ans,dp[i]);
cout<<ans<<endl;
return 0;
}
边栏推荐
- eBPF Cilium实战(1) - 基于团队的网络隔离
- Zcmu--1492: problem d (C language)
- 探索STEAM艺术设计中的创造力
- Analysis of maker education in innovative education system
- Using helm to install rainbow in various kubernetes
- CCTV is so warm-hearted that it teaches you to write HR's favorite resume hand in hand
- 发挥创客教育空间的广泛实用性
- Application of slip ring of shipborne radar antenna
- Interface as a parameter (interface callback)
- Full text query classification
猜你喜欢
随机推荐
Battery and motor technology have received great attention, but electric control technology is rarely mentioned?
Bisenet features
单元测试报告成功率低
Use of out covariance and in inversion in kotlin
归并排序和非比较排序
Vulnerability recurrence easy_ tornado
Automatic upgrading of database structure in rainbow
MES system is a necessary choice for enterprise production
opencv学习笔记四——膨胀/腐蚀/开运算/闭运算
POJ - 3784 Running Median(对顶堆)
Four items that should be included in the management system of integral mall
Opencv learning note 3 - image smoothing / denoising
2-3 lookup tree
Basic use of CTF web shrink template injection nmap
[paper reading] icml2020: can autonomous vehicles identify, recover from, and adapt to distribution shifts?
PLSQL的安装和配置
[quick start of Digital IC Verification] 14. Basic syntax of SystemVerilog learning 1 (array, queue, structure, enumeration, string... Including practical exercises)
MySQL introduction - crud Foundation (establishment of the prototype of the idea of adding, deleting, changing and searching)
国标GB28181协议视频平台EasyGBS新增拉流超时配置
eBPF Cilium实战(1) - 基于团队的网络隔离