当前位置:网站首页>POJ - 3616 Milking Time(DP+LIS)
POJ - 3616 Milking Time(DP+LIS)
2022-07-07 08:31:00 【WA_ automata】
POJ - 3616 Milking Time
Description
Bessie is such a hard-working cow. In fact, she is so focused on maximizing her productivity that she decides to schedule her next N (1 ≤ N ≤ 1,000,000) hours (conveniently labeled 0…N-1) so that she produces as much milk as possible.
Farmer John has a list of M (1 ≤ M ≤ 1,000) possibly overlapping intervals in which he is available for milking. Each interval i has a starting hour (0 ≤ starting_houri ≤ N), an ending hour (starting_houri < ending_houri ≤ N), and a corresponding efficiency (1 ≤ efficiencyi ≤ 1,000,000) which indicates how many gallons of milk that he can get out of Bessie in that interval. Farmer John starts and stops milking at the beginning of the starting hour and ending hour, respectively. When being milked, Bessie must be milked through an entire interval.
Even Bessie has her limitations, though. After being milked during any interval, she must rest R (1 ≤ R ≤ N) hours before she can start milking again. Given Farmer Johns list of intervals, determine the maximum amount of milk that Bessie can produce in the N hours.
Input
- Line 1: Three space-separated integers: N, M, and R
- Lines 2…M+1: Line i+1 describes FJ’s ith milking interval withthree space-separated integers: starting_houri , ending_houri , and efficiencyi
Output
- Line 1: The maximum number of gallons of milk that Bessie can product in the N hours
Sample Input
12 4 2
1 2 8
10 12 19
3 6 24
7 10 31
Sample Output
43
The cow is in n Milk production in time , Farmers have m You can milk for a while , Every period of time has a starting point strat, The end point end, And the milking volume during this period w. After each milking , Cows must rest r Time . Ask how much milk you can get under the most reasonable milking arrangement ?
First, sort the interval according to the end time , Then according to the i Whether to choose or not to carry out dynamic planning
#include<iostream>
#include<algorithm>
using namespace std;
const int N = 1010;
struct Node
{
int l,r,val;
}a[N];
int dp[N];
bool cmp(Node A,Node B)
{
return A.r<B.r;
}
int main()
{
int n,m,r;cin>>n>>m>>r;
for(int i=1;i<=m;i++)
{
cin>>a[i].l>>a[i].r>>a[i].val;
a[i].r+=r;
}
sort(a+1,a+m+1,cmp);
for(int i=1;i<=m;i++)
{
dp[i]=a[i].val;
for(int j=1;j<i;j++)
if(a[j].r<=a[i].l)
dp[i]=max(dp[i],dp[j]+a[i].val);
}
int ans=0;
for(int i=1;i<=m;i++)
ans=max(ans,dp[i]);
cout<<ans<<endl;
return 0;
}
边栏推荐
- Improve the delivery efficiency of enterprise products (1) -- one click installation and upgrade of enterprise applications
- National standard gb28181 protocol video platform easygbs adds streaming timeout configuration
- Practice of implementing cloud native Devops based on rainbow library app
- Virtual address space
- Caractéristiques de bisenet
- SSM 整合
- POJ - 3784 Running Median(对顶堆)
- Open3d ISS key points
- 利用 Helm 在各类 Kubernetes 中安装 Rainbond
- Open3D ISS关键点
猜你喜欢
The single value view in Splunk uses to replace numeric values with text
Iptables' state module (FTP service exercise)
Explore creativity in steam art design
[quick start of Digital IC Verification] 13. SystemVerilog interface and program learning
打通法律服务群众“最后一公里”,方正璞华劳动人事法律自助咨询服务平台频获“点赞”
[hard core science popularization] working principle of dynamic loop monitoring system
Xcit learning notes
在Rainbond中一键部署高可用 EMQX 集群
解析机器人科技发展观对社会研究论
Implement your own dataset using bisenet
随机推荐
Opencv learning notes II - basic image operations
Openvscode cloud ide joins rainbow integrated development system
GFS distributed file system
打通法律服务群众“最后一公里”,方正璞华劳动人事法律自助咨询服务平台频获“点赞”
Splunk子查询模糊匹配csv中字段值为*
AVL平衡二叉搜索树
opencv学习笔记三——图像平滑/去噪处理
[kuangbin]专题十五 数位DP
GOLand idea intellij 无法输入汉字
【Go ~ 0到1 】 第七天 获取时间戳,时间比较,时间格式转换,Sleep与定时器
National standard gb28181 protocol video platform easygbs adds streaming timeout configuration
Kotlin combines flatmap for filtering and zip merge operators
POJ - 3616 Milking Time(DP+LIS)
Give full play to the wide practicality of maker education space
Ebpf cilium practice (2) - underlying network observability
How to understand distributed architecture and micro service architecture
Xcit learning notes
XCiT学习笔记
在Rainbond中实现数据库结构自动化升级
2-3查找樹