当前位置:网站首页>小L的试卷
小L的试卷
2022-07-06 09:14:00 【极客云曦】
题目描述
小L期末考试结束,高高兴兴放假回家了,可是那么多试卷,老师还要加班批改,有n份试卷由k个老师批改,n份试卷进行了密封编号,由于试卷上的做题情况和书写的规范程序不一样,批改不同的试卷用时也可能不一样,每个老师批改试卷的编号顺序是连续的,每位老师批改完分配给自己的试卷就可以离开,问最后离开的老师,最短可能的用时是多少,假定一份试卷让任何一位老师批改用时都是一样的。现在请你设计一种分配方案,使得最后离开的老师用时最短。
输入
第一行两个整数n,k;(0<k≤n≤1000)
第二行n个整数,第i个整数表示批改第i份试卷的用时。
输出
输出一个整数,表示最后离开的老师所用的最短时间
样例输入 Copy
9 3
1 2 3 4 5 6 7 8 9
样例输出 Copy
17
#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
const ll inf = 0x3f3f3f3f;
const int maxn = 1e5 + 10;
int n , k;
ll a[maxn];
bool isok(int x)
{
bool flag = false;
int num = 0;
ll temp = 0;
for (int i=1; i<=n; i++)
{
if (a[i] > x) return false;
temp += a[i];
if (temp > x)
{
num ++;
temp = a[i];
}
}
if (temp > 0) num ++;
if (num <= k) return true;
else return false;
}
int main()
{
scanf("%d%d", &n, &k);
for (int i=1; i<=n; i++) scanf("%lld", &a[i]);
ll l = 0 , r = inf;
while (l <= r)
{
int mid = (l + r) / 2;
if (isok(mid)) r = mid-1;
else l = mid + 1;
}
cout << l << endl;
return 0;
}
边栏推荐
- Classes in C #
- TCP/IP协议(UDP)
- L2-001 紧急救援 (25 分)
- Install mongdb tutorial and redis tutorial under Windows
- Case analysis of data inconsistency caused by Pt OSC table change
- Double to int precision loss
- 图像识别问题 — pytesseract.TesseractNotFoundError: tesseract is not installed or it‘s not in your path
- nodejs 详解
- [free setup] asp Net online course selection system design and Implementation (source code +lunwen)
- Kept VRRP script, preemptive delay, VIP unicast details
猜你喜欢
MySQL and C language connection (vs2019 version)
How to configure flymcu (STM32 serial port download software) is shown in super detail
Cookie setting three-day secret free login (run tutorial)
Leetcode 461 Hamming distance
Kept VRRP script, preemptive delay, VIP unicast details
引入了junit为什么还是用不了@Test注解
vs2019 第一个MFC应用程序
保姆级出题教程
Vs2019 first MFC Application
机器学习笔记-Week02-卷积神经网络
随机推荐
Ansible practical series I_ introduction
Double to int precision loss
error C4996: ‘strcpy‘: This function or variable may be unsafe. Consider using strcpy_s instead
库函数--(持续更新)
ES6 promise object
PHP - whether the setting error displays -php xxx When PHP executes, there is no code exception prompt
Armv8-a programming guide MMU (2)
LeetCode #461 汉明距离
QT creator runs the Valgrind tool on external applications
软件测试与质量学习笔记3--白盒测试
打开浏览器的同时会在主页外同时打开芒果TV,抖音等网站
[NPUCTF2020]ReadlezPHP
Leetcode 461 Hamming distance
QT creator support platform
连接MySQL数据库出现错误:2059 - authentication plugin ‘caching_sha2_password‘的解决方法
Did you forget to register or load this tag
JDBC原理
[蓝桥杯2017初赛]包子凑数
JDBC principle
What does usart1 mean